Differences between revisions 1 and 2
Revision 1 as of 2014-06-21 08:47:24
Size: 11678
Editor: Kron
Comment: Russian translation
Revision 2 as of 2015-11-16 13:15:04
Size: 18331
Editor: Alex
Comment: sync with English master
Deletions are marked like this. Additions are marked like this.
Line 22: Line 22:
<<TableOfContents(2)>> <<TableOfContents(3)>>
Line 25: Line 25:
Line 29: Line 28:



<<Anchor(On_Debian_9)>>
<<Anchor(Debian testing "Stretch")>>
== Debian 9 "Stretch" ==
(Смотрите [[https://wiki.debian.org/ru/skype#Debian_7_.22Wheezy.22|Debian 7 "Wheezy"]])

<<Anchor(On_Debian_8.0)>>
<<Anchor(Debian 8.0 "Jessie")>>
== Debian 8 "Jessie" ==
(Смотрите [[https://wiki.debian.org/ru/skype#Debian_7_.22Wheezy.22|Debian 7 "Wheezy"]])


=== Часто задаваемые вопросы (F.A.Q.) по Jessie 64-бит ===
'''Вопрос:''' Инструкции по инсталяции для Wheezy не работают для Jessie?

'''Answer:''' Попробуйте ввести следующие команды
{{{
sudo dpkg --add-architecture i386
sudo aptitude update
sudo aptitude install libc6:i386 libqt4-dbus:i386 libqt4-network:i386 libqt4-xml:i386 libqtcore4:i386 libqtgui4:i386 libqtwebkit4:i386 libstdc++6:i386 libx11-6:i386 libxext6:i386 libxss1:i386 libxv1:i386 libssl1.0.0:i386 libpulse0:i386 libasound2-plugins:i386
wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
sudo dpkg -i skype-install.deb
}}}

'''Вопрос:''' Почему Skype не исользует мой системный курсор?

'''Ответ:''' Установите 32-бит версию пакета libxcursor1:
{{{
# apt-get install libxcursor1:i386
}}}
Line 33: Line 64:
Line 35: Line 65:

Пакет i386 хорошо работает со стандартной системой Debian 7 i386. Для установки, введите следующую команду в терминал:
Пакет i386 хорошо работает со стандартной системой Debian 7 i386. Для установки Skype используйте один из двух предоставленных методов:

'''1 метод''': Используя [[https://packages.debian.org/wheezy/gdebi|GDebi]]

Введите данные команды в терминал:
{{{
# apt-get install gdebi
# wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
# gdebi skype-install.deb
}}}

GDebi автоматически заинсталирует все нужные зависимости.

## To fix missing dependencies run:

## {{{
### apt-get -f install
###}}}



'''2 метод''': Не используя GDebi

Этот метод считается альтернативным и более предназначен для тех кто использует KDE и нехочет инсталлировать зависимости нужные для GDebi.

Введите данные команды в терминал:
Line 42: Line 97:
Если потребуется, установите требуемые зависимости следующей командой: Для установки требуемых зависимостей используйте следующую команду:
Line 48: Line 104:
Line 50: Line 105:
Примечания
Line 55: Line 109:
'''1 метод''': Используя [[https://packages.debian.org/wheezy/gdebi|GDebi]]
Line 56: Line 112:
Line 62: Line 119:

{{{
# apt-get install gdebi
# wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
# gdebi skype-install.deb
}}}

Некоторые i386 пакеты будут установлены.

Готово, Skype установлен. Наслаждайтесь.

'''2 метод''': Не используя GDebi

Этот метод считается альтернативным и более предназначен для тех кто использует KDE и нехочет инсталлировать зависимости нужные для GDebi.

Для начала вы должны [[Multiarch/HOWTO|включить Multi-Arch]], введя следующую команду в терминал:

{{{
# dpkg --add-architecture i386
# apt-get update
}}}

Далее введите данные команды в терминал:
Line 67: Line 148:
Если потребуется, установите требуемые зависимости следующей командой: Для установки требуемых зависимостей используйте следующую команду:
Line 71: Line 153:
Некоторые i386 пакеты будут установлены.

Готово, Skype установлен. Наслаждайтесь.

Примечания

 * Если вы используете Gnome 3, для доступа в меню Skype, переместите курсор мыши в правую нижнюю часть экрана, потом кликните правой кнопкой мыши на иконку Skype

=== Часто задаваемые вопросы (F.A.Q.) по 64-бит ===

==== Вопрос: Skype не запускается, когда я нажимаю на Skype Launcher? Аналогчино и с помощью терминала, он возвращает ошибку "symbol lookup error" ====

Ответ: Используя терминал, введите следующую команду для запуска Skype


{{{{#!wiki note
Если вы используете Gnome 3, для доступа в меню Skype, переместите курсор мыши в правую нижнюю часть экрана, потом кликните правой кнопкой мыши на иконку Skype
}}}}

=== Проблема с запуском Skype ===
Когда вы запускате Skype, который является 32-битной программой, в 64-бит системе вам может выскочить данная ошибка:
{{{
skype: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory
}}}
Эта ошибка появляласть только в 64-битных системах. Данная командна исправит её:
{{{
# ln -s /usr/lib/mesa-diverted/i386-linux-gnu/libGL.so.1 /usr/lib/i386-linux-gnu/
}}}

=== Часто задаваемые вопросы (F.A.Q.) по Wheezy 64-бит ===
'''Вопрос:''' Почему Skype выдает ошибку то, что он не может подключиться к серверу?<<BR>>
'''Ответ:''' Обновите ваш Skype до версии 4.3 вышедшую в мае 2014 года.
Ошибка вызывается сервером аутентификации Skype и тем самым заставляет пользователей Linux обновится до версии 4.3. [[http://www.linuxquestions.org/questions/linux-software-2/skype-can%27t-connect-4175513174/#post5214188|Спасибо Clived за это решение :)]]. Старые версии Skype работали до конца июля 2014 года, но более сервер не позволяет им подсоединится.
------
'''Вопрос:''' Почему я не могу использовать веб-камеру?<<BR>>
'''Ответ:''' Скорее всего вам надо загрузить v4l совместимость.

Попробуйте это:
{{{
LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so /usr/bin/skype
}}}

К тому-же '''Включить Skype Видео''' должно быть включено иначе Skype никогда не найдет вашу камеру (с версии 4.3).

Чтобы включить Skype видеo зайдите в Skype->Опции->Видео устройства->Включить Skype видео и перезапустите Skype.

Если у вас 64-бит система, то вам нужно 32-бит версию libv4l-0:
{{{
# apt-get install libv4l-0:i386
}}}

------

'''Вопрос:''' Почему Skype не запускается, когда я нажимаю на Skype Launcher? Аналогчино и с помощью терминала, он возвращает ошибку "symbol lookup error"<<BR>>
'''Ответ:''' Используя терминал, введите следующую команду для запуска Skype:
Line 89: Line 200:
Примечания {{{{#!wiki note
Line 98: Line 209:

--------------

====
Вопрос: Не удалось установить libqtwebkit4:i386 ? ====

Ответ: Если apt-get не удалось установить libqtwebkit4:i386 как зависимость, попробуйте использовать aptitude (если вы знаете, что вы делаете)
}}}}
------

'''
Вопрос:''' Почему я не могу установить libqtwebkit4:i386?<<BR>>
'''
Ответ:''' Если apt-get не удалось установить libqtwebkit4:i386 как зависимость, попробуйте использовать aptitude (если вы знаете, что вы делаете)
Line 107: Line 217:
Depends: libstdc++6 (>= 4.1.1-21), libasound2 (>> 1.0.14), libc6 (>= 2.13-1), libgcc1 (>= 1:4.1.1-21)     --------------

====
Вопрос: Проблемы со звуком ? ====

Ответ: Если у вас есть проблемы со звуком
, у вас может отсутствовать libpulse.
Depends: libstdc++6 (>= 4.1.1-21), libasound2 (>> 1.0.14), libc6 (>= 2.13-1), libgcc1 (>= 1:4.1.1-21)
------

'''
Вопрос:''' Почему в Skype нету звука?<<BR>>
'''Ответ:''' Если у вас есть п
роблемы со звуком, у вас может отсутствовать libpulse.
Line 123: Line 230:
1) PULSE_LATENCY_MSEC переменная (из [[http://community.skype.com/t5/Linux/Sound-in-Debian-unstable-64bit-broken/m-p/1725622/highlight/true#M7763|skype forum]]):
{{{
$ PULSE_LATENCY_MSEC=30 skype 
1) PULSE_LATENCY_MSEC variable environment trick from the [[http://community.skype.com/t5/Linux/Sound-in-Debian-unstable-64bit-broken/m-p/1725622/highlight/true#M7763| Skype forum]]:
{{{
$ PULSE_LATENCY_MSEC=30 skype
Line 137: Line 244:



------
Line 144: Line 248:
Line 162: Line 265:

= Обновление Skype =

Просто [[https://wiki.debian.org/ru/skype#A.2BBCMEQQRCBDAEPQQ.2BBDIEOgQw_Skype|установите]] новую Skype версию

== Часто задаваемые вопросы (F.A.Q.) по Skype ==
'''Вопрос:''' Я пытался обновить Skype [[https://wiki.debian.org/ru/skype#A.2BBCMEQQRCBDAEPQQ.2BBDIEOgQw_Skype|установив]] новую Skype версию. Почему Skype всё равно не работает?

'''Ответ:''' Перед тем как предпринимать следующие действия сделайте резервную копию Skype даты.
Вы можете попробовать удалит .skype директорию перед тем как запускать обновленный Skype. В .skype директории хранится вся ваша личная информация и настройки. Если вы успешно запустили обновленный Skype, то первое что вы увидите при запуске это лицензионное соглашение.
Чтобы увидеть .skype директорию нажмите Ctrl + H (Gnome) или Alt + . (KDE).

Line 163: Line 279:
Line 165: Line 280:
Line 170: Line 284:
# lintian -v skype-debian_4.0.0.7-1_i386.deb  # lintian -v skype-debian_4.0.0.7-1_i386.deb
Line 186: Line 300:
{{{{#!wiki note
Line 187: Line 302:
}}}}

Translation(s): English - Français - 简体中文 - Русский


Владелец:

skype.com

Лицензия:

non-free
(copyright.txt)

X-(

Качество:

Рассматриваемая версия: 4.2.0.11-1

Бинарный файл:

неподписанный

X-(

Исходный код:

недоступен

X-(

Lintian:

мало ошибок

(./)

Control scripts

нет

(./)

Языки:

es pl zh_t ja no pt_br fr cs ro lv lt pt_pt et ko bg uk ru en zh_s th de it tr

(./)

Архитектуры:

i386, amd64

-

Легенда: (./) = Хорошо ; X-( = Плохо

Skype является non-free (проприетарным) программным обеспечением. Он также имеет закрытый исходный код, которым владеет корпорация, и не поддерживается Debian. Рассматривали ли вы возможность использовать бесплатную альтернативу с открытым исходным кодом, поддерживаемую Debian, такую как VoIP клиенты ekiga, linphone, или jitsi ?

Установка Skype

Skype доступен для архитектур amd64 и i386 для Debian 5 и новее. Вообще, последние версии пакетов могут быть найдены на веб-сайте Skype

<!> Обратите внимание, в данный момент нет репозиториев, которые содержат последнюю версию Skype. Каждый раз, когда Skype будет обновляться, вам придется вручную качать новую версию с веб-сайта Skype. Поскольку apt-get (и aptitude) не сможет оповещать вас об обновлениях, вы можете включить опцию "Проверять обновления при запуске" во вкладке "Дополнительно", в настройках Skype.

Debian 9 "Stretch"

(Смотрите Debian 7 "Wheezy")

Debian 8 "Jessie"

(Смотрите Debian 7 "Wheezy")

Часто задаваемые вопросы (F.A.Q.) по Jessie 64-бит

Вопрос: Инструкции по инсталяции для Wheezy не работают для Jessie?

Answer: Попробуйте ввести следующие команды

sudo dpkg --add-architecture i386
sudo aptitude update
sudo aptitude install libc6:i386 libqt4-dbus:i386 libqt4-network:i386 libqt4-xml:i386 libqtcore4:i386 libqtgui4:i386 libqtwebkit4:i386 libstdc++6:i386 libx11-6:i386 libxext6:i386 libxss1:i386 libxv1:i386 libssl1.0.0:i386 libpulse0:i386 libasound2-plugins:i386
wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
sudo dpkg -i skype-install.deb

Вопрос: Почему Skype не исользует мой системный курсор?

Ответ: Установите 32-бит версию пакета libxcursor1:

# apt-get install libxcursor1:i386

Debian 7 "Wheezy"

32-битный / i386

Пакет i386 хорошо работает со стандартной системой Debian 7 i386. Для установки Skype используйте один из двух предоставленных методов:

1 метод: Используя GDebi

Введите данные команды в терминал:

# apt-get install gdebi
# wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
# gdebi skype-install.deb

GDebi автоматически заинсталирует все нужные зависимости.

2 метод: Не используя GDebi

Этот метод считается альтернативным и более предназначен для тех кто использует KDE и нехочет инсталлировать зависимости нужные для GDebi.

Введите данные команды в терминал:

# wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
# dpkg -i skype-install.deb

Для установки требуемых зависимостей используйте следующую команду:

# apt-get -f install

64-битный / amd64

  • Следующие инструкции работают и с Debian 7.4, и с Debian 7.5. Если не работают, пожалуйста, откройте тикет на Skype форуме.

  • Начиная с Wheezy, Debian поддерживает Multi-Arch. Пакеты Skype для системы i386 будут хорошо работать с Multi-Arch.

1 метод: Используя GDebi

Для начала вы должны включить Multi-Arch, введя следующую команду в терминал:

# dpkg --add-architecture i386
# apt-get update

После этого, скачайте i386 пакет и установите его:

# apt-get install gdebi
# wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
# gdebi skype-install.deb

Некоторые i386 пакеты будут установлены.

Готово, Skype установлен. Наслаждайтесь.

2 метод: Не используя GDebi

Этот метод считается альтернативным и более предназначен для тех кто использует KDE и нехочет инсталлировать зависимости нужные для GDebi.

Для начала вы должны включить Multi-Arch, введя следующую команду в терминал:

# dpkg --add-architecture i386
# apt-get update

Далее введите данные команды в терминал:

# wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
# dpkg -i skype-install.deb

Для установки требуемых зависимостей используйте следующую команду:

# apt-get -f install

Если вы используете Gnome 3, для доступа в меню Skype, переместите курсор мыши в правую нижнюю часть экрана, потом кликните правой кнопкой мыши на иконку Skype

Проблема с запуском Skype

Когда вы запускате Skype, который является 32-битной программой, в 64-бит системе вам может выскочить данная ошибка:

skype: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory

Эта ошибка появляласть только в 64-битных системах. Данная командна исправит её:

# ln -s /usr/lib/mesa-diverted/i386-linux-gnu/libGL.so.1 /usr/lib/i386-linux-gnu/

Часто задаваемые вопросы (F.A.Q.) по Wheezy 64-бит

Вопрос: Почему Skype выдает ошибку то, что он не может подключиться к серверу?
Ответ: Обновите ваш Skype до версии 4.3 вышедшую в мае 2014 года. Ошибка вызывается сервером аутентификации Skype и тем самым заставляет пользователей Linux обновится до версии 4.3. Спасибо Clived за это решение :). Старые версии Skype работали до конца июля 2014 года, но более сервер не позволяет им подсоединится.


Вопрос: Почему я не могу использовать веб-камеру?
Ответ: Скорее всего вам надо загрузить v4l совместимость.

Попробуйте это:

LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so /usr/bin/skype 

К тому-же Включить Skype Видео должно быть включено иначе Skype никогда не найдет вашу камеру (с версии 4.3).

Чтобы включить Skype видеo зайдите в Skype->Опции->Видео устройства->Включить Skype видео и перезапустите Skype.

Если у вас 64-бит система, то вам нужно 32-бит версию libv4l-0:

# apt-get install libv4l-0:i386


Вопрос: Почему Skype не запускается, когда я нажимаю на Skype Launcher? Аналогчино и с помощью терминала, он возвращает ошибку "symbol lookup error"
Ответ: Используя терминал, введите следующую команду для запуска Skype:

LD_LIBRARY_PATH=/usr/lib/i386-linux-gnu/ /usr/bin/skype

  • Эта команда - обходной путь, она запускает Skype из терминала и использует i386 библиотеки находящиеся в /usr/lib/i386-linux-gnu/
  • Полная первая часть сообщения об ошибке гласит:

skype: symbol lookup error: skype: undefined symbol:
  • Это при условии, что у вас установлен пакет skype:i386, а не amd64/64-битный пакет.
  • Эта ошибка связана с текущим включением Multi-Arch, который позволяет использовать библиотеки от других архитектур.
  • Источник ответа: Iwan / user29978


Вопрос: Почему я не могу установить libqtwebkit4:i386?
Ответ: Если apt-get не удалось установить libqtwebkit4:i386 как зависимость, попробуйте использовать aptitude (если вы знаете, что вы делаете)

Вы можете использовать версию skype-debian_2.2.0.35-1_amd64.deb (новые версии имеют пробелмы с ассоциацией с pulseaudio). Можно отредактировать deb пакет, чтобы исправить зависимости для Wheezy - control file должен иметь:

Depends: libstdc++6 (>= 4.1.1-21), libasound2 (>> 1.0.14), libc6 (>= 2.13-1), libgcc1 (>= 1:4.1.1-21)


Вопрос: Почему в Skype нету звука?
Ответ: Если у вас есть проблемы со звуком, у вас может отсутствовать libpulse.

Вы можете установить его:

# apt-get install libpulse0:i386

Если у вас pulseaudio 4 и Skype 4.2 имеют неправильный звук, используйте следующее решение:

1) PULSE_LATENCY_MSEC variable environment trick from the Skype forum:

$ PULSE_LATENCY_MSEC=30 skype

2) В файле /etc/pulse/default.pa замените строку (из http://pc-freak.net):

load-module module-udev-detect

на

load-module module-udev-detect tsched=0

и перезапустите Pulseaudio server.


Debian 6 "Squeeze"

Веб-сайт Skype больше не предлагает пакеты предназначенные для Debian 6.0: только для Debian 7. В Skype public bug-tracking system уже было доложено об этой ошибке (новые deb пакеты не работают также хорошо как skype debian_2.2.0.35-1_amd64.deb - действительно, самое время перейти на linphone).

http://download.skype.com/linux/skype-debian_4.0.0.7-1_i386.deb работает на Debian 6.0. Неизвестно будут ли новые пакеты Skype работать на Debian 6.0.

Если вы хотите использовать MSN Messenger и поддержку Facebook, вам потребуется Skype 4.1. http://download.skype.com/linux/skype-ubuntu-lucid_4.1.0.20-1_i386.deb — несмотря на имя файла — кажется, он хорошо работает на Debian 6.0. Skype 4.1 еще не рассматривался официально на этой Wiki.

http://download.skype.com/linux/skype-debian_4.1.0.20-1_i386.deb не работает на Debian 6.0.6. Даже когда вы устанавливаете его принудительно, пакет не запускается.

http://download.skype.com/linux/skype-debian_4.0.0.7-1_i386.deb работает на Debian 6.0.0 x86_64 несмотря на несоответствие архитектур, вы можете установить:

# apt-get install ia32-libs ia32-libs-gtk

и запустить:

# dpkg -i --force-architecture skype-debian_4.0.0.7-1_i386.deb

Обновление Skype

Просто установите новую Skype версию

Часто задаваемые вопросы (F.A.Q.) по Skype

Вопрос: Я пытался обновить Skype установив новую Skype версию. Почему Skype всё равно не работает?

Ответ: Перед тем как предпринимать следующие действия сделайте резервную копию Skype даты. Вы можете попробовать удалит .skype директорию перед тем как запускать обновленный Skype. В .skype директории хранится вся ваша личная информация и настройки. Если вы успешно запустили обновленный Skype, то первое что вы увидите при запуске это лицензионное соглашение. Чтобы увидеть .skype директорию нажмите Ctrl + H (Gnome) или Alt + . (KDE).

Обзор пакета

Путь и файлы

Пакет устанавилвает в /usr/bin, некоторые файлы в /usr/share и немного документации в /usr/doc. Конфигурационный файл для dbus кладется в /etc/dbus-1/system.d/.

Lintian

# lintian -v skype-debian_4.0.0.7-1_i386.deb
N: Using profile debian/main.
N: Setting up lab in /tmp/temp-lintian-lab-iZ1DBQdipA ...
N: ----
N: Processing binary package skype (version 4.0.0.7-1, arch i386) ...
W: skype: hardening-no-relro usr/bin/skype
W: skype: changelog-not-compressed-with-max-compression changelog.Debian.gz
W: skype: new-package-should-close-itp-bug
E: skype: description-starts-with-package-name
W: skype: extended-description-line-too-long
W: skype: extended-description-line-too-long
W: skype: possible-unindented-list-in-extended-description
W: skype: extended-description-contains-empty-paragraph
W: skype: binary-without-manpage usr/bin/skype

Обратите внимание, этот лог изменений включен только для целей "соответствия". Это не актуальный список того, что изменилось от версии к версии, и нет истории версий распространяющейся без него.