Translation(s): none


Installing Xen

CPU BIOS Requirements

Virtualization extensions need to be enabled in the BIOS. If not already enabled in BIOS, enable it.

CPU needs to have virtualization extensions.

To check in both Intel and AMD CPUs:

egrep '(vmx|svm)' /proc/cpuinfo

For XEN kernel, check output of the following for 'hvm':

xm dmesg | grep VMX

Debian Install Xen

For debian 7.0 (wheezy)

apt-get install xen-linux-system

For debian 6.0 (squeeze)

apt-get install xen-linux-system xen-qemu-dm xen-utils

Boot Xen kernel by default (both in wheezy and squeeze), without this change the kernel will boot not being dom0

dpkg-divert --divert /etc/grub.d/08_linux_xen --rename /etc/grub.d/20_linux_xen

Management tools

apt-get install libvirt-bin

Using lvm disks

If you want that the new domU are created using the space from a lvm pool, you have to configure libvirt to use it, to do so, you need to create the entry pointing to you pool (in this case lvmspace)

vi /etc/libvirt/storage/lvmspace.xml

<pool type='logical'>
  <name>lvmspace</name>
  <target>
    <path>/dev/lvmspace</path>
  </target>
</pool>

To include this pool into libvirt

virsh pool-define /etc/libvirt/storage/lvmspace.xml 
virsh pool-start lvmspace
virsh pool-autostart lvmspace
virsh pool-info lvmspace

Using disk images

*Change the default location to /home/xen/images: Edit:

vi /etc/libvirt/storage/default.xml

And change the location. Reason I'm doing that is my home partition has 80Gb while / (root) partition has only 5gb.

#from:
/var/lib/libvirt/images/
#to
/home/xen/images

Remote connection

apt-get install virt-manager

* If you want to connect over ssh tunnel you need:

aptitude install ssh-askpass

On debian wheezy/squeeze the default value for this parameter is “no” which means that communication and management tools
Such as “Virt Manager” can not access the Hypervisor.

1. You need to uncomment it and change the value to “yes” –
(xend-unix-server yes)

2. Restart xend to apply the new configuration:
xend restart

Start Networking

virsh net-start default
#or
virsh net-autostart default

Installing new guest OS

Create iso from cdrom

dd if=/dev/cdrom of=~/cd_image.iso

Windows 7

windows7.png

Maintenance

Extending xen raw_storage_volume

Starting Networking

virsh net-start default
#or
virsh net-autostart default

<network>
  <name>default</name>
  <bridge name="virbr0" />
  <forward/>
  <ip address="192.168.122.1" netmask="255.255.255.0">
    <dhcp>
      <range start="192.168.122.2" end="192.168.122.254" />
    </dhcp>
  </ip>
</network>

Disable virbr0

ifconfig

virsh net-list

virsh net-destroy default
virsh net-undefine default
service libvirtd restart
ifconfig 

Errors

Error creating domain: device model '/usr/lib64/xen/bin/qemu-dm' not found

Unable to complete install '<class 'libvirt.libvirtError'> POST operation failed: xend_post: error from 
xen daemon: (xend.err "Error creating domain: device model '/usr/lib64/xen/bin
/qemu-dm' not found")

Solution:

mkdir /usr/lib64/xen/
ln -s /usr/lib/xen-4.0/bin /usr/lib64/xen/bin

iptables bad rule

libvirtError: internal error '/sbin/iptables --table filter --delete INPUT --in-interface virbr0 --protocol udp --destination-port 69 --jump ACCEPT' exited with non-zero status 1 and signal 0: iptables: Bad rule (does a matching rule exist in that chain?).

Solution

This is trying to biund to interface virbr0. If for some reason you didn't start the network you will get this error. Start the network:

virsh net-start default
#or autostart it
virsh net-autostart default

ifconfig

virsh net-dumpxml default

**Notes (Looks like these steps are not needed):

**trying to test this. read: vi /usr/share/doc/libvirt-bin/README.Debian

aptitude install dnsmasq-base bridge-utils iptables
cat <<EOF >/etc/dnsmasq.d/00_libvirtd.conf
# only bind to loopback by default
interface=lo
bind-interfaces
EOF

can handle the virtual bridges.

Sources


CategoryVirtualization | CategorySoftware | CategorySystemAdministration