Translation(s): English - Français - Italiano - 한국어(Korean)


Pacchetti Debian > dpkg


dpkg, un gestore di pacchetti di livello medio per Debian.

Con dpkg --set-selections è possibile impostare quali pacchetti devono essere installati/rimossi la prossima volta che si eseguirà apt-get dist-upgrade.

Perché "di livello medio"?

Sotto di esso, c'è dpkg-deb, che esegue le azioni di livello inferiore sui pacchetti .deb (binari), come leggere le informazioni di controllo ed estrarre direttamente i file contenuti.

dpkg controlla le dipendenze e si rifiuterà di installare un pacchetto per cui le dipendenze non sono soddisfatte, ma non aiuterà a trovarle ed installarle. Per questo serve uno strumento di livello superiore (ad esempio, dselect o apt-get).

Messaggi di errore

E: Impossibile aprire il file di lock /var/lib/dpkg/lock - open (13 Permesso negato)

È stato fatto un tentativo di eseguire più di un processo di gestione pacchetti

Questo errore può verificarsi se si tenta di eseguire più di un processo di gestione dei pacchetti. Ad esempio, se un pacchetto viene installato o rimosso con apt-get o dselect, non dovrebbe essere possibile eseguire un altro strumento di gestione dei pacchetti, fino a quando gli aggiornamenti non siano completi.

Un utente non-root sta cercando di aggiungere o rimuovere i pacchetti

Può verificarsi se un utente non privilegiato (non root) tenta di aggiungere o installare i pacchetti, o fare una modifica allo stato delle informazioni di un pacchetto all'interno del database.

E: Impossibile bloccare la directory di amministrazione (/var/lib/dpkg/), si è root?

Un utente non-root sta cercando di aggiungere o rimuovere dei pacchetti

Questi errori si verificano se un utente non privilegiato (non root) tenta di aggiungere o installare i pacchetti, o fare una modifica allo stato delle informazioni di un pacchetto all'interno del database.

Si veda anche


CategoryQuickPackageManagement | CategoryPackageManagement