Translation(s): English - Français - Italiano - 한국어(Korean)


Pacchetti Debian > Apt > apt-get


apt-get - utilità di gestione pacchetti APT - interfaccia a riga di comando

apt-get è uno strumento per aggiornare automaticamente la propria macchina Debian, ottenere ed installare pacchetti/programmi Debian!

Fa parte del sistema di strumenti per la gestione dei pacchetti.

Messaggi di errore

E: Impossibile aprire il file di lock /var/lib/dpkg/lock - open (13 Permesso negato)

È stato fatto un tentativo di eseguire più di un processo di gestione pacchetti

Questo errore può verificarsi se si tenta di eseguire più di un processo di gestione dei pacchetti. Ad esempio, se un pacchetto viene installato o rimosso con apt-get o dselect, non dovrebbe essere possibile eseguire un altro strumento di gestione dei pacchetti, fino a quando gli aggiornamenti non siano completi.

Un utente non-root sta cercando di aggiungere o rimuovere i pacchetti

Può verificarsi se un utente non privilegiato (non root) tenta di aggiungere o installare i pacchetti, o fare una modifica allo stato delle informazioni di un pacchetto all'interno del database.

E: MMap dinamica esaurita

Questo errore può verificarsi se viene raggiunto il valore di Apt::Cache-Limit. È necessario aggiungere una voce al file di configurazione /etc/apt/apt.conf per sostituire il valore predefinito.

APT::Cache-Limit "33554432";

E: Si è verificato un errore nell'elaborare xfmedia-dev (NewVersion1)

E: Si è verificato un problema con MergeList /var/lib/apt/lists/foobar

E: L'elenco dei pacchetti o il file di status non possono essere letti o aperti

E: Impossibile bloccare la directory di amministrazione (/var/lib/dpkg/), si è root?

Un utente non-root sta cercando di aggiungere o rimuovere dei pacchetti

Questi errori si verificano se un utente non privilegiato (non root) tenta di aggiungere o installare i pacchetti, o fare una modifica allo stato delle informazioni di un pacchetto all'interno del database.

Si veda anche


Per i neofiti Debian:

apt-get seleziona i pacchetti in base alla lista delle fonti, che è /etc/apt/sources.list

apt-get attinge da tre livelli di pacchetti: stable, testing, and unstable. Per esempio, al momento della scrittura apache in stabile era alla versione 1.3.26, 1.3.27 in testing e 1.3.28 in unstable.

Si provi il ?pinning di Apt se si vuole un pacchetto di unstable su un sistema Debian stable. Attenzione, il pacchetto unstable potrebbe richiedere certe librerie, e si potrebbe finire con una miscela del "peggio" di stable e unstable. Meglio cercare un pacchetto backport.


Per i neofiti Debian che non sono root:

(Per esempio, se si usa un semplice server web Debian condiviso.) Non possono usare apt-get. Leggere la bella spiegazione del processo configure/make/make install e darsi da fare.


Server alternativi e non ufficiali per pacchetti sono disponibili all'indirizzo: http://www.apt-get.org

CategorySystemAdministration