Differences between revisions 1 and 2
Revision 1 as of 2010-10-24 02:35:07
Size: 15168
Editor: ?skizzhg
Comment:
Revision 2 as of 2010-10-24 02:59:26
Size: 15164
Editor: ?skizzhg
Comment:
Deletions are marked like this. Additions are marked like this.
Line 123: Line 123:
Posizionare la riga indentata all'interno di una istanza {{{iface}}}, subito dopo la riga {{{gateway}}}; inserire gli indirizzi IP dei nameserver dopo {{{dns-nameservers}}} tutti su una sola riga separati da spazi. Non dimenticare la "{{{s}}}" alla fine di {{{dns-nameservers}}}. Posizionare la riga indentata all'interno del blocco {{{iface}}}, subito dopo la riga {{{gateway}}}; inserire gli indirizzi IP dei nameserver dopo {{{dns-nameservers}}} tutti su una sola riga separati da spazi. Non dimenticare la "{{{s}}}" alla fine di {{{dns-nameservers}}}.

Translation(s): English - Italiano

(!) ?Discussion


Prerequisiti per il lettore: Per ottenere il massimo da questo articolo, è consigliabile capire i seguenti concetti prima di leggere: gli strumenti UNIX di base a riga di comando, editor di testo, DNS, TCP/IP, DHCP, netmask, gateway

Table of Contents

Impostare un'interfaccia ethernet

La maggior parte delle impostazioni di rete può essere fatta tramite il file di configurazione /etc/network/interfaces; qui si può assegnare un indirizzo IP alla scheda di rete (o usare il DHCP), impostare le informazioni di routing, configurare il mascheramento IP, impostare instradamenti predefiniti e molto altro.

Ricordarsi di aggiungere alla riga "auto" le interfacce che si vogliono attivare all'avvio.

Per ulteriori informazioni consultare man interfaces.

Usare DHCP per configurare l'interfaccia automaticamente

Qualcosa di simile sarà tutto ciò che serve se si utilizza DHCP:

    auto eth0
    iface eth0 inet dhcp

Configurare manualmente l'interfaccia

Se si sta configurando manualmente, qualcosa di simile imposterà il gateway predefinito (rete, broadcast e gateway sono opzionali):

    iface eth0 inet static
        address 192.168.0.7
        netmask 255.255.255.0
        gateway 192.168.0.254

Per ulteriori informazioni consultare man interfaces.

Impostare velocità e duplex

In alcune reti la negoziazione automatica non è possibile, se è necessario impostare a mano la velocità e la modalità duplex dell'interfaccia, sarà poi richiesta qualche prova. Ecco i passi fondamentali:

  • installare i pacchetti ethtool e net-tools per avere i programmi ethtool e mii-tool, uno di questi o entrambi potrebbero funzionare

  • nel caso che l'interfaccia di rete diventi inusabile, assicurarsi di avere un modo per accedere al sistema, una connessione ?ssh potrebbe venire interrotta perciò si dovrebbe avere una strategia di ripiego

  • identificare l'interfaccia in questione (spesso sarà eth0) e aggiustare il resto in base a queste istruzioni
  • provare a determinare quale siano le attuali impostazioni di velocità e duplex, ecco come divertirsi:
    • per prima cosa provare ethtool eth0 come utente root e vedere se le linee "Speed:" e "Duplex:" paiono valide; in caso contrario ethtool potrebbe non essere supportato dalla periferica

    • provare mii-tool -v eth0 come utente root e vedere se l'output appare corretto, in caso contrario mii-tool potrebbe non essere supportato dalla periferica

    • se nessuno dei due è supportato si possono impostare i parametri direttamente nel modulo del kernel, identificando quello in uso leggendo l'output dei comandi dmesg e lsmod; si può usare modinfo NOMEMODULO per vedere se ha dei parametri e quali accetta (per fare confronti modinfo funziona anche su moduli non caricati) ToDo: dove si impostano i parametri per i moduli del kernel?

  • provare a cambiare le opzioni dell'interfaccia su cui si sta lavorando, naturalmente è necessario essere root, oppure:
    • ethtool -s eth0 autoneg off speed 100 duplex full (nell'ipotesi di 100 Mbps e full duplex)

    • mii-tool -F 100baseTx-FD eth0 (stessa ipotesi)

    in ogni caso ricontrollare che le impostazioni siano effettivamente cambiate e provare ad inviare e ricevere dei dati per vedere se la scheda di rete stia funzionando correttamente.
  • se uno di equesti comandi configura la scheda con successo lo si può inserire in /etc/network/interfaces affinché venga eseguito quando viene attivata l'interfaccia (ad esempio all'avvio del sistema); tuttavia prima di questo si dovrebbe capire che alcuni driver e dispositivi si comportano diversamente rispetto ad altri.

Quando il modulo viene caricato la scheda di rete può iniziare la negoziazione automatica senza alcun modo di fermarla (in particolare con driver che non accettano parametri), le impostazioni di interfaces vengono applicate dopo e potrebbe accadere nel bel mezzo della negoziazione; alcuni ritengono necessario ritardare il comando ethtool o mii-tool di pochi secondi:

 iface eth0 inet static
        address ...
        netmask ...
        gateway ...
        up sleep 5; ethtool -s eth0 ...
  • o analogamente per il comando mii-tool

  • riavviare la macchina per assicurarsi che venga attivata correttamente e prepararsi ad intervenire manualmente (Ctrl-Alt-Del e avviare in modalità single-user da GRUB o LILO) nel caso non funzioni.


Attivare un'interfaccia senza un indirizzo IP

Si usi il metodo manuale per creare un'interfaccia di rete senza un indirizzo IP e i comandi pre-up e post-down per attivarla e disattivarla.

   iface eth0 inet manual
      pre-up ifconfig $IFACE up
      post-down ifconfig $IFACE down

Definire il nameserver (DNS)

Prima che un computer possa connettersi ad una risorsa di rete esterna (come ad esempio un server web), deve avere il modo di convertire i nomi alfanumerici (wiki.debian.org) in indirizzi numerici (140.211.166.4) (internet utilizza questi indirizzi IP numerici strutturati come indirizzi di rete).

La libreria C e le altre librerie resolver leggono il file /etc/resolv.conf per la lista dei nameserver, che è il file da modificare per impostare la lista dei nomi dei server. Si noti che vari altri programmi per la configurazione dinamica saranno lieti di sovrascrivere le impostazioni:

  1. il programma resolvconf

  2. il demone network-manager

  3. i clien DHCP

Nella maggior parte dei casi il file da modificare è il file di configurazione del tale programma.

Nelle situazioni più complesse l'utilizzo di resolvconf è davvero la strada da percorrere, anche se in configurazioni più semplici è probabilmente eccessivo.

Il file di configurazione resolv.conf

Il file /etc/resolv.conf contiene informazioni che permettono ad un computer di connettersi alla rete e risolvere i nomi in indirizzi (non confondere questo file di configurazione con il programma resolvconf, che sfortunatamente ha un nome molto simile).

Il file resolv.conf contiene solitamente gli indirizzi IP dei nameserver (risolutori di nomi DNS) e cercherà di tradurre i nomi in indirizzi per ogni nodo disponibile sulla rete, ci saranno delle righe simili a queste:

nameserver 12.34.56.78
nameserver 12.34.56.79

In questo esempio il sistema sta usando i nameserver agli indirizzi IP 12.34.56.78 e 12.34.56.79. Inserire semplicemente gli IP necessari dopo ogni nameserver, aggiungendo più righe nameserver in caso se ne abbiano altri. Non usare questo metodo se si ha il programma resolvconf installato.

Il file ha molte altre opzioni per definire come il risolutore controlli i nomi, si veda man resolv.conf per i dettagli.

Il programma resolvconf

Il programma resolvconf (opzionale su un sistema Debian) tiene traccia delle informazioni di sistema sugli attuali nameserver disponibili, non va confuso con il file di configurazione resolv.conf, che purtroppo ha un nome quasi identico.

Il file di configurazione resolv.conf contiene informazioni sui nameserver che il sistema deve usare, tuttavia quando più programmi necessitano di modificare dinamicamente resolv.conf possono interferire tra loro e desincronizzare il file. Il programma resolvconf risolve questo problema agendo come intermediario fra i programmi che provvedono alle informazioni del nameserver (come i client DHCP) e quelli che utilizzano le informazioni del nameserver (i risolutori).

Quando resolvconf è installato correttamente, il file /etc/resolv.conf viene rimpiazzato da un collegamento simbolico in /etc/resolvconf/run/resolv.conf e il risolutore usa invece il file di configurazione /etc/resolvconf/run/resolv.conf generato dinamicamente.

Solitamente è necessario solo quando un sistema ha vari programmi che modificano dinamicamente le informazioni del nameserver, mentre dove queste non cambiano frequentemente, la configurazione con il file resolv.conf è sufficiente.

Non modificare a mano il file resolv.conf se resolvconf è installato, in quanto verrà modificato dai programmi nel sistema, se serve definire i nameserver manualmente (come per un'interfaccia statica) si aggiunga una riga simile al file /etc/network/interfaces:

dns-nameservers 12.34.56.78 12.34.56.79

Posizionare la riga indentata all'interno del blocco iface, subito dopo la riga gateway; inserire gli indirizzi IP dei nameserver dopo dns-nameservers tutti su una sola riga separati da spazi. Non dimenticare la "s" alla fine di dns-nameservers.

Il programma resolvconf è un'aggiunta a Debian piuttosto recente e molti vecchi programmi devono essere aggiornati o riconfigurati per funzionare correttamente. Si veda /usr/share/doc/resolvconf/README per eventuali problemi, ha molte informazioni su come accordare gli altri programmi resolvconf.

Configurazione DNS per network-manager

Attenzione: questa sezione non è stata testata con una reale configurazione di network-manager, si prega di verificare e rimuovere questo avviso.

Se si usa NetworkManager, inserire le proprie configurazioni in /etc/sysconfig/network-scripts/ifcfg-*. Esempio:

DNS1=127.0.0.1
DNS2=8.8.8.8
DNS3=8.8.4.4

Con l'interfaccia grafica questo significa:

  1. Systems menu → Preferences → Network Connections.
  2. Choose a connection (from the Wired or Wireless tab) and click Edit.
  3. Change the Method to something other than “Automatic (DHCP)” in the IPv4 Settings tab. For example, “Automatic (DHCP) addresses only” is likely to be appropriate.
  4. Enter the DNS servers in the “DNS servers” field, separated by spaces.
  5. Click “Apply.”

Si noti che il client DHCP potrebbe sovrascrivere queste impostazioni, in questo caso considerare se segnalarlo come bug e vedere sotto per la configurazione del client DHCP.

Questa sezione è basata sulla pagina http://code.google.com/speed/public-dns/docs/using.html, consultarla per i dettagli.

Configurare il client DHCP

Esempio: dhclient3 usa /etc/dhcp3/dhclient.conf, la configurazione voluta è:

supersede domain-name-servers 12.34.56.78, 12.34.56.79

o magari

prepend domain-name-servers 12.34.56.78, 12.34.56.79

per i dettagli vedere la pagina di manuale di dhclient.conf(5)

Come usare vlan (dot1q, 802.1q, trunk) in Etch e Lenny

Configurazione manuale

modprobe 8021q

apt-get install vlan

vconfig add eth0 222    # 222 is vlan number
ifconfig eth0.222 up
ifconfig eth0.222 mtu 1496    #optional if your network card doesn't support MTU 1504B
ifconfig eth0.222 10.10.10.1 netmask 255.255.255.0

Configurazione di rete con script init

Nel file /etc/modules aggiungere la riga:

8021q

Alla sezione iface di /etc/network/interfaces aggiungere il parametro:

        vlan_raw_device eth0

Esempio:

auto eth0.222
iface eth0.222 inet static
        address 10.10.10.1
        netmask 255.255.255.0
        network 10.10.10.0
        broadcast 10.10.10.255
        vlan_raw_device eth0

Come creare un bonding fault tolerant con vlan in Etch

NetworkConfiguration/debian_bonding.png

NetworkConfiguration/debian_bonding.dia

Howto configure one of the above server active backup bonding 3 vlan {vlan10,vlan20,vlan30} Debian networking without SPOF without native vlan.

aptitude install vlan ifenslave-2.6

Configurazione di rete

Esempio di configurazione di un'interfaccia di scambio Cisco:

interface GigabitEthernet1/2
 description eth1 www.niif.hu :)
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 10,20,30
 switchport mode trunk
 no ip address
 no cdp enable
 spanning-tree portfast trunk

bonding con active backup

Creare il file /etc/modprobe.d/bonding.conf contenente:

alias bond0 bonding
options bonding mode=active-backup miimon=100 downdelay=200 updelay=200 primary=eth1

/etc/network/interfaces

# The loopback network interface
auto lo
iface lo inet loopback
# The primary network interface
auto bond0
iface bond0 inet manual
        up ifconfig bond0 0.0.0.0 up
        slaves eth1 eth0
auto vlan10
iface vlan10 inet static
        address 10.10.10.12
        netmask 255.255.0.0
        network 10.10.0.0
        broadcast 10.10.255.255
        vlan-raw-device bond0
        gateway 10.10.0.1
        dns-search hup.hu
        dns-nameservers 10.10.0.2
auto vlan20
iface vlan20 inet static
        address 10.20.10.12
        netmask 255.255.0.0
        network 10.20.0.0
        broadcast 10.20.255.255
        vlan-raw-device bond0
auto vlan30
iface vlan30 inet static
        address 10.30.10.12
        netmask 255.255.0.0
        network 10.30.0.0
        broadcast 10.30.255.255
        vlan-raw-device bond0

Come assegnare indirizzi IP multipli

È possibile assegnare più indirizzi IP alla stessa interfaccia di rete utilizzando alias di interfaccia, ciò è utile se si ha bisogno di avere più di un server visibile su internet. Si noti che per più server Apache è possibile utilizzare host virtuali per aggiungere con un singolo indirizzo IP i server voluti, Apache utilizza semplicemente il nome di dominio fornito dal client nell'intestazione dell'host http; in altre situazioni è necessario un IP esterno per ogni server che utilizza la stessa porta.

Supponendo che l'interfaccia sia eth0, si può assegnare tre indirizzi IP modificando /etc/network/interfaces con qualcosa di simile a questo:

# the loopback interface
auto lo
iface lo inet loopback

#
auto eth0
iface eth0 inet static
    address 192.168.1.42
    netmask 255.255.255.0
    broadcast 192.168.1.255
    gateway 192.168.1.1

auto eth0:0
iface eth0:0 inet static
    address 192.168.1.41
    netmask 255.255.255.0
    broadcast 192.168.1.255

auto eth0:1
iface eth0:1 inet static
    address 192.168.1.44
    netmask 255.255.255.0
    broadcast 192.168.1.255

Notare che il gateway viene assegnato solo a eth0, se si include dns-nameservers dovrebbe essere specificato solo per eth0. Si può anche utilizzare l'assegnazione IP dinamica per le interfacce.


CategoryNetwork