Differences between revisions 12 and 13
Revision 12 as of 2006-12-11 17:21:54
Size: 3793
Editor: ?nadim
Comment: Main repository noted doesn't resolve - added sidux (from irc.freenode.net #nx)
Revision 13 as of 2007-07-01 10:01:38
Size: 3906
Editor: ?Dick Kniep
Comment: Have been looking for this repository for quite some time, there are a lot of re
Deletions are marked like this. Additions are marked like this.
Line 14: Line 14:
}}}

If using Sarge, use the following repository

{{{
deb http://packages.debianbase.de/sarge/i386/nx/ ./

The repositories for freenx for unstable distribution is at

deb http://debian.tu-bs.de/project/kanotix/unstable/ sid nx
deb-src http://debian.tu-bs.de/project/kanotix/unstable/ sid nx

Add the above two lines to /etc/apt/sources.list and then apt-get install freenx. NOTE: the links above are no longer being maintained.

Other repositories are

deb http://packages.debianbase.de/testing/i386/nx/ ./
deb http://sidux.com/debian/ unstable nx

If using Sarge, use the following repository

deb http://packages.debianbase.de/sarge/i386/nx/ ./

Solutions for NX Client version 2.0.0 and FreeNX 0.4.x and 0.5.0.

If you have problem connecting with new NX Client ver. 2.0.0, there are 2 patch, which working for me with NX Client ver. 2.0.0-93:

'fake cookie authentication problem':

Some new clients uses 1.4.0 as proto version. You have to make sure that 'fake cookie authentication' is working on the server. Look at nxnode and search for that string in 'node_startsession()' function and edit it.

For freenx 0.4.x nxnode in function 'node_startsession()' {{{ if [ "$ENABLE_1_5_0_BACKEND" = "1" -a "$clientproto" = "1.5.0" ] || [ "$ENABLE_1_5_0_BACKEND" = "1" -a "$clientproto" = "1.4.0" ]

  • then
    • # enable fake cookie authentication cookie=$proxy_cookie

fi }}}

For freenx 0.5.0 nxnode in function 'node_startsession()' {{{ if [ "$clientproto" = "1.5.0" ] || [ "$clientproto" = "1.4.0" ]

  • then
    • # enable fake cookie authentication cookie=$proxy_cookie

fi }}}

Pre 1.5 clients will face trouble in this case, though - but works for me (no users with old clients). As I see in comunnication with client ver. 2.0.0-93, it use 1.5.0 proto version, so this is for older 2.0.0 clients.

'Backingstore problem':

Thorsten Sandfuchs found some issues concerning backingstore. Problem arouse as you try to connect to a 0.5.0 installation with no 2.0.0 backend support and a 2.0.0-client. As Nomachine changed the behaviour of the backingstore-option. In 1.5.0-clients the client sends "always, when_requested" et all and freenx just passed this string to the nxagent-call. The new client now sends "backingstore=1" and the 1.5.0-nxagent issues a warning and an error with "no argument requiered for -bs" or with "Error: NX Agent exited with exit status 1.". You can read all his message here: [http://permalink.gmane.org/gmane.network.freenx.general/3839 Backingstore or 2.0.0-client and 1.5.0 backend and freenx-0.5]

Look at nxnode and in function 'node_start_agent()' after this line

[ -n "$backingstore" ] && B="-bs $backingstore"

add these lines: {{{ # backingstore = { "when_requested", "always", ... } [ -n "$backingstore" -a "$ENABLE_2_0_0_BACKEND" != "1" -a "$backingstore" != "1" ] && B="-bs $backingstore" # backingstore = 1 (new nxclient 2.0.0 doesn't send any strings in the option-string for backingstore anymore) [ -n "$backingstore" -a "$ENABLE_2_0_0_BACKEND" != "1" -a "$backingstore" = "1" ] && B="+bs" # backingstore = 1 and 2.0.0-Backend EXPERIMENTAL [ -n "$backingstore" -a "$ENABLE_2_0_0_BACKEND" = "1" ] && B="-bs $backingstore" }}}

This works using nxclient version 2.0.0-98.

--[:Predseda3D:Predseda3D] 2006-08-02

Missing Color Definitions Cause Some Applications to Fail

After upgrading to the latest X.org (xorg/testing 1:7.0.22), some applications will fail to start while using FreeNX (freenx 0.4.4+0.4.5-4) with the following error:

(application): Cannot allocate color (some color), such as:

xterm: Cannot allocate color green

Other applications will fail with similar errors.

The reason for this is that nxagent is looking for rgb.txt in /usr/X11R6/lib/X11, and it is not present.

Issuing a:

ln -s /etc/X11/rgb.txt /usr/X11R6/lib/X11/rgb.txt 

and restarting nxserver clears up the issue.