Translation(s): English - Français - 简体中文 - Русский


Vendeur :

skype.com

Licence :

propriétaire
(copyright.txt)

X-(

propriétés :

Version examinée : 4.3.0.37-1

Téléchargement

.deb non signé

X-(

Sources :

non disponible

X-(

Lintian :

erreurs mineures

(./)

Scripts de contrôle

aucun

(./)

Langues :

es pl zh_t ja no pt_br fr cs ro lv lt pt_pt et ko bg uk ru en zh_s th de it tr

(./)

Architectures :

i386, amd64

-

Légende : (./) = Bon ; X-( = Mauvais

Skype est un logiciel non-libre (propriétaire). Il n'est pas pris en charge par Debian. Il est probablement plus judicieux d'utiliser un logiciel de voix sur IP tel que Iceweasel/Firefox Hello, ekiga , linphone, ou jitsi ! Voir aussi UnifiedCommunications (en).

Installer Skype

Skype est disponible pour les architectures amd64 et i386 architectures de Debian 5 et plus récent. En général, on trouve les derniers paquets sur le site de Skype.

<!> Attention, il n'y a pas de dépôt qui possède la dernière version (4.x). Vous devrez donc télécharger le paquet chaque fois qu'il y a une mise à jour. Et comme apt-get ne peut pas vous avertir des mises à jour, on vous conseille d'activer « [x] Vérifier les mises à jour au démarrage » dans l'onglet « Avancé » du menu options de Skype.

Debian 9 « Stretch »

(Voir Debian 7 « Wheezy »)

Debian 8 « Jessie »

(Voir Debian 7 « Wheezy »)

Questions fréquemment posées (F.A.Q.) pour Jessie 64 bits

Question : Les instructions d'installation pour Wheezy ne fonctionnent pas pour Jessie ?

Réponse : Essayez les commandes suivantes

sudo dpkg --add-architecture i386
sudo aptitude update
sudo aptitude install libc6:i386 libqt4-dbus:i386 libqt4-network:i386 libqt4-xml:i386 libqtcore4:i386 libqtgui4:i386 libqtwebkit4:i386 libstdc++6:i386 libx11-6:i386 libxext6:i386 libxss1:i386 libxv1:i386 libssl1.0.0:i386 libpulse0:i386 libasound2-plugins:i386
wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
sudo dpkg -i skype-install.deb

Question : Pourquoi Skype n'utilise-t-il pas le curseur par défaut de mon système ?

Réponse : Installez la variante 32 bits de libxcursor1.

# apt-get install libxcursor1:i386

Question : Pourquoi Skype n'utilise-t-il pas le thème par défaut de mon système ?

Réponse : Installez la variante 32 bits de gtk2-engines-murrine et gtk2-engines-pixbuf.

# apt-get install gtk2-engines-murrine:i386 gtk2-engines-pixbuf:i386

Utilisateurs KDE

Afin d'utiliser Skype sous KDE avec le thème du système, vous devez installer la variante 32 bits du moteur GTK2 du thème que vous utilisez. Puis, allez dans les options de Skype et spécifiez l'utilisation de GTK+ au lieu des paramètres du bureau.

Par exemple, si vous utilisez le moteur GTK du thème Oxygen pour vos applications GTK, vous devez alors installer :

# apt-get install gtk2-engines-oxygen:i386

Debian 7 « Wheezy »

32 bits / i386

Le paquet i386 fonctionne bien avec un système Debian 7 i386 standard.

Pour installer Skype, choisiez l'une des deux options suivantes :

Option 1 : En utilisant GDebi

Tapez les commandes suivantes dans un terminal :

# apt-get install gdebi
# wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
# gdebi skype-install.deb

GDebi installera automatiquement les dépendances requises.

Option 2 : Sans utiliser GDebi

Cette option est une méthode alternative d'installation de Skype, principalement pour les utilisateurs de KDE qui ne souhaitent pas installer les dépendances de GDebi.

Tapez les commandes suivantes dans un terminal :

# wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
# dpkg -i skype-install.deb

En utilisant dpkg, il pourrait y avoir des messages d'erreur concernant des dépendances manquantes. Pour corriger ces problèmes de dépendances manquantes, exécutez :

# apt-get -f install

64 bits / amd64

  • Les instructions suivantes fonctionnent avec Debian 7.4 et 7.5. Si cela ne fonctionne pas, merci d'ouvrir un ticket sur le forum Skype.

  • A partir de Wheezy, Debian prend en charge Multi-Arch. Les paquets Skype pour i386 fonctionnent bien avec Multi-Arch.

Option 1 : En utilisant GDebi

D'abord, il faut activer Multi-Arch. Pour faire cela, tapez dans terminal les lignes de commandes suivantes en tant que Root :

# dpkg --add-architecture i386
# apt-get update

Puis, téléchargez le paquet i386 comme on l'a vu plus haut et installez-le :

# apt-get install gdebi
# wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
# gdebi skype-install.deb

Un certain nombre de paquets i386 seront installés, cependant soyez prudent à ceux que la commande ci-dessus risque de désinstaller, cela pourrait supprimer des paquets important comme openssh-server.

Skype est maintenant installé, il n'y a plus qu'à essayer.

Option 2 : Sans utiliser GDebi

Cette option est une méthode alternative d'installation de Skype, principalement pour les utilisateurs de KDE qui ne souhaitent pas installer les dépendances de GDebi.

D'abord, il faut activer Multi-Arch :

# dpkg --add-architecture i386
# apt-get update

Puis, téléchargez le paquet i386 comme on l'a vu plus haut et installez-le :

# wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
# dpkg -i skype-install.deb

En utilisant dpkg, il pourrait y avoir des messages d'erreur concernant des dépendances manquantes. Pour corriger ces problèmes de dépendances manquantes, exécutez :

# apt-get -f install

Si vous utilisez Gnome 3, afin d'accéder au menu Skype, déplacez votre souris jusqu'au coin droit en bas de votre écran, puis faites un click droit sur l'icône Skype.

Problèmes au lancement de Skype

Au lancement de Skype (un exécutable 32 bits natif) dans un environnement 64 bits, vous pourriez rencontrer l'erreur suivante avec Skype refusant de démarrer :

skype: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory

Jusqu'à présent ce problème n'a été rencontré qu'en environnement 64 bits. Voici la solution :

# ln -s /usr/lib/mesa-diverted/i386-linux-gnu/libGL.so.1 /usr/lib/i386-linux-gnu/

Questions fréquemment posées (F.A.Q.) pour Wheezy 64 bits

Question : Pourquoi Skype remonte le message « Skype can't connect », ou « Sign in failed » et « Server connect failed » ?
Réponse : Mettre à jour le logiciel Skype vers la version 4.3, sortie en mai 2014.

Pour mettre à jour Skype, suivez simplement les instructions ci-dessus.

Cette erreur est causée par le serveur d'authentification de Skype, qui force les utilisateurs Linux à mettre à jour vers la version 4.3.Merci à Clived pour cette solution :). Les version plus anciennes fonctionnent toujours, même après fin avril 2014, mais le serveur Skype ne les acceptera plus. Le message d'erreur pourrait être plus clair en invitant les utilisateurs Linux à mettre à niveau leur logiciel Skype.


Question : Pourquoi Skype ne peut pas utiliser ma webcam ?
Réponse : Vous avez probablement besoin de pré-charger v4l.

Essayez ceci :

LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so /usr/bin/skype 

L'utilisateur qui lance Skype doit aussi être un membre du groupe 'video'.

Notez aussi que si Activer la vidéo avec Skype est désactivé quand Skype démarre, il ne trouvera jamais la webcam (à partir de la version 4.3).

Donc vérifiez dans le menu Skype->Options->Vidéo->Activer la vidéo avec Skype, activez le, fermez Skype complètement (Vérifiez que ce soit bien le cas dans votre barre des tâches), puis démarrez le une nouvelle fois.

Pour l'architecture amd64, vous devrez peut être installer le paquet libv4l-0 pour l'architecture i386 :

# apt-get install libv4l-0:i386


Question : Pourquoi Skype ne se lance pas quand je clique sur le lanceur ? Pourquoi me retourne-t-il « symbol lookup error » quand j'essaye de le lancer depuis le terminal ?
Réponse : En utilisant un terminal, tapez les commandes suivantes pour lancer Skype :

LD_LIBRARY_PATH=/usr/lib/i386-linux-gnu/ /usr/bin/skype

  • Cette commande est un contournement. Elle lance Skype depuis le terminal et s'assure manuellement qu'il pointe vers la librairie i386 : /usr/lib/i386-linux-gnu/
  • La première partie du message d'erreur indiquait :

skype: symbol lookup error: skype: undefined symbol:
  • Cela part du principe que vous avez le paquet skype:i386 installé, et non le paquet pour amd64.
  • Cette erreur est due au fait que la transition vers le Multi-Arch permet d'avoir les librairies d'architectures différentes sur la même installation, comme i386 et amd64.
  • Sources de la réponse : Iwan / user29978


Question : Pourquoi je ne peux pas installer libqtwebkit4:i386 ?
Réponse : Si apt-get n'est pas capable d'installer libqtwebkit4:i386 comme dépendance, essayez de l'installer avec aptitude, si vous savez ce que vous faites.

Vous aurez probablement besoin de la version skype-debian_2.2.0.35-1_amd64.deb, puisque les nouvelles version ont un problème avec PulseAudio. Vous pouvez éditer le paquet deb pour résoudre les dépendances pour Wheezy. Le fichier de contrôle devrait avoir : Depends: libstdc++6 (>= 4.1.1-21), libasound2 (>> 1.0.14), libc6 (>= 2.13-1), libgcc1 (>= 1:4.1.1-21)


Question : Pourquoi Skype reste muet ?
Réponse : Si vous avez des problèmes de son, vous avez peut-être besoin de libpulse.

<!> Depuis la version 4.3.0 de Skype, le serveur PulseAudio doit être lancé, puisque le support d'ALSA a été supprimé. Les symptômes sont l'absence de son dans le programme et pas d'autres équipements que « défaut » listés dans les options du programme pour les microphones et les enceintes. La version 4.2.0 fonctionne avec ALSA, mais libpulse doit quand même être installé, comme décrit ci-dessous.

Vous pouvez installer libpulse avec :

# apt-get install libpulse0:i386

Si vous avez PulseAudio 4 et Skype 4.2 avec un son défectueux, utilisez plutôt cette solution :

1) Astuce avec la variable d'environnement PULSE_LATENCY_MSEC issue du forum Skype :

$ PULSE_LATENCY_MSEC=30 skype

2) Astuce issue de http://pc-freak.net : dans le fichier /etc/pulse/default.pa remplacez la ligne

load-module module-udev-detect

par

load-module module-udev-detect tsched=0

et relancez le serveur PulseAudio.


Si le microphone est trop faible avec pulseaudio et Skype 4.3, tapez F6 dans le alsamixer et choisissez la bonne entrée. https://askubuntu.com/a/95691/322045. En outre, vous pourriez vous apercevoir que cela n'est pas sauvegardé avec le reste d'ALSA, et de ce fait vous aurez besoin de le faire souvent... peut-être qu'un réglage de « Internal Mic Boost » à 100% dans amixer -c 0 à l'aide d'un script pourrait fonctionner...

Debian 6 « Squeeze »

Le site de Skype ne fournit plus de paquets développés spécialement pour Debian 6.0 : seulement pour Debian 7. Il y a un rapport de bogue sur le système de suivi de bogue public de Skype qui dénonce cela.

http://download.skype.com/linux/skype-debian_4.0.0.7-1_i386.deb fonctionne avec Debian 6.0. On ne sait pas s'il y aura de nouveaux paquets Skype faits pour Debian 6.0.

Si on veut la prise en charge de MSN Messenger et de Facebook on a besoin de Skype 4.1. http://download.skype.com/linux/skype-ubuntu-lucid_4.1.0.20-1_i386.deb — malgré le nom du fichier — paraît bien fonctionner avec Debian 6.0. La version 4.1 de Skype n'a pas encore été examinée pour ce wiki.

http://download.skype.com/linux/skype-debian_4.1.0.20-1_i386.deb ne marche pas avec Debian 6.0.6. Même si on peut forcer l'installation, le programme ne démarre pas.

http://download.skype.com/linux/skype-debian_4.0.0.7-1_i386.deb fonctionne avec Debian 6.0.6 x86_64 bien que l'architecture ne fonctionne pas ; on peut l'installer :

# apt-get install ia32-libs ia32-libs-gtk

puis exécuter la commande :

# dpkg -i --force-architecture skype-debian_4.0.0.7-1_i386.deb

Mise à jour de Skype

Installez simplement la nouvelle version de Skype.

Questions fréquemment posées (F.A.Q.) concernant la mise à jour de Skype

Question : J'ai essayé de mettre à jour Skype en installant la nouvelle version de Skype. Mais Skype est encore bogué ou ne fonctionne pas correctement. Que faire ?

Réponse : Avant toute chose, il est suggéré de sauvegarder toutes les données importantes de Skype afin de réduire le risque de pertes de données. Ceci étant, pour mettre à jour manuellement Skype, vous devrez effacer le dossier « .Skype » dans votre répertoire home avant d'installer une nouvelle version. Le répertoire « .Skype » contient vos informations personnelles ainsi que vos préférences. Sinon, Skype ne se lancera pas dans sa dernière version, comme vous pourrez le voir dans le titre de la fenêtre. Si vous avez réussi à lancer la version mise à jour, Skype vous demandera de signer des conditions générales d'utilisation. Si vous ne voyez pas le dossier « .Skype » dans votre dossier home, pressez Ctrl+H afin d'afficher les fichiers cachés.

Examen des paquets

Répertoires et fichiers

Le binaire est installé dans /usr/bin, quelques fichiers de données sont dans /usr/share un peu de documentation dans /usr/doc. Le fichier de configuration pour dbus a été déplacé dans /etc/dbus-1/system.d/.

Lintian

# lintian -v skype-debian_4.0.0.7-1_i386.deb 
N: Using profile debian/main.
N: Setting up lab in /tmp/temp-lintian-lab-iZ1DBQdipA ...
N: ----
N: Processing binary package skype (version 4.0.0.7-1, arch i386) ...
W: skype: hardening-no-relro usr/bin/skype
W: skype: changelog-not-compressed-with-max-compression changelog.Debian.gz
W: skype: new-package-should-close-itp-bug
E: skype: description-starts-with-package-name
W: skype: extended-description-line-too-long
W: skype: extended-description-line-too-long
W: skype: possible-unindented-list-in-extended-description
W: skype: extended-description-contains-empty-paragraph
W: skype: binary-without-manpage usr/bin/skype

Un journal des modifications est inclus dans un but de « conformité ». Mais il ne donne pas vraiment la liste des changements de version en version et il n'y a pas d'historique des versions.

Skype Web

https://web.skype.com est en version Beta. Il nécessite d'installer un greffon dans son navigateur. Ce greffon ne fournit pour le moment pas de prise en charge pour Debian, ni pour aucune autre distribution Linux. Skype Web ne fonctionne donc pas pour passer des appels Skype sur Linux. :(

Vous pouvez malgré tout utiliser Skype Web sur Debian en tant que messagerie instantanée pour discuter en ligne avec vos contacts.

Il est nécessaire d'utiliser un navigateur web moderne dans Debian tel que Iceweasel.

Pages similaires et sources :