Differences between revisions 2 and 3
Revision 2 as of 2013-02-17 14:16:41
Size: 3878
Comment: gallicize some links
Revision 3 as of 2015-12-01 09:24:19
Size: 3888
Editor: vauss
Comment: superutilisateur, typo & translation fix
Deletions are marked like this. Additions are marked like this.
Line 7: Line 7:
Line 23: Line 22:
Ce message d'erreur arrive si un simple utilisateur (qui n'a pas les droits du super-utilisateur essaye d'installer ou de retirer un paquet ou veut changer les informations sur l'état d'un paquet dans la base de données des paquets. Ce message d'erreur arrive si un simple utilisateur (qui n'a pas les droits du superutilisateur essaye d'installer ou de retirer un paquet ou veut changer les informations sur l'état d'un paquet dans la base de données des paquets.
Line 27: Line 26:
Ce message d'erreur arrive si le cache de Apt est plein Apt::Cache-Limit . Il est nécessaire d'ajouter une ligne au fichier de configuration de APT, /etc/apt/apt.conf, pour override la valeur par défaut. Ce message d'erreur arrive si le cache de Apt est plein Apt::Cache-Limit . Il est nécessaire d'ajouter une ligne au fichier de configuration de APT, /etc/apt/apt.conf, pour outrepasser la valeur par défaut.
Line 39: Line 38:
==== A non-root user is trying to add or remove packages ==== ==== Un simple utilisateur essaye d'installer ou de retirer un paquet ====
Line 41: Line 40:
Ce message d'erreur arrive si un simple utilisateur (qui n'a pas les droits du super-utilisateur essaye d'installer ou de retirer un paquet ou veut changer les informations sur l'état d'un paquet dans la base de données des paquets. Ce message d'erreur arrive si un simple utilisateur (qui n'a pas les droits du superutilisateur essaye d'installer ou de retirer un paquet ou veut changer les informations sur l'état d'un paquet dans la base de données des paquets.
Line 53: Line 52:
Apt-get sélectionne les paquets en fonction de votre liste de dépôts qui est dans le fichier /etc/apt/sources.list.
Line 54: Line 54:
apt-get sélectionne les paquets en fonction de votre liste de dépôts qui est dans le fichier /etc/apt/sources.list. Apt-get se sert de trois niveaux de paquets : stable, testing et unstable. Par exemple, au moment de la traduction de cette page, la version de Synaptic dans stable est 0.70, dans testing 0.75.12 et dans unstable 0.75.13.
Line 56: Line 56:
apt-get se sert de trois niveaux de paquets : stable, testing et unstable. Par exemple, au moment de la traduction de cette page, la version de synaptic dans stable est 0.70, dans testing 0.75.12 et dans unstable 0.75.13.

On peut essayer l'AptPinning pour installer un paquet d'unstable dans une version stable de Debian. Attention, l'installation d'un paquet peut entraîner l'installation de bibliothèques d'unstable et vous pouvez vous retrouver avec le "pire" des mélanges de stable et d'unstable. Il est plus sage de rechercher un paquet dans [[fr/Backports|backport]]
On peut essayer l'AptPinning pour installer un paquet d'unstable dans une version stable de Debian. Attention, l'installation d'un paquet peut entraîner l'installation de bibliothèques d'unstable et vous pouvez vous retrouver avec le "pire" des mélanges de stable et d'unstable. Il est plus sage de rechercher un paquet dans [[fr/Backports|backport]].
Line 61: Line 59:
Pour les débutants avec Debian qui n'ont pas les droits de super-utilisateur : Pour les débutants avec Debian qui n'ont pas les droits de superutilisateur :

Translation(s): English - Français - Italiano - 한국어(Korean)

(!) ?Discussion


Paquets Debian > Apt > apt-get


apt-get - utilitaire en ligne de commande de APT pour manipuler les paquets de Debian

apt-get est un utilitaire pour mettre à jour automatiquement votre système Debian et pour installer les paquets ou programmes de Debian !

Il appartient au système de gestion de paquets de Debian DebianPackageManagement.

Messages d'erreur

E: Could not open lock file /var/lib/dpkg/lock - open (13 Permission denied)

On tente d'exécuter plus d'une instance du gestionnaire de paquets

Ce message d'erreur arrive si on tente d'exécuter plus d'une instance du gestionnaire de paquets. Par exemple, si on met à jour, installe ou désinstalle un paquet avec apt-get, il n'est pas possible d'exécuter un autre programme de gestion de paquets, jusqu'à ce que la mise à jour soit terminée.

Un simple utilisateur essaye d'installer ou de retirer un paquet

Ce message d'erreur arrive si un simple utilisateur (qui n'a pas les droits du superutilisateur essaye d'installer ou de retirer un paquet ou veut changer les informations sur l'état d'un paquet dans la base de données des paquets.

E: Dynamic MMap ran out of room

Ce message d'erreur arrive si le cache de Apt est plein Apt::Cache-Limit . Il est nécessaire d'ajouter une ligne au fichier de configuration de APT, /etc/apt/apt.conf, pour outrepasser la valeur par défaut.

APT::Cache-Limit "33554432";

E: Error occurred while processing xfmedia-dev (NewVersion1)

E: Problem with MergeList /var/lib/apt/lists/foobar

E: The package lists or status file could not be parsed or opened.

E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

Un simple utilisateur essaye d'installer ou de retirer un paquet

Ce message d'erreur arrive si un simple utilisateur (qui n'a pas les droits du superutilisateur essaye d'installer ou de retirer un paquet ou veut changer les informations sur l'état d'un paquet dans la base de données des paquets.

Voir aussi


Pour les débutants avec Debian :

Apt-get sélectionne les paquets en fonction de votre liste de dépôts qui est dans le fichier /etc/apt/sources.list.

Apt-get se sert de trois niveaux de paquets : stable, testing et unstable. Par exemple, au moment de la traduction de cette page, la version de Synaptic dans stable est 0.70, dans testing 0.75.12 et dans unstable 0.75.13.

On peut essayer l'?AptPinning pour installer un paquet d'unstable dans une version stable de Debian. Attention, l'installation d'un paquet peut entraîner l'installation de bibliothèques d'unstable et vous pouvez vous retrouver avec le "pire" des mélanges de stable et d'unstable. Il est plus sage de rechercher un paquet dans backport.


Pour les débutants avec Debian qui n'ont pas les droits de superutilisateur :

Par exemple, si vous utilisez un simple serveur web partagé de Debian, vous ne pourrez pas utiliser apt-get. Vous trouverez dans cette page une bonne explication des des processus d'installation et de configuration, et allez-y.


On peut trouver d'autres serveurs non-officiels de paquets pour apt-get à l'adresse : http://www.apt-get.org

CategorySystemAdministration