Differences between revisions 16 and 17
Revision 16 as of 2016-06-15 21:34:43
Size: 8301
Comment: sync with english version
Revision 17 as of 2017-04-16 13:02:09
Size: 8299
Editor: vauss
Comment: sync with English master
Deletions are marked like this. Additions are marked like this.
Line 118: Line 118:
    # apt-get install gstreamer1.0-libav gstreamer1.0-plugins-good     apt-get install gstreamer1.0-libav gstreamer1.0-plugins-good

Translation(s): English - Français - Italiano - 简体中文 - Русский


Official Iceweasel Icon, used in Debian Package - by Ricardo Fernandez Fuentes (Tri-licensed under Gnu GPL, Gnu LGPL, and Mozilla Public License)

Qu'est-ce que Iceweasel ?

Iceweasel est un fork [de Firefox] avec les objectifs suivants :

  1. rétro-portage des correctifs de sécurité sur la version Debian stable.

  2. exclusion des éléments graphiques ayant la marque déposée Mozilla (à cause du point #1 ci-dessus)

À part cela, les deux logiciels sont pour l'essentiel identique, (citation du message de Roberto C. Sanchez dans la liste de diffusion debian-devel).

Firefox de nouveau distribué dans Debian

Comme cela est expliqué dans l'article The end of the Iceweasel Age, Firefox est de retour dans Debian avec ses nom et marque officiels.

À la demande de Mozilla (voir 815006), Debian fournit maintenant Mozilla « Firefox ESR » (édition longue durée - Extended Support Release) comme paquet firefox-esr. La politique normale de suivi de Debian, y compris la correction de bogues, s'applique au paquet.

Comment installer Iceweasel (Firefox)

Dans Debian Stretch et les versions suivantes, le paquet iceweasel est un paquet de transition qui installe le paquet firefox-esr.

<!> À la date du 9 juin 2016, le paquet Firefox-ESR remplace Iceweasel, et il est dans les dépôts de sécurité de Wheezy et Jessie.

Dans les versions antérieures à Debian Stretch, le paquet iceweasel est un paquet de transition pour Firefox-ESR comme cela est décrit plus haut. Il peut être installé à partir des dépôts Debian avec la commande :

aptitude install iceweasel

ou

# apt-get install iceweasel

Les versions en langue étrangère, telles que firefox-esr-l10n-fr, sont aussi disponibles.

La page de Wikipedia explique certains termes qualifiant les différentes versions.

Comment obtenir le logo Iceweasel dans Firefox

Le greffon Mozilla « Logo Iceweasel » applique le logo Debian Iceweasel à Firefox.

Actuellement (à la date du 11 avril 2016), il n'y a pas de paquet Debian pour installer ce greffon.

Greffons

Le dossier des greffons (plugins) est situé ici :

  •  /usr/lib/iceweasel/plugins

tandis que celui des greffons xul-ext pour Debian se trouvent là :

  •  /usr/lib/mozilla/extensions

pour plus d'informations sur les greffons d'Iceweasel, référez-vous à la section plugins de la page Mozilla.

Identification de l'application

Les chaînes d'identification ("User agent string") d'Iceweasel (à l'heure de rédaction) sont :

  • Debian Wheezy

    • Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20140429 Firefox/24.0 Iceweasel/24.5.0

Certains sites Internet vont fournir différent contenu en fonction de cette chaîne, ou empêcher l'accès. Vous pouvez changer la chaîne d'identification manuellement (about:config, general.useragent.override dans les préférences) ou via le greffon User Agent Switcher.

Par défaut, general.useragent.compatMode.firefox est sur "true", ce qui inclus "Firefox" dans la chaîne d'identification.

Site de Debian-Mozilla

Il s'agit d'une ressource où vous pouvez vous procurer les dernières versions de Iceweasel qui arriveront peut-être dans Debian d'abord dans experimental, unstable puis dans testing et enfin dans stable. Habituellement les versions abouties atteignent Debian unstable puis continuent leur diffusion vers stable, tandis que les versions beta sont diffusées dans experimental. La plupart des versions alpha se trouvent dans le dépôt mozilla.debian.net.

Vous pouvez aussi communiquer avec les mainteneurs de Debian-mozilla dans cette liste de diffusion aussi bien que sur le canal IRC #debian-mozilla sur irc.oftc.net.

Avertissement SSL / Secure Connection

Le message :

  •   Secure Connection Failed
      XXXX uses an invalid security certificate.
      The certificate is not trusted because it is self signed.
      The certificate is only valid for 00:16:b6:82:73:60
      (Error code: sec_error_untrusted_issuer)

peut être désactivé. Voir : http://changetheworldwithyourpassion.blogspot.com/2008/07/turn-off-secure-connection-failed-in.html

Personnaliser le profil par défaut

Les fichiers qui sont copiés dans le répertoire ~/.mozilla/firefox/ quand on crée un nouveau profil Iceweasel (quand le navigateur est lancé pour la première fois ou en utilisant, en ligne de commande, l'option -P) se trouvent dans le répertoire /etc/iceweasel/profile/. Ce sont ces fichiers qui rempliront le nouveau profil avec la configuration par défaut, les extensions et tout un tas d'autres choses.

Dépannage

Mon Iceweasel plante constamment sur un site web

  • Pour commencer, lancez Iceweasel sans charger les extensions ni les plugins et regardez si le problème persiste. Pour ce faire, utilisez l'option -safe-mode

   MOZILLA_DISABLE_PLUGINS=1 iceweasel -safe-mode
  • Si le problème disparaît, cela signifie que c'est une extension qui est responsable du problème. Sinon lire la suite !
  • Créez un nouvel utilisateur et essayez de reproduire le problème sur le nouveau compte utilisateur.
  • S'il n'y plus de problème avec Iceweasel sur le nouveau compte utilisateur, c'est que le dossier ~/.mozilla/firefox/ est corrompu.
  • pour être sûr que le dossier ~/.mozilla/firefox/ est corrompu, déplacez-le dans un autre dossier et relancez à nouveau Iceweasel

    mv ~/.mozilla/firefox/ ~/old_firefox
    iceweasel &
  • Si le problème disparaît, c'est bon. Sinon, vous pouvez demander de l'aide sur la mailing list debian-user en fournissant toutes les informations comme "la façon de reproduire le plantage", "la version d'Iceweasel que vous utilisez", et "la distribution que vous utilisez" etc., Enfin, si vous êtes sûr que c'est un bogue dans le paquet Iceweasel, merci de déposer un rapport de bogue sur le paquet Iceweasel.

Erreur de navigateur non supporté

  • Afin de naviguer sur les sites web comme mlsni.net qui autorise l'usage de Firefox mais pas celui d'Iceweasel, vous devrez changer l'identification de votre navigateur. Regardez la section "Identification de l'application" pour savoir comment la modifier.

Pas de support H.264 dans youtube

  • Afin de regarder des vidéos 720p dans youtube et en utilisant son lecteur HTML5, Gstreamer libav et les plugins Gstreamer issus de "good" doivent être installés. Pour les installer, exécutez la commande suivante :

    apt-get install gstreamer1.0-libav gstreamer1.0-plugins-good
  • Assurez-vous que les réglages de media.peerconnection.video.h264_enabled dans about:config sont à « true ».

  • Après avoir installé ces codecs, le lecteur HTML5 doit être requis depuis la page HTML5 de youtube.

Voir aussi