Differences between revisions 34 and 35
Revision 34 as of 2021-01-10 20:18:48
Size: 14576
Editor: vauss
Comment: sync with English version
Revision 35 as of 2021-02-27 20:06:23
Size: 2965
Editor: vauss
Comment: sync with English version
Deletions are marked like this. Additions are marked like this.
Line 7: Line 7:
La prise en charge du lecteur de Flash s'est terminée le 31 décembre 2020, et le greffon ne fonctionnera plus au 12 janvier 2021 : https://www.adobe.com/products/flashplayer/end-of-life.html# Si vous avez besoin de lire du contenu basé sur flash, il serait préférable d'utiliser à la place flashpoint : https://bluemaxima.org/flashpoint/ ou ruffle: https://ruffle.rs/ pour lire du contenu flash archivé tel que des jeux. La prise en charge du lecteur de Flash s'est terminée le 31 décembre 2020, et le greffon fonctionne plus depuis le 12 janvier 2021 : https://www.adobe.com/products/flashplayer/end-of-life.html# Si vous avez besoin de lire du contenu basé sur flash, il serait préférable d'utiliser à la place flashpoint : https://bluemaxima.org/flashpoint/ ou ruffle: https://ruffle.rs/ pour lire du contenu flash archivé tel que des jeux.
Line 10: Line 10:
/!\ Veuillez noter que Flash a eu sa prise en charge terminée à la fin de 2020. Vous devez donc migrer de Flash vers HTML5 dès que possible.
||<tablestyle="width:100%; text-align: left" style="border:0">{{https://upload.wikimedia.org/wikipedia/commons/3/32/Adobe_Flash_Player_v11_icon.png}}||<style="border:0;vertical-align: top;">'''Adobe Flash Player''' est une plate-forme multimédia utilisée pour ajouter des animations, des vidéos ou de l'interactivité à des pages Web. Flash est fréquemment utilisé pour des publicités ou des jeux.<<BR>>Cette page wiki décrit comment installer Adobe Flash Player, anciennement connu sous le nom de Macromedia Flash Player, sur un système Debian. Cette page sert de page d'accueil du paquet Debian DebianPkg:flashplugin-nonfree.<<BR>>Avant d'installer manuellement, vous devriez considérer l'utilisation de [[fr/PepperFlashPlayer|PepperFlashPlayer]] (avec [[fr/Freshplayerplugin|Freshplayerplugin]] si vous utilisez Firefox).||
/!\ Veuillez noter que Flash n'est désormais plus maintenu ou pris en charge depuis le 31 décembre 2020. Vous devez donc migrer de Flash vers HTML5 dès que possible.
||<tablestyle="width:100%; text-align: left" style="border:0">{{https://upload.wikimedia.org/wikipedia/commons/3/32/Adobe_Flash_Player_v11_icon.png}}||<style="border:0;vertical-align: top;">'''Adobe Flash Player''' était une plate-forme multimédia utilisée pour ajouter des animations, des vidéos ou de l'interactivité à des pages Web. Flash était fréquemment utilisé pour des publicités ou des jeux.<<BR>>Cette page wiki décrit comment installer Adobe Flash Player, anciennement connu sous le nom de Macromedia Flash Player, sur un système Debian. Cette page servait de page d'accueil du paquet Debian.||
Line 26: Line 26:
== Installation ==

=== Debian 9 Stretch ===
==== Firefox ====
1. Téléchargez la dernière version d'Adobe Flash Player pour Linux sur https://get.adobe.com/flashplayer/

 * Sur un système 64 bits, ce devrait être : flash_player_npapi_linux.x86_64.tar.gz<<BR>>
 * Sur un système 32 bits, ce devrait être : flash_player_npapi_linux.i386.tar.gz

Sinon, vous pouvez télécharger à partir de : https://get.adobe.com/flashplayer/otherversions/

2. Décompressez le fichier tar.gz : '''tar -xzf flash_player_npapi_linux*.tar.gz'''

3. Identifiez l'emplacement du répertoire des greffons du navigateur en fonction de votre distribution Linux et de votre version de Firefox :

''Exemple : Debian 9 Stretch + Firefox 52.4.0 (64-Bit): '''/usr/lib/mozilla/plugins/'''''

''Exemple : Debian 9 Stretch + Firefox 62+ (64-Bit): '''~/.mozilla/plugins/'''''

'''''*Veuillez noter que vous devez créer ce répertoire s'il n'existe pas*'''''

4. Copiez '''libflashplayer.so''' dans le répertoire des greffons de votre navigateur : '''sudo cp libflashplayer.so <emplacement_des_greffons_du_navigateur>'''

''Exemple : sudo cp libflashplayer.so /usr/lib/mozilla/plugins/''

5. Copiez les fichiers de configuration locaux de Flash Platter dans le répertoire /usr : '''sudo cp -r usr/* /usr'''
  
6. Redémarrez Firefox.

==== Chromium ====

1. Téléchargez la dernière version d'Adobe Flash Player pour Linux sur https://get.adobe.com/flashplayer/
 * Sur des systèmes 64 bits, ce devrait être : flash_player_ppapi_linux.x86_64.tar.gz<<BR>>
 * Sur des systèmes 32 bits, ce devrait être : flash_player_ppapi_linux.i386.tar.gz

2. Décompressez le fichier tar.gz : '''tar -xzf flash_player_ppapi_linux*.tar.gz'''

3. Copiez '''libpepflashplayer.so''' vers le répertoire lib approprié : '''sudo cp libflashplayer.so <browserpluginlocation>'''

''Exemple : sudo cp flash/libflashplayer.so /usr/local/lib''

4. Vérifiez la version du greffon flash à partir du fichier manifest.json

''Exemple : grep version flash/manifest.json''

   "version": "31.0.0.153",

5. Redémarrez Chromium avec les paramètres d'emplacement et de version du greffon flash : '''chromium --ppapi--flash-path=<browserpluginname> --ppapi-flash-version=<browserpluginversion>'''

''Exemple : chromium --ppapi-flash-path=/usr/local/lib/libpepflashplayer.so --ppapi-flash-version=31.0.0.153''

=== Installation semi-automatique et/ou mise à jour pour Mozilla Firefox sur Debian 9 Stretch ===

1. Téléchargez et exécutez ce script shell ([[https://github.com/cybernova/fireflashupdate|fireflashupdate]]) avec les commandes suivantes :
{{{
wget https://raw.githubusercontent.com/cybernova/fireflashupdate/master/fireflashupdate.sh
chmod +x fireflashupdate.sh
./fireflashupdate.sh
}}}

2. Redémarrez Firefox
Line 89: Line 27:
''Note : flashplugin-nonfree n'est pas dans la distribution stable. Référez-vous à la section [[fr/FlashPlayer#Mise_.2BAOA_jour_manuelle|Mise à jour manuelle]]''.

 1. Vérifiez que le fichier /etc/apt/sources.list comprend la section contrib (pour plus d'information consultez la page [[fr/SourcesList|sources.list]])
 1. Installez flashplugin-nonfree (depuis la section contrib).
{{{
# apt-get install flashplugin-nonfree
}}}

== Mise à jour ==

=== Mise à jour semi-automatique ===

Pour mettre à jour Adobe Flash Player :
{{{
# update-flashplugin-nonfree --install
}}}

Si cela échoue avec le message « ERROR: wget failed to download ... », essayez la [[fr/FlashPlayer#Mise_à_jour_manuelle|mise à jour manuelle]].

=== Mise à jour manuelle ===

Lorsque vous lancez `update-flashplugin-nonfree --install` pour pourriez rencontrer l'erreur suivante :

`ERROR: wget failed to download http://people.debian.org/~bartm/flashplugin-nonfree/D5C0FC14/fp.24.0.0.221.sha512.amd64.pgp.asc`

C'est malheureusement un [[https://bugs.debian.org/flashplugin-nonfree|bogue récurent]]. Cependant, vous pouvez quand même mettre à jour le greffon, manuellement, en suivant cette procédure :

  1. Téléchargez la dernière version du greffon au format tar.gz à l'adresse https://get.adobe.com/flashplayer/
  1. En tant que superutilisateur, extrayez le fichier tar.gz et copiez `libflashplayer.so` vers `/usr/lib/flashplugin-nonfree`
  1. Donnez au fichier les mêmes valeurs de permission/droit :
  {{{
  chmod 644 /usr/lib/flashplugin-nonfree/libflashplayer.so
  chown root:root /usr/lib/flashplugin-nonfree/libflashplayer.so
  }}}
  1. Vérifiez que les entrées `/etc/alternatives` appropriées sont correctes (cela ne devrait pas être nécessaire si le greffon fonctionnait correctement avant la mise à niveau)
  `update-alternatives --list flash-mozilla.so` devrait retourner `/usr/lib/flashplugin-nonfree/libflashplayer.so`
  Si ce n'est pas le cas, vous pouvez corriger cela avec :
  `update-alternatives --quiet --install /usr/lib/mozilla/plugins/flash-mozilla.so flash-mozilla.so /usr/lib/flashplugin-nonfree/libflashplayer.so 50`

(la procédure est basée sur celle suggérée à l'adresse : https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=851066#30)

Notez que le nom de fichier pourrait être libpepflashplayer.so pour la variante [[PepperFlashPlayer]].
''Note : le paquet flashplugin-nonfree package n'est plus empaqueté dans les versions de Debian depuis la fin 2020.
Line 134: Line 30:
Line 141: Line 36:
== Navigateurs compatibles ==
Line 142: Line 38:

 * [[Firefox]]
Line 145: Line 39:
 * [[fr/Chromium|Chromium]]
Line 149: Line 42:


== Rapport de bogues ==

Si vous découvrez un problème avec flashplugin-nonfree, veuillez le rapporter dans le système de suivi de bogues de Debian.

Néanmoins, nous ne pouvons pas modifier Adobe Flash Player pour résoudre les problèmes dans Debian.
Donc, si vous découvrez un problème avec Adobe Flash Player, rapportez-le à Adobe.

Si vous avez trouvé un moyen de contourner un problème, vous pouvez l'ajouter dans la partie « dépannage » ci-dessous.

== Dépannage ==

 * Proxy : Le paquet flashplugin-nonfree possède "sa propre solution" pour mettre en mémoire cache le gros fichier .tar.gz téléchargé de chez Adobe. En téléchargeant fp10.*.pgp.asc, on n'a pas le cache de flashplugin-nonfree. Le conseil de l'auteur de ce paragraphe est de ne pas utiliser un proxy avec un cache avec flashplugin-nonfree, parce la récupération de fp10.*.pgp.asc à partir du cache pourrait aboutir à l'installation d'une mise à jour de sécurité plus tard qu'il ne le faudrait. Si on doit utiliser un proxy parce que l'on n'a pas d'accès direct à internet, alors bien sûr, on n'a pas d'autre choix que d'utiliser le proxy. Dans ce cas, ceci devrait fonctionner : {{{
http_proxy=http://my.proxy.intranet:8080/ apt-get install flashplugin-nonfree
}}} ou bien encore cela : {{{
http_proxy=http://my.proxy.intranet:8080/ update-flashplugin-nonfree --install
}}} Ceci devrait aussi fonctionner : {{{
http_proxy=http://my.proxy.intranet:8080/ update-flashplugin-nonfree --install
}}}ou{{{
https_proxy=http://my.proxy.intranet:8080/ update-flashplugin-nonfree --install
}}}


 sinon, avec une variable d'environnement différente de http_proxy, regardez : http://www.gnu.org/software/wget/manual/html_node/Proxies.html

 * Rappelez-vous que si on a besoin que Flash Player fonctionne avec pulse, on peut demander à libasound de le faire dans le fichier {{{~/.asoundrc}}} : {{{
pcm.pulse {
    type pulse
}

ctl.pulse {
    type pulse
}

pcm.!default {
    type pulse
}

ctl.!default {
    type pulse
}
}}}
 * Pour vérifier le numéro de la version de Adobe Flash Player installée sur votre machine, allez voir la [[http://www.adobe.com/products/flash/about/|page About Flash Player]], ou, avec un clic droit sur le contenu exécuté par Flash Player, sélectionnez "About Adobe (or Macromedia) Flash Player" dans le menu. Si vous utilisez plusieurs navigateurs, vérifiez sur chacun d'entre eux. ([[http://www.adobe.com/support/security/|Source : Bulletins de sécurité de Flash player]]). Flash Player 11.2 est la dernière version de Flash Player pour Linux. Adobe continuera à fournir des mises à jour de sécurité. ([[http://www.adobe.com/software/flash/about/|Source]]).
 * Adobe a abandonné la prise en charge des processeurs sans SSE2 avec Linux (on peut vérifier la présence de SSE2 avec la commande {{{ grep ^flags /proc/cpuinfo}}} les lettres « sse2 » devraient apparaitre dans la liste) dans une révision mineure de Flash Player 11. Le lecteur continue à s'installer, mais il plante quand il est appelé. Cela affecte surtout les plus anciens processeurs 32bits d'AMD. Vous pouvez installer Flash Player 10 à partir du site d'Adobe, voir [[DebianBug:697339]].
 * Au cas où le plugin provoque une utilisation excessive du processeur, on peut essayer cela (au fait, l'accélération matérielle de Linux Flash Player est [[https://bugbase.adobe.com/index.cfm?event=bug&id=2992148|désactivé depuis FP 11]]) : créez le fichier {{{/etc/adobe/mms.cfg}}} : {{{
 # Adobe player settings
 AVHardwareDisable = 0
 FullScreenDisable = 0
 LocalFileReadDisable = 1
 FileDownloadDisable = 1
 FileUploadDisable = 1
 LocalStorageLimit = 1
 ThirdPartyStorage = 1
 AssetCacheSize = 10
 AutoUpdateDisable = 1
 LegacyDomainMatching = 0
 LocalFileLegacyAction = 0
 AllowUserLocalTrust = 0
 # DisableSockets = 1
 OverrideGPUValidation = 1
 EnableLinuxHWVideoDecode=1
}}}

Le décodage vidéo matériel était considéré comme [[http://helpx.adobe.com/flash-player/release-note/release-notes-flash-player-10-3.html|expérimental dans FP 10.3]] et n'est [[https://bugbase.adobe.com/index.cfm?event=bug&id=2992148|pas pris en charge dans FP 11]] pour des raisons de stabilité et il peut provoquer des plantages. Il n'est pas documenté dans le guide officiel Flash Player Admin Guides. Il est activé à la discrétion de l'utilisateur :{{{
 EnableLinuxHWVideoDecode = 1
}}}

 Sinon, une bonne solution pour les utilisateurs de netbooks avec une carte vidéo accélérée (telle que l'Intel 945GM) et un processeur Atom, est de revenir à la version FP 10, de cette manière, vous pourrez bénéficier à nouveau des fonctionnalités d'accélération du processeur, plutôt que de gaspiller ses capacités. Mais cela n'est pas recommandé parce qu'Adobe ne fournit plus de mises à jour de sécurité que pour FP 11.2.

 * Une lecture fluide avec Firefox est possible, il faut remplacer les options précédentes par celles-ci. Elles permettront une lecture haute définition fluide, avec accélération matérielle (ou sans accélération matérielle), dans le navigateur, sauf pour le plein écran haute définition qui dépend des capacités de votre machine.

{{{
AssetCacheSize = 50
LocalStorageLimit = 5
}}}

<<Anchor(flickering)>>

 * Si la fenêtre des navigateurs Chromium ou Google Chrome est vacillante ou clignotante en permanence sur certaines pages web, la cause de ce problème est Flash Player et les étapes suivantes pourrait le corriger.

  1. Regardez avec votre navigateur une page contenant une vidéo flash
  1. Cliquez avec le bouton droit de votre souris sur la vidéo, choisissez l'option "Paramètres" et décochez l'option « Activer l'accélération matérielle »
  1. Fermez le navigateur puis réouvrez-le, cliquez avec le bouton droit sur la vidéo, choisissez l'option « Paramètres » et cochez l'option « Activer l'accélération matérielle »
Line 239: Line 47:
Line 242: Line 49:
 * [[http://www.adobe.com/products/flashplayer/|Page d'accueil de Adobe Flash Player]]
 * [[DebianPkg:flashplugin-nonfree|Paquets flashplugin-nonfree dans Debian]]
Line 245: Line 50:
 * [[DebianBug:src:flashplugin-nonfree|Bogues du paquet source de flashplugin-nonfree]]

Translation(s): English - Español - Français - Italiano - Русский - 简体中文


Flash > Adobe Flash Player


La prise en charge du lecteur de Flash s'est terminée le 31 décembre 2020, et le greffon fonctionne plus depuis le 12 janvier 2021 : https://www.adobe.com/products/flashplayer/end-of-life.html# Si vous avez besoin de lire du contenu basé sur flash, il serait préférable d'utiliser à la place flashpoint : https://bluemaxima.org/flashpoint/ ou ruffle: https://ruffle.rs/ pour lire du contenu flash archivé tel que des jeux.

/!\ Veuillez noter que Flash n'est désormais plus maintenu ou pris en charge depuis le 31 décembre 2020. Vous devez donc migrer de Flash vers HTML5 dès que possible.

https://upload.wikimedia.org/wikipedia/commons/3/32/Adobe_Flash_Player_v11_icon.png

Adobe Flash Player était une plate-forme multimédia utilisée pour ajouter des animations, des vidéos ou de l'interactivité à des pages Web. Flash était fréquemment utilisé pour des publicités ou des jeux.
Cette page wiki décrit comment installer Adobe Flash Player, anciennement connu sous le nom de Macromedia Flash Player, sur un système Debian. Cette page servait de page d'accueil du paquet Debian.

Accord de licence pour l'utilisateur final de Adobe Flash Player

Les dernières versions du paquet flashplugin-nonfree de Debian contiennent cet avertissement dans la description du paquet :

WARNING: Installing this Debian package causes the
Adobe Flash Player to be downloaded from www.adobe.com.
The End User License Agreement of the Adobe Flash Player
is available at www.adobe.com.

Anciennes versions

Note : le paquet flashplugin-nonfree package n'est plus empaqueté dans les versions de Debian depuis la fin 2020.

Désinstallation

Pour désinstaller Adobe Flash Player et le paquet flashplugin-nonfree :

# update-flashplugin-nonfree --uninstall
# apt-get remove flashplugin-nonfree

Voir aussi

Liens externes


CategoryPermalink | CategoryProprietarySoftware | CategoryVideo | CategorySound