Asus EEE PC 900

Diese Seite ist gedacht als Sammelplatz für alle Informationen speziell zu diesem Modell.

Behebbare Probleme

Mikrofon

**Update**: Das Mikrofon funktioniert mit 2.6.26 aus Debian unstable. Wenn doch nicht, siehe ?../HowTo/Sound, Abschnitt "Installieren eines geupdateten Alsa".

Abspielen funktioniert bestens mit dem Kernel 2.6.25-2-686, aber das Mikrofon funktioniert nicht. Asus patchte den snd-intel Alsa-Kerneldriver um ihn auf dieser Hardware zum Laufen zu bringen. Diese Patches sind nur für das ursprüngliche Xandros verfügbar, das mit dem Linux Eee PC 900 kam.

Der gegenwärtige Testing Kernel für Debian, 2.6.25-2-686 enthält keine solchen Patches. Auch die alsa-source-1.0.16-2 nicht. Um das Mikrofon zu benutzen muss die letzte Version des alsa-driver 1.0.17 von http://www.alsa-project.org/main/index.php/Main_Page heruntergeladen, kompiliert und installiert werden.

./configure ; make ; make install funktioniert. Es gibt auch einen "schmutzigen Trick" um ein Debianpacket mit den 1.0.17 Treibern zu generieren, der vom gegenwärtigen 1.0.16-2 Packetmechanismus ausgeht:

apt-get install alsa-source
cd /usr/src
tar jxf alsa-driver.tar.bz2
cd modules
wget ftp://ftp.alsa-project.org/pub/driver/alsa-driver-1.0.17.tar.bz2
tar jxf alsa-driver-1.0.17.tar.bz2
cp -a alsa-driver/debian/ alsa-driver-1.0.17/
cd alsa-driver-1.0.17/
vim debian/changelog

Füge jetzt einige Linien Versionsinformationen zu Beginn des Files ein:

alsa-driver (1.0.17) unstable; urgency=low

  * Dirty update to latest upstream version to make Asus EEE PC 900 microphone work.

 -- Your Name <your@email.com> Sat, 26 Jul 2006 16:01 -0300

Generiere und installiere das Packet folgendermassen:

KVERS=$(uname -r) KSRC=/lib/modules/$(uname -r)/build make -f debian/rules binary_modules
dpkg -i ../alsa-modules-2.6.25-2-686_1.0.17_i386.deb

Nach einem Reboot sollte das Mikrofon nun funktionieren.

Lautstärketasten

Das Packet eeepc-acpi-scripts kommt mit einer Konfiguration für das Mixerdevice in /etc/default/eeepc-acpi-scripts die nicht mit dem 900er Modell funktioniert. Ändere die Bezeichnung auf Master:

VOLUME_LABEL='Master'

und es wird funktionieren.

Problemfälle

Touchpad

Das Synaptics Device wird vom xorg Treiber nicht erkannt:

(II) Synaptics touchpad driver version 0.14.6 (1406)
Synaptics0 no synaptics event device found
(**) Option "Device" "/dev/psaux"
(**) Option "SHMConfig" "true"
(**) Option "HorizEdgeScroll" "1"
Query no Synaptics: 6003C8

Trotzdem kann es benutzt werden, da es sich wie eine Standard PS/2 Maus verhält. Aber es ist nicht möglich spezifische Device Konfigurationen vorzunehmen, wie zB. horizontales Scrollen.

Asus hat den xorg synaptics Treiber gepacht damit diese Elantec Version richtig funktioniert. Aber der Quellcode ist nicht auffindbar. Weder Asus noch der Xandros Paketbeauftragte haben auf eMails reagiert die nach dem Quellcode gefragt haben.

Akku

Der GNOME Powermanager wird sich beklagen, die Batterie hätte nur 1% Kapazität. Soviel ich weiss, ist das ein ACPI Treiber Bug, der zu unsinnigen Werten führt. Lass Dich nicht beunruhigen, die Meldungen sind bedeutungslos. Mein Eee PC 900 arbeitet etwa 3:15 mit einer Ladung.

Der GNOME Powermanager wird nicht warnen oder einen Shutdown starten wenn die Batterie leer wird. Vielleicht ist der Treiber schuld, oder es könnte besser konfiguriert werden. Das braucht noch mehr Nachforschungen.

Sound

Der Soundtreiber (ALSA 1.0.17, wie oben beschrieben) zeigt einige Mängel wenn das System unter mässige Last kommt. zB führt das umschalten von Gnome Arbeitsflächen den Sound für einige Millisekunden unterbrechen. Ein wichtiges problem ist hierbei HAL, der von zeit zu Zeit kurz sehr viel prozessorleistung frisst (einige Sekunden) und jedesmal wird der Sound beeinträchtigt. Es wird auch berichtet, dass CPU scaling auf niedere Frequenzen den Sound stört. Manchmal führt dies zu einem "Robotereffekt" der nur aufgehoben werden kann, indem der Sound gestoppt und wieder neu gestartet wird (mplayer spezifisch).

Es muss noch abgeklärt werden, ob Asus den kernel 2.6.24.1 der mit Xandros kam, gepatcht hat.

Wireless

Nach einem Suspend funktioniert das Funknetztwerk nicht mehr (kein Netzwerk wird gefunden, obwohl es vorhanden scheint). Die Lösung ist es ab- und wieder anzuschalten mit Ctrl+F2. Eine automatische Lösung wird noch gesucht.