Differences between revisions 11 and 13 (spanning 2 versions)
Revision 11 as of 2020-07-20 04:42:04
Size: 2160
Editor: PaulWise
Comment: drop obsolete link
Revision 13 as of 2020-12-31 04:03:45
Size: 1869
Editor: PaulWise
Comment: modernise
Deletions are marked like this. Additions are marked like this.
Line 15: Line 15:
$ su
#
apt-get install build-essential cmake git m4 texinfo && exit
$ sudo apt install build-essential cmake git m4 texinfo
Line 39: Line 38:
$ su
#
cp target_firmware/*.fw /lib/firmware/ && exit
$ sudo cp target_firmware/*.fw /lib/firmware/
Line 46: Line 44:

--(With the new version of NetworkManager (Debian 10 Stretch & Bullseye) [[ath9k_htc]] can't establish connection with any AP. The current workaround is to disable wifi.scan-rand-mac-address by creating a configuration file specific to this usb wireless adapter:)--

Translation(s): English - Français


Open firmware for ath9k_htc

This page describes how to compile and install open firmware for the ath9k_htc driver on Debian systems.

There's also a binary version prepared for the debian archives in the package firmware-ath9k-htc

Installation

  1. Install required packages:

    $ sudo apt install build-essential cmake git m4 texinfo
  2. Clone the repo:

    $ git clone https://github.com/qca/open-ath9k-htc-firmware.git
    $ cd open-ath9k-htc-firmware
  3. Checkout the latest tagged release:

    $ git tag
    1.3.1
    1.3.2
    $ git checkout 1.3.2
  4. Build the toolchain:

    $ make toolchain

    If the tool chain doesn't build, try checking out master:

    $ git checkout master
    $ make toolchain
  5. Build the firmware:

    $ make firmware
  6. Install the firmware:

    $ sudo cp target_firmware/*.fw /lib/firmware/
  7. Connect the device to your system. The ath9k_htc kernel module is automatically loaded for supported devices.

  8. Configure your wireless interface as appropriate.

Fix the "Scan but not Connect" issue (NetworkManager)

This was due to a bug in wpasupplicant which has been fixed in Stretch (2:2.4-1+deb9u6), Buster (2:2.7+git20190128+0c1e29f-6+deb10u2), and Bullseye/unstable (2:2.9.0-12).

See Also


CategoryHardware | CategoryWireless