Ruby 2.2 compatibility