Differences between revisions 194 and 216 (spanning 22 versions)
Revision 194 as of 2020-02-17 04:59:53
Size: 2387
Comment:
Revision 216 as of 2020-09-20 09:52:49
Size: 2521
Comment:
Deletions are marked like this. Additions are marked like this.
Line 6: Line 6:
 * [[https://udd.debian.org/dmd.cgi?email1=debian-ocaml-maint%40lists.debian.org|Debian Maintainer Dashboard]]
Line 19: Line 20:
     * coccinelle (no longer requires camlp4, being [[https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=886679|updated]])
   * the following packages may be removed because they are [[https://discuss.ocaml.org/t/the-end-of-camlp4/4216/5|obsolete]]:
     * optcomp -> --(eliom, ocaml-deriving-ocsigen)--
 * lablgtk2
 * [[https://bugs.debian.org/967559|lablgtk2]]
Line 29: Line 27:
 * [[https://github.com/janestreet-deprecated/|deprecated]] packages by Jane Street:
   * type-conv -> --(ocaml-deriving-ocsigen)--
Line 34: Line 30:
StephaneGlondu
 * eliom 4.2-3 -> 6.10.1
 * js-of-ocaml 3.5.2 -> 3.5.2 + doc (needs odoc) + tests (needs ppx-expect)
 * ocaml-ctypes 0.15.1-1 -> 0.15.1 + tests
 * ppx-deriving 4.4-1 -> 4.4 + doc (needs odoc)
 * ppxlib 0.12.0-1 -> 0.12.0 + tests (needs cinaps)
[[https://salsa.debian.org/ocaml-team/opam-debian-switch/-/blob/master/newer-in-opam.txt|Packages that have newer versions in opam-debian-switch]]

= Existing packages that need new packages =

 * js-of-ocaml: doc (needs odoc) + tests (needs ppx-expect)
 * ppx-deriving: doc (needs odoc)
 * ppxlib: tests (needs cinaps)
Line 43: Line 40:
 * [[https://opam.ocaml.org/packages/odoc/|odoc]] (needed by ppx-deriving doc) ([[https://bugs.debian.org/900674|RFP]])
 * [[https://opam.ocaml.org/packages/alcotest/|ocaml-alcotest]] (needed by tyxml tests)
[[https://salsa.debian.org/ocaml-team/opam-debian-switch/-/blob/master/newer-in-opam.txt|Packages present in opam-debian-switch but not in Debian]]

 * [[https://opam.ocaml.org/packages/alcotest/|ocaml-alcotest]] (needed by tyxml tests) ([[https://bugs.debian.org/956487|ITP]])
Line 47: Line 45:
 * [[https://opam.ocaml.org/packages/ppx_bin_prot/|ppx-bin-prot]] (maybe needed by future unison) ([[https://bugs.debian.org/951238|ITP]])
 * [[https://opam.ocaml.org/packages/ppx_here/|ppx-here]] (needed by ppx-bin-prot) ([[https://bugs.debian.org/951240|ITP]], in NEW)
 * [[https://opam.ocaml.org/packages/mew/|ocaml-mew]] (needed by ocaml-mew-vi) ([[https://bugs.debian.org/970626|ITP]], in NEW)
 * [[https://opam.ocaml.org/packages/cstruct/|ocaml-cstruct]] (needed by ocaml-hex) ([[https://bugs.debian.org/969043|ITP]], in NEW)
 * [[https://opam.ocaml.org/packages/hex/|ocaml-hex]] (needed by pgocaml) ([[https://bugs.debian.org/969045|ITP]], waiting for ocaml-cstruct)
 * [[https://opam.ocaml.org/packages/mew_vi/|ocaml-mew-vi]] (needed by lambda-term (>= 3.1.0)) ([[https://bugs.debian.org/970627|ITP]], waiting for ocaml-mew)

See also ../OCamlTransitions

Release management

Deprecated or obsolete packages

  • camlp4

    • it is deprecated in favour of menhir, sedlex, ppx stuff, ..., camlp5
    • it is not key
    • notable packages in transitive closure:
      • cudf
      • sks
      • ocamlnet
  • lablgtk2

    • it is deprecated in favour of lablgtk3
    • it is not key
    • notable packages in transitive closure:
      • coq
      • unison
      • ocaml-cairo2, which is a build-dependency of lablgtk3!

New versions

Packages that have newer versions in opam-debian-switch

Existing packages that need new packages

  • js-of-ocaml: doc (needs odoc) + tests (needs ppx-expect)
  • ppx-deriving: doc (needs odoc)
  • ppxlib: tests (needs cinaps)

New packages

Packages present in opam-debian-switch but not in Debian