Differences between revisions 191 and 200 (spanning 9 versions)
Revision 191 as of 2020-02-13 04:00:23
Size: 2696
Comment:
Revision 200 as of 2020-08-12 15:09:22
Size: 2272
Comment:
Deletions are marked like this. Additions are marked like this.
Line 6: Line 6:
 * [[https://udd.debian.org/dmd.cgi?email1=debian-ocaml-maint%40lists.debian.org|Debian Maintainer Dashboard]]
Line 19: Line 20:
     * coccinelle (no longer requires camlp4, being [[https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=886679|updated]])
Line 21: Line 21:
     * optcomp -> eliom (not in testing), ocaml-deriving-ocsigen
 * [[https://github.com/janestreet-deprecated/|deprecated]] packages by Jane Street:
   * js-build-tools ([[https://bugs.debian.org/950835|RM]])
   * type-conv -> ocaml-deriving-ocsigen
 * lablgtk2
     * optcomp -> --(eliom, ocaml-deriving-ocsigen)--
 * [[https://bugs.debian.org/967559|lablgtk2]]
Line 32: Line 29:
 * [[https://github.com/janestreet-deprecated/|deprecated]] packages by Jane Street:
   * type-conv -> --(ocaml-deriving-ocsigen)--
Line 44: Line 43:
 * [[https://opam.ocaml.org/packages/odoc/|odoc]] (needed by ppx-deriving doc) ([[https://bugs.debian.org/900674|RFP]])
Line 48: Line 46:
 * [[https://opam.ocaml.org/packages/ppx_bin_prot/|ppx-bin-prot]] (maybe needed by future unison) ([[https://bugs.debian.org/951238]])
 * [[https://opam.ocaml.org/packages/ppx_here/|ppx-here]] (needed by ppx-bin-prot) ([[https://bugs.debian.org/951240|ITP]], in NEW)

Maybe needed by a future parmap (>> 1.0~rc10?) release (see [[https://github.com/rdicosmo/parmap/pull/88|here]]):
 * [[https://opam.ocaml.org/packages/setcore/|ocaml-setcore]]
 * [[https://opam.ocaml.org/packages/bytearray/|ocaml-bytearray]]
 * [[https://opam.ocaml.org/packages/mew_vi/|ocaml-mew-vi]] (needed by lambda-term (>= 3.1.0))
 * [[https://opam.ocaml.org/packages/mew/|ocaml-mew]] (needed by ocaml-mew-vi)
 * [[https://opam.ocaml.org/packages/trie/|ocaml-trie]] (needed by ocaml-mew)

See also ../OCamlTransitions

Release management

Deprecated or obsolete packages

  • camlp4

    • it is deprecated in favour of menhir, sedlex, ppx stuff, ..., camlp5
    • it is not key
    • notable packages in transitive closure:
      • cudf
      • sks
      • ocamlnet
    • the following packages may be removed because they are obsolete:

      • optcomp -> eliom, ocaml-deriving-ocsigen

  • lablgtk2

    • it is deprecated in favour of lablgtk3
    • it is not key
    • notable packages in transitive closure:
      • coq
      • unison
      • ocaml-cairo2, which is a build-dependency of lablgtk3!
  • deprecated packages by Jane Street:

    • type-conv -> ocaml-deriving-ocsigen

New versions

StephaneGlondu

  • eliom 4.2-3 -> 6.10.1

  • js-of-ocaml 3.5.2 -> 3.5.2 + doc (needs odoc) + tests (needs ppx-expect)

  • ocaml-ctypes 0.15.1-1 -> 0.15.1 + tests

  • ppx-deriving 4.4-1 -> 4.4 + doc (needs odoc)

  • ppxlib 0.12.0-1 -> 0.12.0 + tests (needs cinaps)

New packages