Differences between revisions 185 and 194 (spanning 9 versions)
Revision 185 as of 2020-02-10 04:07:56
Size: 2312
Comment:
Revision 194 as of 2020-02-17 04:59:53
Size: 2387
Comment:
Deletions are marked like this. Additions are marked like this.
Line 5: Line 5:
 * [[https://qa.debian.org/developer.php?login=debian-ocaml-maint@lists.debian.org|Debian OCaml Maintainers' DDPO]]
Line 20: Line 21:
     * optcomp -> eliom (not in testing), ocaml-deriving-ocsigen
 * [[https://github.com/janestreet-deprecated/|deprecated]] packages by Jane Street:
   * js-build-tools ([[https://bugs.debian.org/950835|RM]])
   * type-conv -> ocaml-deriving-ocsigen
     * optcomp -> --(eliom, ocaml-deriving-ocsigen)--
Line 31: Line 29:
 * [[https://github.com/janestreet-deprecated/|deprecated]] packages by Jane Street:
   * type-conv -> --(ocaml-deriving-ocsigen)--
Line 34: Line 34:
[[https://qa.debian.org/developer.php?login=debian-ocaml-maint@lists.debian.org|Debian OCaml Maintainers' DDPO]]
Line 37: Line 35:
 * lwt 4.3.0-2 -> 5.1.1
 * js-of-ocaml 2.5-2 -> 3.5.2
Line 40: Line 36:
 * js-of-ocaml 3.5.2 -> 3.5.2 + doc (needs odoc) + tests (needs ppx-expect)
Line 49: Line 46:

Maybe needed by a future parmap (>> 1.0~rc10?) release (see [[https://github.com/rdicosmo/parmap/pull/88|here]]):
 * [[https://opam.ocaml.org/packages/setcore/|ocaml-setcore]]
 * [[https://opam.ocaml.org/packages/bytearray/|ocaml-bytearray]]
 * [[https://opam.ocaml.org/packages/ppx_expect/|ppx-expect]] (needed by js-of-ocaml tests)
 * [[https://opam.ocaml.org/packages/ppx_bin_prot/|ppx-bin-prot]] (maybe needed by future unison) ([[https://bugs.debian.org/951238|ITP]])
 * [[https://opam.ocaml.org/packages/ppx_here/|ppx-here]] (needed by ppx-bin-prot) ([[https://bugs.debian.org/951240|ITP]], in NEW)

See also ../OCamlTransitions

Release management

Deprecated or obsolete packages

  • camlp4

    • it is deprecated in favour of menhir, sedlex, ppx stuff, ..., camlp5
    • it is not key
    • notable packages in transitive closure:
      • cudf
      • sks
      • ocamlnet
      • coccinelle (no longer requires camlp4, being updated)

    • the following packages may be removed because they are obsolete:

      • optcomp -> eliom, ocaml-deriving-ocsigen

  • lablgtk2
    • it is deprecated in favour of lablgtk3
    • it is not key
    • notable packages in transitive closure:
      • coq
      • unison
      • ocaml-cairo2, which is a build-dependency of lablgtk3!
  • deprecated packages by Jane Street:

    • type-conv -> ocaml-deriving-ocsigen

New versions

StephaneGlondu

  • eliom 4.2-3 -> 6.10.1

  • js-of-ocaml 3.5.2 -> 3.5.2 + doc (needs odoc) + tests (needs ppx-expect)

  • ocaml-ctypes 0.15.1-1 -> 0.15.1 + tests

  • ppx-deriving 4.4-1 -> 4.4 + doc (needs odoc)

  • ppxlib 0.12.0-1 -> 0.12.0 + tests (needs cinaps)

New packages