Differences between revisions 1 and 195 (spanning 194 versions)
Revision 1 as of 2019-08-03 07:13:33
Size: 1162
Comment:
Revision 195 as of 2020-07-25 05:29:25
Size: 1993
Comment:
Deletions are marked like this. Additions are marked like this.
Line 1: Line 1:
= Misc = See also [[../OCamlTransitions]]
Line 3: Line 3:
 * [[https://bugs.debian.org/933722|eliminate camlp4]]
   * make camlp4 not key (it is [[https://udd.debian.org/cgi-bin/key_packages.yaml.cgi|key]] because of lwt because of ocaml-ctypes because of llvm-toolchain-7, it is however optional in this dependency chain)
= Release management =

 * [[https://qa.debian.org/developer.php?login=debian-ocaml-maint@lists.debian.org|Debian OCaml Maintainers' DDPO]]
 * [[https://release.debian.org/transitions/html/ocaml.html|OCaml transition tracker]]
 * [[https://people.debian.org/~nomeata/binNMUs-ocaml.txt|Suggested binNMUs]] by nomeata
 * [[https://tests.reproducible-builds.org/debian/unstable/amd64/pkg_set_maint_debian-ocaml.html|Reproducible builds of OCaml packages]]

= Deprecated or obsolete packages =

 * [[https://bugs.debian.org/933722|camlp4]]
   * it is deprecated in favour of menhir, sedlex, ppx stuff, ..., camlp5
   * it is not key
   * notable packages in transitive closure:
     * cudf
     * sks
     * ocamlnet
     * coccinelle (no longer requires camlp4, being [[https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=886679|updated]])
   * the following packages may be removed because they are [[https://discuss.ocaml.org/t/the-end-of-camlp4/4216/5|obsolete]]:
     * optcomp -> --(eliom, ocaml-deriving-ocsigen)--
 * lablgtk2
   * it is deprecated in favour of lablgtk3
   * it is not key
   * notable packages in transitive closure:
     * coq
     * unison
     * ocaml-cairo2, which is a build-dependency of lablgtk3!
 * [[https://github.com/janestreet-deprecated/|deprecated]] packages by Jane Street:
   * type-conv -> --(ocaml-deriving-ocsigen)--

= New versions =

StephaneGlondu
 * eliom 4.2-3 -> 6.10.1
 * js-of-ocaml 3.5.2 -> 3.5.2 + doc (needs odoc) + tests (needs ppx-expect)
 * ocaml-ctypes 0.15.1-1 -> 0.15.1 + tests
 * ppx-deriving 4.4-1 -> 4.4 + doc (needs odoc)
 * ppxlib 0.12.0-1 -> 0.12.0 + tests (needs cinaps)
Line 8: Line 43:
 * [[https://github.com/ocaml/caml-mode|caml-mode]] ([[https://bugs.debian.org/933241|ITP]] by Ralf Treinen)
 * [[https://github.com/ocaml/num|ocaml-num]] (needed by scilab and z3)

= Packages to upload =

Waiting for [[../OCamlTransitions|ocaml-result and others]] to [[https://tracker.debian.org/ocaml-result|migrate]]:
 * findlib 1.8.1-1
 * ocamlbuild 0.14.0-1
 * ocaml-zarith 1.8-1

= Packages to update =

StephaneGlondu
 * ocaml-dune 1.6.2 -> 1.11.0 (waiting processing of the NEW queue)
 * lwt 2.7.1 -> (2.7.1 with camlp4 disabled) -> 4.1.0
 * ocaml-ctypes 0.7.0 -> 0.15.1
 * cryptokit 1.11 -> 1.13
 * ocaml-csv 1.5 -> 2.2
 * ocaml-sqlite3 4.0.5 -> 4.1.3
 * ocaml-re 1.7.3 -> 1.9.0
 * cppo 1.6.4 -> 1.6.6
 * ocaml 4.05.0 -> [[https://ocaml.debian.net/transitions/ocaml-4.08.0|4.08.x]]

Kyle Robbertze
 * ocaml-ssl
 * liquidsoap
 * [[https://opam.ocaml.org/packages/alcotest/|ocaml-alcotest]] (needed by tyxml tests)
 * [[https://opam.ocaml.org/packages/markup/|ocaml-markup]] (needed by tyxml-ppx)
 * [[https://opam.ocaml.org/packages/ppx_expect/|ppx-expect]] (needed by js-of-ocaml tests)

See also ../OCamlTransitions

Release management

Deprecated or obsolete packages

  • camlp4

    • it is deprecated in favour of menhir, sedlex, ppx stuff, ..., camlp5
    • it is not key
    • notable packages in transitive closure:
      • cudf
      • sks
      • ocamlnet
      • coccinelle (no longer requires camlp4, being updated)

    • the following packages may be removed because they are obsolete:

      • optcomp -> eliom, ocaml-deriving-ocsigen

  • lablgtk2
    • it is deprecated in favour of lablgtk3
    • it is not key
    • notable packages in transitive closure:
      • coq
      • unison
      • ocaml-cairo2, which is a build-dependency of lablgtk3!
  • deprecated packages by Jane Street:

    • type-conv -> ocaml-deriving-ocsigen

New versions

StephaneGlondu

  • eliom 4.2-3 -> 6.10.1

  • js-of-ocaml 3.5.2 -> 3.5.2 + doc (needs odoc) + tests (needs ppx-expect)

  • ocaml-ctypes 0.15.1-1 -> 0.15.1 + tests

  • ppx-deriving 4.4-1 -> 4.4 + doc (needs odoc)

  • ppxlib 0.12.0-1 -> 0.12.0 + tests (needs cinaps)

New packages