Coordination for ocaml related backports.

Problematic: the backports available at http://www.backports.org/ need to be coordinated. As for testing, we need to rebuild every module with the latest ocaml package.

This comes for all newly introduced packages backported from testing that were not in the latest stable, as well as stable packages, when the ocaml version in backports.org in not the same as in stable.

Build dependencies can be very tricky. You have to keep in mind that they are resolved while trying to use as less as possible the packages from backports.org. From instance, if ocaml-findlib pulls ocaml-nox-3.09.x in current stable, and the source package also have a versioned build dependency on a more recent ocaml-nox, then the resolution will fail.

The safe solution for now is to version as much as possible the build dependencies when backporting. This also goes for ocaml related binary dependencies. Indeed, if your package binary-depends on an unversioned package, then the resolver will pull the one from stable and then fail for the very same reason...

Also, it's important to check that every build-dep has been built on all available archs before uploading a module depending on it. Indeed, there does not seem to have new build attempts after a failed build on backports.org

Instructions for preparing backports are available there:

Packages that depends on ocaml 3.09 on etch

A (possibly non exhaustive) list of packages that should be rebuild against the backported ocaml can be:

cairo-ocaml
calendar
cameleon
camlidl
camlimages
camlzip
camomile
cduce
cryptokit
extlib
facile
findlib
gdome2-xslt
gmetadom
lablgl
lablgtk2
lablgtkmathview
mlgmp
mlpcap
mysql-ocaml
numerix
ocamlagrep
ocaml-benchmark
ocamlcreal
ocamldap
ocaml-expat
ocaml-fileutils
ocaml-getopt
ocamlgraph
ocamlgsl
ocaml-http
ocaml-mad
ocamlnet
ocamlodbc
ocamlsdl
ocaml-sha
ocaml-shout
ocaml-ssl
ocaml-vorbis
ocurl
otags
ounit
pagodacf
pcre-ocaml
perl4caml
postgresql-ocaml
pxp
pycaml
syslog-ocaml
ulex
xml-light
xstr

(Command used to generate it: {{{cat Contents-i386 | grep usr/lib/ocaml/3.09.2/ | \ tr -s ' ' | cut -d' ' -f 2 | cut -d'/' -f2 | sort -u | \ while read i; do apt-cache showsrc "$i" | grep "Package: "; done | \ cut -d' ' -f 2 | sort -u}}})

Some of them are already backported, but a lot are missing. If you need one of them, feel free to pick it up, or contact us at [debian-ocaml-maint@lists.debian.org]