Differences between revisions 36 and 38 (spanning 2 versions)
Revision 36 as of 2012-02-12 11:22:07
Size: 8094
Comment: skktools fixed
Revision 38 as of 2012-02-15 23:14:31
Size: 8108
Comment: put skktools version in right column
Deletions are marked like this. Additions are marked like this.
Line 47: Line 47:
|| mgetty-fax || getopts.pl || N || [[http://bugs.debian.org/659425|#659425]] || || || || || mgetty-fax || getopts.pl || N || [[http://bugs.debian.org/659425|#659425]] || || ||false positive ||
Line 56: Line 56:
|| skktools || getopts.pl || N || [[http://bugs.debian.org/659427|#659427]] || || ||1.3.2-2 || || skktools || getopts.pl || N || [[http://bugs.debian.org/659427|#659427]] || || 1.3.2-2|| ||

Introduction

Perl 4 era libraries (*.pl) have been deprecated in 5.14 and have been removed for 5.16.

We would like to remove these references from packages before wheezy, so that we don't have to Depend on them for a release cycle, like we are with some other deprecated modules). See #629472 for more information.

The following Lintian warnings are currently defined:

The next step is to categorize each report according to whether the use of perl 4 libs is in the shipped software, or only as an example. The examples can probably be overridden, or at least would not block removal of the core libs in wheezy+1 on their own. It would be useful to also categorize which libraries are being used. This can all sit in a table on this wiki page.

Once this has been done, we can consider filing bugs against such packages with proposed patches. In some cases it may be possible to suggest an easy alternative; in some cases it may be appropriate just to add the dependency on libperl4-corelibs-perl.

Bug reports

http://bugs.debian.org/cgi-bin/pkgreport.cgi?users=debian-perl@lists.debian.org&tag=perl4-corelibs

Affected packages

Binary package name

Library/libraries used

Example only?

Debian bug filed?

Upstream bug filed?

Fixed in Debian?

Priority > optional

fvwm

getcwd.pl

N

#658917

info2man

flush.pl

N

#652499

1.1-6

libcgi-simple-perl

shellwords.pl

N

N

https://rt.cpan.org/Public/Bug/Display.html?id=71065

1.113-2

libperlmenu-perl

termcap.pl

N

#658931

adzapper

flush.pl

N

#658932

am-utils

ctime.pl

Y

N

amanda-server

newgetopt.pl

N

#658933

autoconf2.13

find.pl

N

#658450

2.13-61

cdrdao

getopts.pl

Y

#658944

cfengine2

getopts.pl

N

#658945

cgvg

find.pl

N

#658946

cvs

getopts.pl

N (but contrib)

#658947

2:1.12.13+real-7

cvs2html

getopts.pl, ctime.pl

N

#658948

1.98-3

dist

getopts.pl, shellwords.pl

N

#658949

dspam-webfrontend

ctime.pl

N

#658950

http://sourceforge.net/tracker/?func=detail&aid=3389943&group_id=250683&atid=1126467 (fixed)

3.10.1+dfsg-4

flowscan

getopts.pl

N

#659420

giflib-tools

getopts.pl

N

#659421

gnuplot-doc

ctime.pl

Y

N

gri

getopts.pl

N

#659422

ifmail

getopts.pl

N

#659423

imageindex

flush.pl

N

#659424

inn

getopts.pl

N

N (but fixes pending from maintainer)

libnet-rawip-perl

getopts.pl

Y

N

lsof

getopts.pl

Y

N

Y

mgetty-fax

getopts.pl

N

#659425

false positive

mgp

getopts.pl

N

#659426

mh-book

shellwords.pl, ctime.pl

Y

N

mrtg-contrib

find.pl, stat.pl

Y

N

nas-bin

getopts.pl

N

N

1.9.3-4

net-acct

ctime.pl

Y

N

pari-gp

newgetopt.pl

N

N

2.5.1-1

perlindex

find.pl

N

N

https://rt.cpan.org/Ticket/Display.html?id=74537

1.605-4

samba-doc

getopts.pl

Y

N

skktools

getopts.pl

N

#659427

1.3.2-2

ssake

getopts.pl

N

#659428

3.8-2

tedia2sql

getopts.pl

N

#659429

texlive-base

newgetopt.pl

N

#659430

Installed but not used

vim-runtime

getopts.pl

N

#659431

script not likely to be used

wu-ftpd

getopts.pl

N

#659432

wwwstat

getopts.pl

N

#659433

Common libraries in use

Library name

Number of occurrences

Notes on replacement

getopts.pl

22

Getopt::Long or Getopt::Std

ctime.pl

6

POSIX ctime function

find.pl

4

File::Find

flush.pl

3

IO::Handle

shellwords.pl

3

Text::?ParseWords::old_shellwords

newgetopt.pl

3

Getopt::Long

getcwd.pl

1

Cwd

termcap.pl

1

Term::Cap

Example bug report

Dear maintainer,

Your package PACKAGE currently uses one or more deprecated perl 4 era packages:

<insert cut and paste from lintian report>

As detailed at [1] we would like you to either add a dependency on

libperl4-corelibs-perl | perl (<< 5.12.3-7)

or (ideally) to replace their use with more modern equivalents.

If you prefer, I will NMU your package with the dependency added.

The wiki page [1] has references (taken from the source of the libraries in question) for the recommended replacement libraries.

Thanks, Dominic.

[1] <http://wiki.debian.org/Teams/DebianPerlGroup/OpenTasks/Transitions/Perl4CoreLibs>