Differences between revisions 11 and 12
Revision 11 as of 2013-01-26 00:25:15
Size: 899
Comment: Add link to Swedish translation
Revision 12 as of 2018-06-02 15:52:50
Size: 3009
Editor: OsamuAoki
Comment:
Deletions are marked like this. Additions are marked like this.
Line 10: Line 10:
 * Long answer: It isn't supported because 1. The packages' installation scripts (postinst...) are designed to handle upgrade only. 2. The installation tools are ''designed'' to replace older versions of packages by newer versions.  * Long answer: It isn't supported because
   
1. The packages' installation scripts (postinst...) are designed to handle upgrade only.
    
2. The installation tools are ''designed'' to replace older versions of packages by newer versions.
Line 15: Line 17:

== But I am desperate since I have no backup ... ==

There are some work around to save your system provided you know where your important data are. They may be in your home directory, `/etc/`, `/mail/`, ....

 1. If upgrade caused system breakage, boot your system with a live CD/USB-key etc., and make a backup of your private data to somewhere (USB connected HDD, SSH connected remote system, ...).
 2. Make a fresh new system install.
 3. Restore your private data from back up.

== But I am desperate and lazy ... ==

Here is a totally unsupported trick which may work under some lucky situation. (Desktop focused example)

System downgrade tends to be more successful, if there are not many packages installed. No GUI program and no TeX is good idea. I mean removing practically all non-essential packages is the trick :-) I know the following is very terse. If this is too cryptic, try the above method with live CD/USB-key, instead.

 1. Save data and stop all your Desktop tasks.
 1. CTRL-ALT-F3 to get to console and login as root.
 1. Start `aptitude -u`
 1. Press `l`
 1. Enter `~i!~prequired!~pimportant!~pstandard!~M!~skernel!~sadmin!~n^firmware` to dialog
 1. Press 'M' on 'Installed Packages' line and press '['.
 1. Press 'm' on key packages like 'vim' 'mc' 'git' 'ssh' 'exim4-daemon-light' ... (packages you need to keep)
 1. Press '+' on key packages to be installed.
 1. Press '+' again if key packages show 'B' to resolve broken dependency.
 1. Press 'g' (resolve broken dependency as needed).
 1. Exit `aptitude`.
 1. Edit `/etc/apt/sources.list` to point repository to the downgraded distribution.
 1. Set `apt_preferences`(5) to set the downgraded distribution with PIN 10001
 1. Run `apt update; apt full-upgrade`
 1. Run `aptitude -u` to interactively resolve issues.
 1. Remove `apt_preferences`(5) PIN.
 1. Run `aptitude -u` and install system. (Use `task` list in `aptitude` and information from backed up `/var/lib/dpkg/status`.)
 1. If you are lucky, you may have somewhat functioning system. No guarantee for the stability!!!

Translation(s): English - Français - Italiano - Svenska

What is "downgrading a system"?

In Debian world, it means to move to an older distribution (typically, to move from unstable to testing). Do not expect to get anything stable by downgrading!

Is it supported?

  • Short answer: No, it isn't supported.

  • Long answer: It isn't supported because
    1. The packages' installation scripts (postinst...) are designed to handle upgrade only.
    2. The installation tools are designed to replace older versions of packages by newer versions.

So, what's the supported way?

  1. Make a backup of your system before you upgrade, so you can restore your backup to "downgrade" it!
  2. or re-install.

But I am desperate since I have no backup ...

There are some work around to save your system provided you know where your important data are. They may be in your home directory, /etc/, /mail/, ....

  1. If upgrade caused system breakage, boot your system with a live CD/USB-key etc., and make a backup of your private data to somewhere (USB connected HDD, SSH connected remote system, ...).
  2. Make a fresh new system install.
  3. Restore your private data from back up.

But I am desperate and lazy ...

Here is a totally unsupported trick which may work under some lucky situation. (Desktop focused example)

System downgrade tends to be more successful, if there are not many packages installed. No GUI program and no TeX is good idea. I mean removing practically all non-essential packages is the trick :-) I know the following is very terse. If this is too cryptic, try the above method with live CD/USB-key, instead.

  1. Save data and stop all your Desktop tasks.
  2. CTRL-ALT-F3 to get to console and login as root.
  3. Start aptitude -u

  4. Press l

  5. Enter ~i!~prequired!~pimportant!~pstandard!~M!~skernel!~sadmin!~n^firmware to dialog

  6. Press 'M' on 'Installed Packages' line and press '['.
  7. Press 'm' on key packages like 'vim' 'mc' 'git' 'ssh' 'exim4-daemon-light' ... (packages you need to keep)
  8. Press '+' on key packages to be installed.
  9. Press '+' again if key packages show 'B' to resolve broken dependency.
  10. Press 'g' (resolve broken dependency as needed).
  11. Exit aptitude.

  12. Edit /etc/apt/sources.list to point repository to the downgraded distribution.

  13. Set apt_preferences(5) to set the downgraded distribution with PIN 10001

  14. Run apt update; apt full-upgrade

  15. Run aptitude -u to interactively resolve issues.

  16. Remove apt_preferences(5) PIN.

  17. Run aptitude -u and install system. (Use task list in aptitude and information from backed up /var/lib/dpkg/status.)

  18. If you are lucky, you may have somewhat functioning system. No guarantee for the stability!!!