Differences between revisions 3 and 4
Revision 3 as of 2006-09-10 10:03:25
Size: 4845
Comment:
Revision 4 as of 2006-09-10 10:05:59
Size: 2415
Comment:
Deletions are marked like this. Additions are marked like this.
Line 1: Line 1:
== RollbackUpdate == ' Last security update of mozilla-browser makes the browser crash when logging to my live journal account. Rolling back to the previous version solved ( temporarly) the problem
Line 4: Line 4:
The last security update of Debian 3.1 for mozilla-browser introduced a bug that makes the browser crash when loggin in my livejournal account. I went back to the previous version and it worked ok.


---- /!\ '''Edit conflict - other version:''' ----
Line 60: Line 56:

---- /!\ '''Edit conflict - your version:''' ----
 * Find the version of the faulty package
{{{ export COLUMNS=132

dpkg -l mozilla-browser
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé
|/ Err?=(aucune)/H=à garder/besoin Réinstallation/X=les deux (État,Err: majuscule=mauvais)
||/ Nom Version Description
+++-===========================-===========================-======================================================================
ii mozilla-browser 1.7.8-1sarge7.2.1 The Mozilla Internet application suite - core and browse }}}

 * Find the previous version of the browser
Doing a package search on http://www.debian.org/distrib/packages show me that last version before update was
2:1.7.8-1sarge7.1
If you need an older version version of the package, you can have a look at http://snapshot.debian.net

( note the unexplained 2: before the package version )

 * Downgrade the package
{{{ apt-get install mozilla-browser=2:1.7.8-1sarge7.1
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  mozilla-browser: Depends: libnspr4 (= 2:1.7.8-1sarge7.1) but 2:1.7.8-1sarge7.2.1 is to be installed
E: Broken packages }}}


 * Resolve dependencies
{{{ apt-get install mozilla-browser=2:1.7.8-1sarge7.1 libnspr4=2:1.7.8-1sarge7.1 }}}

 * Pin point this two packages so further "at-get upgrade" won't upgrade then
You have to put in /etc/apt/preferences

{{{ Package: mozilla-browser
Pin: version 1.7.8-1sarge7.1
Pin-Priority: 1001

Package: libnspr4
Pin: version 1.7.8-1sarge7.1
Pin-Priority: 1001 }}}

 * Make bug report about the regression


---- /!\ '''End of edit conflict''' ----

' Last security update of mozilla-browser makes the browser crash when logging to my live journal account. Rolling back to the previous version solved ( temporarly) the problem

  • Find the version of the faulty package

{{{ export COLUMNS=132

dpkg -l mozilla-browser Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder | État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé |/ Err?=(aucune)/H=à garder/besoin Réinstallation/X=les deux (État,Err: majuscule=mauvais) ||/ Nom Version Description +++-===========================-===========================-====================================================================== ii mozilla-browser 1.7.8-1sarge7.2.1 The Mozilla Internet application suite - core and browse }}}

  • Find the previous version of the browser

Doing a package search on http://www.debian.org/distrib/packages show me that last version before update was 2:1.7.8-1sarge7.1 If you need an older version version of the package, you can have a look at http://snapshot.debian.net

( note the unexplained 2: before the package version )

  • Downgrade the package

{{{ apt-get install mozilla-browser=2:1.7.8-1sarge7.1 Reading Package Lists... Done Building Dependency Tree... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that the package is simply not installable and a bug report against that package should be filed. The following information may help to resolve the situation:

The following packages have unmet dependencies:

  • mozilla-browser: Depends: libnspr4 (= 2:1.7.8-1sarge7.1) but 2:1.7.8-1sarge7.2.1 is to be installed

E: Broken packages }}}

  • Resolve dependencies

 apt-get install mozilla-browser=2:1.7.8-1sarge7.1 libnspr4=2:1.7.8-1sarge7.1 

  • Pin point this two packages so further "at-get upgrade" won't upgrade then

You have to put in /etc/apt/preferences

{{{ Package: mozilla-browser Pin: version 1.7.8-1sarge7.1 Pin-Priority: 1001

Package: libnspr4 Pin: version 1.7.8-1sarge7.1 Pin-Priority: 1001 }}}

  • Make bug report about the regression