Differences between revisions 12 and 13
Revision 12 as of 2009-12-06 15:23:42
Size: 2470
Editor: ?Dererk
Comment: Minor fix on quoting ;)
Revision 13 as of 2012-11-04 12:18:19
Size: 2470
Editor: PaulWise
Comment: snapshot is an official service now
Deletions are marked like this. Additions are marked like this.
Line 21: Line 21:
If you need an older version version of the package, you can have a look at http://snapshot.debian.net If you need an older version version of the package, you can have a look at http://snapshot.debian.org

Rationale: It happened that a security update of mozilla-browser made the browser crash when logging to my live journal account. Rolling back to the previous version solved the problem until a new security update corrected the problem

  • Find the version of the faulty package

export COLUMNS=132

dpkg -l mozilla-browser
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé
|/ Err?=(aucune)/H=à garder/besoin Réinstallation/X=les deux (État,Err: majuscule=mauvais)
||/ Nom                         Version                     Description
+++-===========================-===========================-======================================================================
ii  mozilla-browser             1.7.8-1sarge7.2.1           The Mozilla Internet application suite - core and browse 
  • Find the previous version of the browser

Doing a package search on http://www.debian.org/distrib/packages show me that last version before update was 2:1.7.8-1sarge7.1 If you need an older version version of the package, you can have a look at http://snapshot.debian.org

  • Downgrade the package

apt-get install mozilla-browser=2:1.7.8-1sarge7.1
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  mozilla-browser: Depends: libnspr4 (= 2:1.7.8-1sarge7.1) but 2:1.7.8-1sarge7.2.1 is to be installed
E: Broken packages 
  • Resolve dependencies

apt-get install mozilla-browser=2:1.7.8-1sarge7.1 libnspr4=2:1.7.8-1sarge7.1 
  • Pin point this two packages so further "apt-get upgrade" won't upgrade then

You have to put in /etc/apt/preferences (create the file if it doesn't exist )

Package: mozilla-browser
Pin: version 1.7.8-1sarge7.1
Pin-Priority: 1001

Package: libnspr4
Pin: version  1.7.8-1sarge7.1
Pin-Priority: 1001 
  • Make bug report about the regression