Rationale: It happened that a security update of mozilla-browser made the browser crash when logging to my live journal account. Rolling back to the previous version solved the problem until a new security update corrected the problem

export COLUMNS=132

dpkg -l mozilla-browser
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé
|/ Err?=(aucune)/H=à garder/besoin Réinstallation/X=les deux (État,Err: majuscule=mauvais)
||/ Nom                         Version                     Description
ii  mozilla-browser             1.7.8-1sarge7.2.1           The Mozilla Internet application suite - core and browse 

Doing a package search on http://www.debian.org/distrib/packages show me that last version before update was 2:1.7.8-1sarge7.1 If you need an older version version of the package, you can have a look at http://snapshot.debian.org

apt-get install mozilla-browser=2:1.7.8-1sarge7.1
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  mozilla-browser: Depends: libnspr4 (= 2:1.7.8-1sarge7.1) but 2:1.7.8-1sarge7.2.1 is to be installed
E: Broken packages 

apt-get install mozilla-browser=2:1.7.8-1sarge7.1 libnspr4=2:1.7.8-1sarge7.1 

You have to put in /etc/apt/preferences (create the file if it doesn't exist )

Package: mozilla-browser
Pin: version 1.7.8-1sarge7.1
Pin-Priority: 1001

Package: libnspr4
Pin: version  1.7.8-1sarge7.1
Pin-Priority: 1001 

CategoryPackageManagement CategoryDebugging