Differences between revisions 117 and 118
Revision 117 as of 2017-11-24 19:58:39
Size: 9361
Comment: kde4libs: Patch available
Revision 118 as of 2017-12-12 15:19:30
Size: 9377
Editor: BoyuanYang
Comment: mark webkit-image as finished
Deletions are marked like this. Additions are marked like this.
Line 73: Line 73:
 * webkit-image DebianBug:784559 Its source is apparently not available anymore in the josm repository (?)
Line 186: Line 185:
 * webkit-image DebianBug:784559 Its source is apparently not available anymore in the josm repository -> RoM/RoQA removed

Qt4's WebKit removal

Template text to file bugs

Subject: Qt4's WebKit removal
Source: @FILLME@
User: debian-qt-kde@lists.debian.org
Usertags: qt4webkit-removal

Hi! As you might know we the Qt/KDE team are preparing to remove Qt4's WebKit
as announced in [announce].

[announce] <https://lists.debian.org/debian-devel-announce/2015/05/msg00001.html>

Basically we are about to get the last Qt4 point release and upstream is
migrating from WebKit to Blink in the Qt5 series, so we won't have much upstreams
support for maintaining Qt4's WebKit (Qt5's WebKit is expected to stay supported
until Qt6).

In order to make this move, all packages directly or indirectly depending on
the Qt4's WebKit library have to either get ported to Qt5 or eventually get
removed from the Debian repositories.

Therefore, please take the time and:
- contact your upstream (if existing) and ask about the state of a Qt5 
port of your application
- if there are no activities regarding porting, investigate whether there are 
suitable alternatives for your users
- if there is a Qt5 port that is not yet packaged, consider packaging it
- if both the Qt4 and the Qt5 versions already coexist in the Debian 
archives, consider removing the Qt4 version

= Porting =

Some of us where involved in various Qt4 to Qt5 migrations [migration] and we
know for sure that porting stuff from Qt4 to Qt5 is much much easier and less
painful than it was from Qt3 to Qt4.

We also understand that there is still a lot of software still using Qt4. In
order to ease the transition time we have provided Wheezy backports for Qt5.

Don't forget to take a look at the C++ API changes page [apichanges] whenever
you start porting your application.

[migration] http://pkg-kde.alioth.debian.org/packagingqtbasedstuff.html
[apichanges] http://doc.qt.io/qt-5/sourcebreaks.html

For any questions and issues, do not hesitate to contact the Debian Qt/KDE 
team at debian-qt-kde@lists.debian.org

Apps using Qt4's WebKit

Situation of apps and libraries using Qt4's ?WebKit

Reminder bugs filed against these packages

Remaining

Extra build dependencies

Qt4-specific

Below are all the sources which are specific to Qt4, and thus will not be ported; the only resolution will be their removal.

Done

  • algobox: Looks like a partial false positive. It's actually only available in Debian ports.

  • arc-gui-clients 784450 No upstream activity since 2014, but switched to Qt5

  • basic256 784452 Switched to Qt5

  • bibletime 816804 Bibletime 2.11 (released on 21 Dec 2016, Qt5-only) was uploaded

  • brewtarget 784453 Switched to Qt5 (package version 2.3.1-1)

  • calligra 784454 Updated to Qt5, only in experimental ATM.

  • calibre 784609

  • camitk 816805 Switched to Qt5

  • cantata 784456

  • cb2bib 784455

  • clam-networkeditor 784457 RoM

  • connectome-workbench 784458 Removed webkit dependency

  • creepy 784619 Removed from the archive (various reasons).

  • cutycapt 784459

  • dff 784616 Removed from the archive due to various reasons.

  • digikam 784460

  • erik 784617

  • fatrat 784461

  • fcitx-libpinyin 784462 The last 0.5.1 upstream version is Qt5-based

  • fontmatrix 784463 Removed from the archive, dead upstream.

  • fotowall 816806 Removed from the archive, dead upstream, will not work with Qt5.

  • freecad 784464 Removed dependency.

  • frescobaldi 784610 Switched to Qt5

  • gambas3 784465

  • gammaray 784466

  • gazebo 816800

  • gofigure2 816807 Removed from the archive, dead upstream.

  • goldencheetah 784467

  • goldendict 784468 Switched to Qt5.

  • gpsbabel 816808 Switched to Qt5.

  • hotot 784470 Removed from the archive, dead upstream. 743767

  • kadu 784472

  • kadu-mime-tex 784473

  • kalgebra 784474

  • kate4 816809

  • kbibtex 784475 Switched to Qt5.

  • kde-workspace 784478

  • kdepim-runtime 784481

  • kdeplasma-addons 784482

  • kdevelop 784483 Ported to Qt5

  • kdevelop-php-docs 784485 Removed from the archive, as merged with src:kdevelop-php

  • kdevplatform 784484 Ported to Qt5

  • ktorrent 784487 Switched to Qt5.

  • ktp-auth-handler 784488

  • ktp-text-ui 784489

  • kvirc 784490

  • libkgapi 784491

  • libqt4pas 784493 Fixed in experimental

  • marble 784492

  • mathgl 784495 and 867297

  • mediaconch 816810 Switched to Qt5

  • metview 784497

  • merkaartor 784494

  • mixxx 784496

  • monkeystudio 784498 Switched to Qt5

  • musescore 784499

  • navit 784500

  • nmapsi4 784501 Version 0.5 alpha released two years ago is based on Qt5; it was packaged

  • openlp 784614 Migrated to ?PyQt5.

  • openwalnut 784503 Removed - QA

  • owncloud-client 784504

  • paraview 784505 Removed the build dependency on ?QtWebKit

  • phantomjs 784506

  • plasma-widget-adjustableclock 784507 Removed, non functional without Plasma 4, no porting, RC buggy.

  • postbooks 784508 Switched to Qt5

  • postbooks-updater 784509 Removed dependency.

  • psi-plus 784510 Ported to Qt5.

  • pykde4 784511

  • pythonqt 816811 Removed webkit support.

  • python-qt4 784513

  • qgis 784514 Removed support until the final Qt5 can be uploaded.

  • qlandkartegt 784515

  • qmf 784516 Removed because it is a library without current reverse dependencies.

  • qt4-x11 Will get fixed on next upload, changes already in the repo.
  • qtruby 784517

  • quassel 784519

  • quiterss 784520

  • qupzilla 784521

  • qutecom 816812 Removed from the archive, dead upstream.

  • qzion 784522 RoM

  • recoll 784523

  • rocs 784525

  • shelxle 784526

  • skrooge 784527

  • smokeqt 784528

  • socnetv 784529

  • spyder 784613 ?PyQt4 -> ?PyQt5.

  • subsurface 784530 Removed due to other reasons

  • supercollider 784531 It was deemed a useless dependency.

  • swift-im 784532 Ported to Qt5

  • tulip 784533

  • turpial 784618 Removed due to other reasons

  • ugene/non-free 784534

  • utopia-documents 816813 Switched to Qt5

  • vtk6 784557

  • webissues 784558

  • webkit-image 784559 Its source is apparently not available anymore in the josm repository -> RoM/RoQA removed

  • wkhtmltopdf 784561