Intro

To package the xTuple / PostBooks web UI, it is necessary to package various build tools and dependencies.

The ITP bug is 742996

Dependencies

Item

License

Version constraints

Referenced by

ITP

Package

PostgreSQL

BSD-like

=9.1

-

-

postgresql-9.1

Note: jessie and Ubuntu moving to v9.3, xTuple must update

postgresql plv8

BSD-like

?

?

?

postgresql-9.3-plv8

Not in backports yet

libv8

?

?

postgresql plv8

?

libv8-3.14.5

Various versions exist, version in package name

backbone

?

?

package.json

?

node-backbone ?

csslint

?

?

package.json

662759

jshint license issue ("no evil"). Dependency should be made optional.

backbone-relational

MIT License

0.8.0

package.json

?

?

https://github.com/PaulUithol/Backbone-relational

moment

?

2.4.x

package.json

?

?

https://github.com/moment/moment

underscore.string

MIT License

2.3.3

package.json

718937

?

https://github.com/epeli/underscore.string

bcrypt

MIT License

0.7.x

package.json

?

?

https://github.com/ncb000gt/node.bcrypt.js

colors

MIT License

0.6.x

package.json

?

node-colors

https://github.com/Marak/colors.js

commander

MIT License

1.2.x

package.json

?

node-commander

https://github.com/visionmedia/commander.js

congruence

BSD like

1.2.4

package.json

?

?

https://github.com/tjwebb/congruence

connect-ensure-login

MIT License

0.1.x

package.json

?

?

https://github.com/jaredhanson/connect-ensure-login

ejs

MIT License

0.8.x

package.json

?

node-ejs

https://github.com/visionmedia/ejs

express

MIT License

3.1.x

package.json

?

node-express

https://github.com/visionmedia/express

ipp

MIT License

0.0.5

package.json

?

?

https://github.com/williamwicks/ipp

less

Apache v2

1.5.0

package.json

?

node-less

https://github.com/less/less.js

nodemailer

MIT License

0.3.x

package.json

?

?

https://github.com/andris9/nodemailer

passport

MIT License

0.1.x

package.json

?

node-passport

https://github.com/jaredhanson/passport

passport-http

MIT License

0.2.x

package.json

?

?

https://github.com/jaredhanson/passport-http