Differences between revisions 17 and 18
Revision 17 as of 2006-06-25 20:00:43
Size: 1445
Editor: SvenHoexter
Comment:
Revision 18 as of 2006-07-06 14:51:32
Size: 1239
Editor: SvenHoexter
Comment: Reflect the current state of the patches and other tasks
Deletions are marked like this. Additions are marked like this.
Line 17: Line 17:
  * Done for 02.htlatex_documentation.dpatch
* 01.boost_limits.dpatch - code seems to be reworked in the boost upstream source. Need to wait until the LyX upstream resyncs with the boost upstream. Alternative: Wait for LyX 1.5 where we can use an external boost lib from Debian.
  * 04.fix_manpages.dpatch is up for discussion on the [http://marc.theaimsgroup.com/?l=lyx-devel&m=115125539407629&w=2 lyx-devel Mailinglist]
 * Use sensible-browser.
 * Get the update-lyxrc script and the /etc/lyxrc vs. /usr/share/lyx/lyxrc.dist thing sorted out
  * 01.boost_limits.dpatch - code seems to be reworked in the boost upstream source. Need to wait until the LyX upstream resyncs with the boost upstream. Alternative: Wait for LyX 1.5 where we can use an external boost lib from Debian. 
 * Use sensible-browser, run-mailcap and/or xdg-open from the xdg-utils package in the configure.py script

LyX is collaboratively maintained in the pkg-lyx Alioth project. It is currently maintained by SvenHoexter, PerOlofsson and ?GeorgBaum.

TODO

  • Fix bugs in the BTS
  • Upload 1.4.2 (not released yet)

dvipost

lyx

  • Should we recommend rcs and dvipost or depend on them?
    • This problem applies to many of LyX's dependencies...
  • Send patches upstream.
    • 01.boost_limits.dpatch - code seems to be reworked in the boost upstream source. Need to wait until the LyX upstream resyncs with the boost upstream. Alternative: Wait for LyX 1.5 where we can use an external boost lib from Debian.
  • Use sensible-browser, run-mailcap and/or xdg-open from the xdg-utils package in the configure.py script