Differences between revisions 130 and 165 (spanning 35 versions)
Revision 130 as of 2011-02-02 20:27:08
Size: 1923
Editor: SvenHoexter
Comment:
Revision 165 as of 2018-02-04 22:45:24
Size: 2314
Editor: ?TobiasQuathamer
Comment: Update URL for fedora packaging
Deletions are marked like this. Additions are marked like this.
Line 1: Line 1:
LyX is collaboratively maintained in the pkg-lyx Alioth project. It is currently maintained by PerOlofsson and SvenHoexter. LyX is collaboratively maintained on salsa.debian.org.
It's currently maintained with the git-buildpackage toolchain in conjunction with pristine-tar and tarball imports, thus still disconnected
from the upstream git repository.
Line 3: Line 5:
 * Git repository [[http://git.debian.org/?p=pkg-lyx/lyx.git|Browse]]
 * (Old) Subversion repository at Alioth. [[http://svn.
debian.org/viewsvn/pkg-lyx|Browse]]
 * [[http://packages.qa.debian.org/lyx|Package Overview]]
 * Git repository [[https://salsa.debian.org/debian/lyx|Browse]]
 * [[https://tracker.debian.org/pkg/lyx|Package Overview]]
Line 10: Line 11:
 * Remove ttf-lyx transitional package. -> removed in git/master
   * Requires bug filling for remaining reverse dependencies.
   * Reassign all open bugs from ttf-lyx to fonts-lyx.
 * forward spelling patches to upstream and produce more of them - started with http://www.lyx.org/trac/ticket/10678 - closed, should be better with 2.3.x on-wards
Line 11: Line 16:
  * prefer-xdg-open - Will be Debian specific until all other issue with xdg-open are solved. [[http://www.mail-archive.com/lyx-devel@lists.lyx.org/msg133878.html|Discussion on lyx-devel.]]
  * fix-manpage-errors - fix the errors in tex2lyx.1. [[http://www.lyx.org/trac/ticket/6051|#6051]] (doesn't work any longer with LyX 2.0.0, needs to be redone completly (more or less))
 * Monitor the [[http://wiki.debian.org/OldPkgRemovals#defoma | defoma removal]] because of ttf-lyx.
 * Post-Squeeze: Finish the latex-xft-fonts -> ttf-lyx migration.
 * Bug for bogus exec permissions [[http://www.lyx.org/trac/ticket/7276 | 7276]]
  * prefer-xdg-open - Will be Debian specific until all other issue with xdg-open are solved. [[http://www.mail-archive.com/lyx-devel@lists.lyx.org/msg133878.html|Discussion on lyx-devel.]] sensible-editor has problems too, see [[http://www.lyx.org/trac/ticket/7448|#7448]].

== general notes ==
 * Since at least 2.1.0 there is a build dependency on bc to compare Qt versions, see also:
  * http://comments.gmane.org/gmane.editors.lyx.devel/137498
  * http://lists.alioth.debian.org/pipermail/pkg-lyx-devel/2014-September/006379.html
 * Lintian warning: "I: lyx: spelling-error-in-binary usr/bin/lyx collapsable collapsible" - got forwarded by SvenHoexter some time ago to upstream, but was declined by a general disagreement about the correct spelling depending on country you're in.
Line 19: Line 26:
 * [[http://pkgs.fedoraproject.org/gitweb/?p=lyx.git;a=summary|LyX packaging for Fedora]]
 * [[http://sources.gentoo.org/viewcvs.py/gentoo-x86/app-office/lyx/|LyX packaging for Gentoo]]
 * [[http://svn.mandriva.com/cgi-bin/viewvc.cgi/packages/cooker/lyx/current/| LyX packaging for Mandriva]]
 * [[https://apps.fedoraproject.org/packages/lyx|LyX packaging for Fedora]]
 * [[https://packages.gentoo.org/packages/app-office/lyx|LyX packaging for Gentoo]]

LyX is collaboratively maintained on salsa.debian.org. It's currently maintained with the git-buildpackage toolchain in conjunction with pristine-tar and tarball imports, thus still disconnected from the upstream git repository.

TODO

  • Remove ttf-lyx transitional package. -> removed in git/master

    • Requires bug filling for remaining reverse dependencies.
    • Reassign all open bugs from ttf-lyx to fonts-lyx.
  • forward spelling patches to upstream and produce more of them - started with http://www.lyx.org/trac/ticket/10678 - closed, should be better with 2.3.x on-wards

  • Send patches upstream. We should aim at having a minimal packaging, as much as possible should be sent upstream. Only Debian-specific and "packaging-specific" stuff should be kept.
    • prefer-xdg-open - Will be Debian specific until all other issue with xdg-open are solved. Discussion on lyx-devel. sensible-editor has problems too, see #7448.

general notes