Differences between revisions 3 and 70 (spanning 67 versions)
Revision 3 as of 2015-12-18 11:25:20
Size: 818
Editor: ?NikoTyni
Comment:
Revision 70 as of 2015-12-21 11:50:31
Size: 3668
Comment:
Deletions are marked like this. Additions are marked like this.
Line 1: Line 1:
Open issues for the Perl 5.22 transition + coordinaating Open issues for the Perl 5.22 transition + coordinating
Line 3: Line 3:
12:56 < ntyni> looks like qdbm and subversion are victims of an openjdk-7 jre SIGSEGV regression on arm64 = Issues which show up in the transition tracker =
Line 5: Line 5:
12:58 < ntyni> libdevel-bt-perl is a long-standing problem (#721421), IMO we should probably make the survive test suite failures as they generally seem to be issues in gdb rather libdevel-bt-perl sid-only packages excluded
Line 7: Line 7:
12:59 < ntyni> anyway libdevel-bt-perl is a leaf package I think so it can go for now https://release.debian.org/transitions/html/perl.html
Line 9: Line 9:
13:03 < ntyni> the wxwidgets version detection logic in libalien-wxwidgets-perl debian/rules is a bit and broke when wxwidgets3.0 acquired a +dfsg suffix in its version number  * ifeffi: DebianBug:808307 is in contrib, needs a manual upload
 * libpgplot-perl: DebianBug:808331 is in contrib, needs a manual upload
 * linux-tools: has been built against 5.22 but not showing up in tracker for some reason
 * libb-hooks-op-check-entersubforcv-perl: longstanding issue, can be removed from testing: (DebianBug:787499)
 * libdevel-findref-perl: (DebianBug:787446)
    * no rdeps, no idea why this hasn't already been autoremoved from testing
 * redhat-cluster: pochu dicussing with maintainers.
 * libdevel-beginlift-perl: dep libb-hooks-op-check-entersubforcv-perl, will be removed from testing
 * libembperl-perl: DebianBug:806897 long standing general issue, can be removed from testing
Line 11: Line 19:
13:15 < BTS> Opened #808284 (serious) in libalien-wxwidgets-perl 0.67+dfsg-2 by Axel Beckert (abe) «dependencies in binary package after BinNMU». https://bugs.debian.org/808284 == Done ==

 * [DONE] qdbm, subversion: these seem to be victims of an openjdk-7 jre SIGSEGV regression on arm64
    * both built after a give-back, wookey suspects a local problem on arm-arm-01 buildd
    * DebianBug:808453
 * [DONE, hopefully] libdevel-bt-perl seems fixable (DebianBug:808480)
 * [DONE] libalien-wxwidgets-perl: wxwidgets version detection logic broken and not binNMU safe (DebianBug:808284)
 * [DONE] rrdtool: FTBFS on mips: `FAIL: tune2` DebianBug:805391
   * also fails with CC=gcc-4.9
   * also fails with DEB_BUILD_OPTIONS=noopt
   * patch submitted, maintainer active
 * [DONE] postgresql-9.4: test suite failures
    * reproducible.d.n last successfully built this on 20151211
    * builds with libxml2_2.9.2+zdfsg1-4 on amd64, so regressed with 2.9.3+dfsg1-1
    * DebianBug:808325 filed
 * [DONE, as in: giveback + severity lowered] libsendmail-milter-perl: (DebianBug:807392)
 * [DONE] linux-tools: looks like it's defending against binNMUs or something
    * bug filed: DebianBug:808329
 * [DONE] libchemistry-formula-perl: depends on perlapi-* even though it's arch:all, presumably due to a packlist file that's in vendorarch
    * needs a sourceful upload to become installable again (DebianBug:808310)
 * [DONE] slic3r/s390x is b-d-uninstallable because of something with boost-1.58 or mpich (DebianBug:808444)
 * [DONE] uwsgi/powerpc has mono troubles (DebianBug:807688, DebianBug:808507)
 * [DONE] libprelude FTBFS everywhere with SWIG errors in the perl bindings
    * bug filed (DebianBug:808395)
    * patch added
 * [DONE] rrdtool: FTBFS on mips: `FAIL: tune2` DebianBug:805391
   * also fails with CC=gcc-4.9
   * also fails with DEB_BUILD_OPTIONS=noopt
   * patch submitted, maintainer active
 * libsbml: pochu will poke mono people


= Other issues =

== perl5 ==

(Dom mostly filing/fixing)

 * [DONE] html2wml: DebianBug:808189
 * amanda-common: DebianBug:808209, maintainer upload [[http://blog.calhariz.com/post/2015/12/20/Preview-of-amanda-3.3.7p1-1|pending]]
 * [DONE] ddclient: DebianBug:808210
 * [DONE: DELAYED/1] jailer: DebianBug:808218
 * [DONE] nas-bin: DebianBug:808232
 * [DONE] p10cfgd: DebianBug:808233
 * gwyddion-plugins (alternate only so not critical)
 * [DONE] swish++: DebianBug:808323
 * [DONE] troffcvt: DebianBug:808324
 * votca-csg: DebianBug:808321 (not in testing due to RC bug of dependency)
 * [DONE] wmanager: DebianBug:808327
 * [DONE] xpilot-extra: DebianBug:808413 NMUed with maintainer permission
 * geneweb (current version not in testing: 2 RC bugs: license, and FTBFS on various architectures): DebianBug:808390
 * [DONE] ippl: DebianBug:808412

== other fallout ==

 * acm: DebianBug:808489
   * patch sent

Open issues for the Perl 5.22 transition + coordinating

Issues which show up in the transition tracker

sid-only packages excluded

https://release.debian.org/transitions/html/perl.html

  • ifeffi: 808307 is in contrib, needs a manual upload

  • libpgplot-perl: 808331 is in contrib, needs a manual upload

  • linux-tools: has been built against 5.22 but not showing up in tracker for some reason
  • libb-hooks-op-check-entersubforcv-perl: longstanding issue, can be removed from testing: (787499)

  • libdevel-findref-perl: (787446)

    • no rdeps, no idea why this hasn't already been autoremoved from testing
  • redhat-cluster: pochu dicussing with maintainers.
  • libdevel-beginlift-perl: dep libb-hooks-op-check-entersubforcv-perl, will be removed from testing
  • libembperl-perl: 806897 long standing general issue, can be removed from testing

Done

  • [DONE] qdbm, subversion: these seem to be victims of an openjdk-7 jre SIGSEGV regression on arm64
    • both built after a give-back, wookey suspects a local problem on arm-arm-01 buildd
    • 808453

  • [DONE, hopefully] libdevel-bt-perl seems fixable (808480)

  • [DONE] libalien-wxwidgets-perl: wxwidgets version detection logic broken and not binNMU safe (808284)

  • [DONE] rrdtool: FTBFS on mips: FAIL: tune2 805391

    • also fails with CC=gcc-4.9
    • also fails with DEB_BUILD_OPTIONS=noopt
    • patch submitted, maintainer active
  • [DONE] postgresql-9.4: test suite failures
    • reproducible.d.n last successfully built this on 20151211
    • builds with libxml2_2.9.2+zdfsg1-4 on amd64, so regressed with 2.9.3+dfsg1-1
    • 808325 filed

  • [DONE, as in: giveback + severity lowered] libsendmail-milter-perl: (807392)

  • [DONE] linux-tools: looks like it's defending against binNMUs or something
  • [DONE] libchemistry-formula-perl: depends on perlapi-* even though it's arch:all, presumably due to a packlist file that's in vendorarch
    • needs a sourceful upload to become installable again (808310)

  • [DONE] slic3r/s390x is b-d-uninstallable because of something with boost-1.58 or mpich (808444)

  • [DONE] uwsgi/powerpc has mono troubles (807688, 808507)

  • [DONE] libprelude FTBFS everywhere with SWIG errors in the perl bindings
    • bug filed (808395)

    • patch added
  • [DONE] rrdtool: FTBFS on mips: FAIL: tune2 805391

    • also fails with CC=gcc-4.9
    • also fails with DEB_BUILD_OPTIONS=noopt
    • patch submitted, maintainer active
  • libsbml: pochu will poke mono people

Other issues

perl5

(Dom mostly filing/fixing)

  • [DONE] html2wml: 808189

  • amanda-common: 808209, maintainer upload pending

  • [DONE] ddclient: 808210

  • [DONE: DELAYED/1] jailer: 808218

  • [DONE] nas-bin: 808232

  • [DONE] p10cfgd: 808233

  • gwyddion-plugins (alternate only so not critical)
  • [DONE] swish++: 808323

  • [DONE] troffcvt: 808324

  • votca-csg: 808321 (not in testing due to RC bug of dependency)

  • [DONE] wmanager: 808327

  • [DONE] xpilot-extra: 808413 NMUed with maintainer permission

  • geneweb (current version not in testing: 2 RC bugs: license, and FTBFS on various architectures): 808390

  • [DONE] ippl: 808412

other fallout