Differences between revisions 1 and 48 (spanning 47 versions)
Revision 1 as of 2015-12-18 11:23:36
Size: 907
Editor: ?NikoTyni
Comment:
Revision 48 as of 2015-12-19 14:49:30
Size: 3126
Editor: ?GregorHerrmann
Comment: mark ddclient as DONE
Deletions are marked like this. Additions are marked like this.
Line 1: Line 1:
Open issues for the Perl 5.22 transition + coordinaating Open issues for the Perl 5.22 transition + coordinating
Line 3: Line 3:
12:56 < ntyni> looks like qdbm and subversion are victims of an openjdk-7 jre SIGSEGV regression on arm64
12:58 < ntyni> libdevel-bt-perl is a long-standing problem (#721421), IMO we should probably make the build
               survive test suite failures as they generally seem to be issues in gdb rather than
               libdevel-bt-perl
12:59 < ntyni> anyway libdevel-bt-perl is a leaf package I think so it can go for now
= Issues which show up in the transition tracker =
Line 9: Line 5:
13:03 < ntyni> the wxwidgets version detection logic in libalien-wxwidgets-perl debian/rules is a bit fragile
               and broke when wxwidgets3.0 acquired a +dfsg suffix in its version number
https://release.debian.org/transitions/html/perl.html
Line 12: Line 7:
 * [DONE] qdbm, subversion: these seem to be victims of an openjdk-7 jre SIGSEGV regression on arm64
    * ntyni asked about this on #debian-arm
    * both built after a give-back, wookey suspects a local problem on arm-arm-01 buildd
    * not sure if we should still file a bug, waiting for input from wookey
 * libdevel-bt-perl is a long-standing problem (DebianBug:721421)
   * we should probably make the survive test suite failures as they generally seem to be issues in gdb rather libdevel-bt-perl
   * but libdevel-bt-perl is a leaf package I think so it can go for now (ntyni)
 * [DONE] libalien-wxwidgets-perl: wxwidgets version detection logic broken and not binNMU safe (DebianBug:808284)
 * ifeffit is in contrib, needs a bug and a manual upload
    * bug filed (DebianBug:808307)
 * libpgplot-perl is in contrib, needs a bug and manual upload
    * bug filed (DebianBug:808331)
 * libb-hooks-op-check-entersubforcv-perl: longstanding issue, can be removed from testing: (DebianBug:787499)
 * libdevel-findref-perl: (DebianBug:787446)
    * no rdeps, no idea why this hasn't already been autoremoved from testing
 * libsbml: pochu will poke mono people
 * rrdtool: FTBFS on mips: `FAIL: tune2` DebianBug:805391
   * also fails with CC=gcc-4.9
   * also fails with DEB_BUILD_OPTIONS=noopt
   * claimed by ntyni
 * [DONE] postgresql-9.4: test suite failures
    * reproducible.d.n last successfully built this on 20151211
    * builds with libxml2_2.9.2+zdfsg1-4 on amd64, so regressed with 2.9.3+dfsg1-1
    * DebianBug:808325 filed
 * libsendmail-milter-perl: (DebianBug:807392)
 * [DONE] linux-tools: looks like it's defending against binNMUs or something
    * bug filed: DebianBug:808329
 * [DONE] libchemistry-formula-perl: depends on perlapi-* even though it's arch:all, presumably due to a packlist file that's in vendorarch
    * needs a sourceful upload to become installable again (DebianBug:808310)
 * slic3r/s390x is b-d-uninstallable because of something with boost-1.58 or mpich
 * uwsgi/powerpc has mono troubles
 * libprelude FTBFS everywhere with SWIG errors in the perl bindings
    * bug filed (DebianBug:808395)
    * patch added
Line 13: Line 42:
13:15 < BTS> Opened #808284 (serious) in libalien-wxwidgets-perl 0.67+dfsg-2 by Axel Beckert (abe) «Broken
             dependencies in binary package after BinNMU». https://bugs.debian.org/808284
= Other issues =

 * perl5 (Dom mostly filing/fixing)
   * [DONE: DELAYED/2] html2wml: DebianBug:808189
   * amanda-common: DebianBug:808209
   * [DONE] ddclient: DebianBug:808210
   * jailer: DebianBug:808218
   * nas-bin: DebianBug:808232
   * [DONE] p10cfgd: DebianBug:808233
   * gwyddion-plugins (alternate only so not critical)
   * [DONE] swish++: DebianBug:808323
   * [DONE] troffcvt: DebianBug:808324
   * votca-csg: DebianBug:808321 (not in testing due to RC bug of dependency)
   * wmanager: DebianBug:808327 (active maintainer, already fixed in git(?))
   * xpilot-extra (last upload 2006-04-20)
   * geneweb (current version not in testing: 2 RC bugs: license, and FTBFS on various architectures): DebianBug:808390
   * ippl

Open issues for the Perl 5.22 transition + coordinating

Issues which show up in the transition tracker

https://release.debian.org/transitions/html/perl.html

  • [DONE] qdbm, subversion: these seem to be victims of an openjdk-7 jre SIGSEGV regression on arm64
    • ntyni asked about this on #debian-arm
    • both built after a give-back, wookey suspects a local problem on arm-arm-01 buildd
    • not sure if we should still file a bug, waiting for input from wookey
  • libdevel-bt-perl is a long-standing problem (721421)

    • we should probably make the survive test suite failures as they generally seem to be issues in gdb rather libdevel-bt-perl
    • but libdevel-bt-perl is a leaf package I think so it can go for now (ntyni)
  • [DONE] libalien-wxwidgets-perl: wxwidgets version detection logic broken and not binNMU safe (808284)

  • ifeffit is in contrib, needs a bug and a manual upload
  • libpgplot-perl is in contrib, needs a bug and manual upload
  • libb-hooks-op-check-entersubforcv-perl: longstanding issue, can be removed from testing: (787499)

  • libdevel-findref-perl: (787446)

    • no rdeps, no idea why this hasn't already been autoremoved from testing
  • libsbml: pochu will poke mono people
  • rrdtool: FTBFS on mips: FAIL: tune2 805391

    • also fails with CC=gcc-4.9
    • also fails with DEB_BUILD_OPTIONS=noopt
    • claimed by ntyni
  • [DONE] postgresql-9.4: test suite failures
    • reproducible.d.n last successfully built this on 20151211
    • builds with libxml2_2.9.2+zdfsg1-4 on amd64, so regressed with 2.9.3+dfsg1-1
    • 808325 filed

  • libsendmail-milter-perl: (807392)

  • [DONE] linux-tools: looks like it's defending against binNMUs or something
  • [DONE] libchemistry-formula-perl: depends on perlapi-* even though it's arch:all, presumably due to a packlist file that's in vendorarch
    • needs a sourceful upload to become installable again (808310)

  • slic3r/s390x is b-d-uninstallable because of something with boost-1.58 or mpich
  • uwsgi/powerpc has mono troubles
  • libprelude FTBFS everywhere with SWIG errors in the perl bindings
    • bug filed (808395)

    • patch added

Other issues

  • perl5 (Dom mostly filing/fixing)
    • [DONE: DELAYED/2] html2wml: 808189

    • amanda-common: 808209

    • [DONE] ddclient: 808210

    • jailer: 808218

    • nas-bin: 808232

    • [DONE] p10cfgd: 808233

    • gwyddion-plugins (alternate only so not critical)
    • [DONE] swish++: 808323

    • [DONE] troffcvt: 808324

    • votca-csg: 808321 (not in testing due to RC bug of dependency)

    • wmanager: 808327 (active maintainer, already fixed in git(?))

    • xpilot-extra (last upload 2006-04-20)
    • geneweb (current version not in testing: 2 RC bugs: license, and FTBFS on various architectures): 808390

    • ippl