My computer:

USB

Sound

Processor

Disc units.

lspci

 0000:00:00.0 Host bridge: Silicon Integrated Systems ["SiS"] 651 Host (rev 02)
 0000:00:01.0 PCI bridge: Silicon Integrated Systems ["SiS"] Virtual PCI-to-PCI bridge (AGP)
 0000:00:02.0 ISA bridge: Silicon Integrated Systems ["SiS"] SiS85C503/5513 (LPC Bridge) (rev 25)
 0000:00:02.5 ["IDE"] interface: Silicon Integrated Systems ["SiS"] 5513 ["IDE"]
 0000:00:02.7 Multimedia audio controller: Silicon Integrated Systems ["SiS"] Sound Controller (rev a0)
 0000:00:03.0 USB Controller: Silicon Integrated Systems ["SiS"] USB 1.0 Controller (rev 0f)
 0000:00:03.1 USB Controller: Silicon Integrated Systems ["SiS"] USB 1.0 Controller (rev 0f)
 0000:00:03.3 USB Controller: Silicon Integrated Systems ["SiS"] USB 2.0  Controller0000:00:09.0 USB Controller: ["OPTi"] Inc. 82C861 (rev 10)
 0000:00:0a.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
 0000:01:00.0 VGA compatible controller: Silicon Integrated Systems ["SiS"] 65x/M650/740 PCI/AGP VGA Display Adapter

Audio

From dmesg.

Intel 810 + AC97 Audio, version 0.24, 02:11:06 Aug 26 2003 i810: SiS 7012 found at IO 0xdc00 and 0xd800, MEM 0x0000 and 0x0000, IRQ 9 i810_audio: Audio Controller supports 6 channels. i810_audio: Defaulting to base 2 channel mode. i810_audio: Resetting connection 0 ac97_codec: AC97 Audio codec, id: ?ALG32 (?ALC650) i810_audio: AC'97 codec 0, new EID value = 0x05c7 i810_audio: AC'97 codec 0, DAC map configured, total channels = 6

Alsaconf

?AlsaConf error messages:

Running update-modules...

depmod: *** Unresolved symbols in /lib/modules/2.4.21-xfs/misc/bttv-cards.o

depmod: *** Unresolved symbols in /lib/modules/2.4.21-xfs/misc/bttv-driver.o

Loading driver...

No state is present for card ?SI7012

Setting default volumes...

Now ALSA is ready to use.

For adjustment of volumes, use your favorite mixer.

Have a lot of fun!