Attachment 'dh-cm-upgrade.patch'

Download

   1 --- a/debian/control
   2 +++ b/debian/control
   3 @@ -8,7 +8,7 @@
   4  
   5  Package: openssh-client
   6  Architecture: any
   7 -Depends: ${shlibs:Depends}, debconf (>= 1.2.0) | debconf-2.0, adduser (>= 3.10), dpkg (>= 1.7.0), passwd, libssl0.9.8 (>= 0.9.8g-9)
   8 +Depends: ${shlibs:Depends}, ${misc:Depends}, debconf (>= 1.2.0) | debconf-2.0, adduser (>= 3.10), dpkg (>= 1.7.0), passwd, libssl0.9.8 (>= 0.9.8g-9)
   9  Recommends: xauth, openssh-blacklist, openssh-blacklist-extra
  10  Conflicts: ssh (<< 1:3.8.1p1-9), sftp, rsh-client (<<0.16.1-1), ssh-krb5 (<< 1:4.3p2-7)
  11  Replaces: ssh, ssh-krb5
  12 @@ -37,7 +37,7 @@
  13  Package: openssh-server
  14  Priority: optional
  15  Architecture: any
  16 -Depends: ${shlibs:Depends}, debconf (>= 1.2.0) | debconf-2.0, libpam-runtime (>= 0.76-14), libpam-modules (>= 0.72-9), adduser (>= 3.9), dpkg (>= 1.9.0), openssh-client (= ${binary:Version}), lsb-base (>= 3.2-13), libssl0.9.8 (>= 0.9.8g-9), openssh-blacklist, procps
  17 +Depends: ${shlibs:Depends}, ${misc:Depends}, debconf (>= 1.2.0) | debconf-2.0, libpam-runtime (>= 0.76-14), libpam-modules (>= 0.72-9), adduser (>= 3.9), dpkg (>= 1.9.0), openssh-client (= ${binary:Version}), lsb-base (>= 3.2-13), libssl0.9.8 (>= 0.9.8g-9), openssh-blacklist, procps
  18  Recommends: xauth, openssh-blacklist-extra
  19  Conflicts: ssh (<< 1:3.8.1p1-9), ssh-nonfree (<<2), ssh-socks, ssh2, sftp, rsh-client (<<0.16.1-1), ssh-krb5 (<< 1:4.3p2-7)
  20  Replaces: ssh, openssh-client (<< 1:3.8.1p1-11), ssh-krb5
  21 --- a/debian/openssh-server.postinst
  22 +++ b/debian/openssh-server.postinst
  23 @@ -448,6 +448,7 @@
  24  
  25  
  26  fix_doc_symlink
  27 +#DEBHELPER#
  28  create_sshdconfig
  29  check_idea_key
  30  create_keys
  31 --- a/debian/rules
  32 +++ b/debian/rules
  33 @@ -242,6 +242,8 @@
  34  
  35  binary-openssh-server: DH_OPTIONS=-popenssh-server
  36  binary-openssh-server: build install
  37 +	dh_config_model_upgrade --model_name Sshd -p openssh-server \
  38 +           --model_package libconfig-model-openssh-perl --model_version 1.206
  39  	dh_testdir
  40  	dh_testroot
  41  	dh_installdebconf

Attached Files

To refer to attachments on a page, use attachment:filename, as shown below in the list of files. Do NOT use the URL of the [get] link, since this is subject to change and can break easily.
  • [get | view] (2009-10-06 12:55:28, 9.4 KB) [[attachment:approx-add-model.patch]]
  • [get | view] (2009-10-06 12:45:14, 1.1 KB) [[attachment:approx-simple.patch]]
  • [get | view] (2009-09-14 12:31:18, 1.9 KB) [[attachment:dh-cm-upgrade.patch]]
  • [get | view] (2009-04-24 12:23:11, 17.4 KB) [[attachment:gui.png]]
  • [get | view] (2009-04-27 12:27:19, 11.1 KB) [[attachment:upgrade-minimal.patch]]
  • [get | view] (2009-06-30 16:49:45, 10.4 KB) [[attachment:upgrade-simple.patch]]
 All files | Selected Files: delete move to page

You are not allowed to attach a file to this page.