Differences between revisions 1 and 24 (spanning 23 versions)
Revision 1 as of 2017-06-14 19:07:37
Size: 3160
Editor: HubertChathi
Comment:
Revision 24 as of 2017-09-19 02:10:41
Size: 4983
Editor: HubertChathi
Comment: Babel is now in contrib
Deletions are marked like this. Additions are marked like this.
Line 1: Line 1:
= Matrix =
Line 3: Line 5:
= Clients = == Packaging ==
Line 5: Line 7:
 * [[https://github.com/matrix-org/purple-matrix|purple-matrix]] [[https://packages.debian.org/purple-matrix|in Debian sid]]
 * [[https://github.com/vector-im/riot-web|Riot]] no package nor ITP yet
   * depends on a lot of node packages that are not yet in Debiana
   * build-depends on npm > 2, which is not in Debian, and nodejs > 6, which is currently in experimental
 * [[https://github.com/QMatrixClient/Quaternion|quaternion]] [[https://bugs.debian.org/864375|ITP]]
 * [[https://github.com/mujx/nheko|nheko]] [[https://bugs.debian.org/864374|ITP]]
 * [[https://github.com/Ralith/nachat|nachat]] no package nor ITP yet -- seems to be abandoned upstream
Packaging team uses [[https://alioth.debian.org/projects/pkg-matrix/|Alioth]] with a [[https://lists.alioth.debian.org/mailman/listinfo/pkg-matrix-maintainers|mailinglist]].
Line 13: Line 9:
= Servers = Discussion about Matrix packaging takes place in [[https://matrix.to/#/#debian-matrix:matrix.org|#debian-matrix:matrix.org]].
Line 15: Line 11:
 * [[https://github.com/matrix-org/synapse|synapse]] [[https://packages.debian.org/matrix-synapse|in Debian sid]]
   * [[https://github.com/matrix-org/matrix-synapse-ldap3|matrix-synapse-ldap3]] no package nor ITP yet
 * [[https://github.com/matrix-org/dendrite|dendrite]] no package nor ITP yet (probably not stable enough to be uploaded, but initial packaging investigation could be done)
== Clients ==

 * [[https://github.com/matrix-org/purple-matrix|purple-matrix]]: [[https://packages.debian.org/purple-matrix|in Debian sid]]
 * [[https://github.com/vector-im/riot-web|Riot]]: no package nor ITP yet ([[https://bugs.debian.org/866502|RFP]])
   * depends on a lot of node packages that are not yet in Debian, including [[https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=805376|React]]
   * also depends on JavaScript version of olm, which is not buildable in Debian yet (see below)
   * build-depends on npm > 2, which is not in Debian
   * desktop version depends on Electron, which is not yet in Debian
 * [[https://github.com/QMatrixClient/Quaternion|quaternion]]: [[https://bugs.debian.org/864375|ITP]]/[[https://anonscm.debian.org/git/collab-maint/quaternion.git/|Git]], currently in NEW
 * [[https://github.com/mujx/nheko|nheko]]: [[https://bugs.debian.org/864374|ITP]]/[[https://anonscm.debian.org/cgit/collab-maint/nheko.git/|Git]], currently in NEW
 * [[https://github.com/torhve/weechat-matrix-protocol-script|weechat plugin]]: no package nor ITP yet. Has [[https://github.com/torhve/weechat-matrix-protocol-script/issues/50|known performance issues]].
 * [[https://github.com/Ralith/nachat|nachat]]: no package nor ITP yet -- seems to be abandoned upstream

== Servers ==

 * [[https://github.com/matrix-org/synapse|synapse]]: [[https://packages.debian.org/matrix-synapse|in Debian sid]]/[[https://anonscm.debian.org/cgit/collab-maint/matrix-synapse.git/|Git]]
   * [[https://github.com/matrix-org/matrix-synapse-ldap3|matrix-synapse-ldap3]] : [[https://packages.debian.org/matrix-synapse-ldap3|in Debian sid]]/[[https://anonscm.debian.org/cgit/collab-maint/matrix-synapse-ldap3.git/|Git]]
 * [[https://github.com/matrix-org/dendrite|dendrite]]: no package nor ITP yet (probably not stable enough to be uploaded, but initial packaging investigation could be done)
Line 19: Line 30:
 * [[https://ruma.io/|ruma]] no package nor ITP yet (probably not stable enough to be uploaded, but initial packaging investigation could be done)  * [[https://ruma.io/|ruma]]: no package nor ITP yet (probably not stable enough to be uploaded, but initial packaging investigation could be done)
Line 21: Line 32:
= Libraries/SDKs = == Libraries/SDKs ==
Line 23: Line 34:
 * [[https://matrix.org/git/olm|olm]] [[https://bugs.debian.org/847566|ITP]] (uploaded, waiting for NEW processing)  * [[https://matrix.org/git/olm|olm]]: [[https://packages.debian.org/source/sid/olm|in Debian]]
Line 25: Line 36:
 * [[https://github.com/matrix-org/matrix-js-sdk/|matrix-js-sdk]] no package nor ITP yet
   * depends on [[https://github.com/NegativeMjark/another-json|another-json]], which is not in Debian, but should be easy to package (or else maybe fall back on built-in JSON serialization)
 * [[https://github.com/matrix-org/matrix-js-sdk/|matrix-js-sdk]]: no package nor ITP yet
   * build-depends on [[https://babeljs.io/|Babel]], which is [[https://packages.debian.org/sid/node-babel-cli|in contrib]]
   * depends on [[https://
github.com/NegativeMjark/another-json|another-json]], which is not in Debian, but should be easy to package. But only needed by crypto code, so not needed until olm JavaScript is available
Line 28: Line 40:
 * [[https://github.com/matrix-org/matrix-python-sdk|matrix-python-sdk]] no package nor ITP yet
 * [[https://github.com/matrix-org/gomatrix|gomatrix]] no package nor ITP yet
 * [[https://github.com/matrix-org/matrix-appservice-node|matrix-appservice]] no package nor ITP yet
   * new upstream version depends on bluebird, which is not yet in Debian ([[https://bugs.debian.org/779305|RFP]])
 * [[https://github.com/matrix-org/matrix-python-sdk|matrix-python-sdk]]:
no package nor ITP yet
 * [[https://github.com/matrix-org/gomatrix|gomatrix]]: no package nor ITP yet
 * [[https://github.com/matrix-org/matrix-appservice-node|matrix-appservice]]: no package nor ITP yet
Line 32: Line 45:
 * [[https://github.com/matrix-org/matrix-appservice-bridge|matrix-appservice-bridge]] (JavaScript) no package nor ITP yet  * [[https://github.com/matrix-org/matrix-appservice-bridge|matrix-appservice-bridge]]: (JavaScript) no package nor ITP yet
Line 35: Line 48:
 * [[https://github.com/matrix-hacks/matrix-puppet-bridge|matrix-puppet-bridge]]: (JavaScript) no package nor ITP yet
   * depends on several packages that are not yet in Debian
Line 36: Line 51:
= Bridges/Bots/etc = == Bridges/Bots/etc ==
Line 38: Line 53:
 * [[https://github.com/matrix-org/matrix-appservice-gitter|matrix-appservice-gitter]]
 * [[https://github.com/matrix-org/matrix-appservice-irc|matrix-appservice-irc]]
 * [[https://github.com/matrix-org/matrix-appservice-slack|matrix-appservice-slack]]
 * [[https://github.com/matrix-org/go-neb|go-neb]]
 * [[https://github.com/matrix-org/matrix-ircd|matrix-ircd]]
 * [[https://github.com/matrix-org/matrix-appservice-gitter|matrix-appservice-gitter]]: no package nor ITP yet
 * [[https://github.com/matrix-org/matrix-appservice-irc|matrix-appservice-irc]]: no package nor ITP yet
 * [[https://github.com/matrix-org/matrix-appservice-slack|matrix-appservice-slack]]: no package nor ITP yet
 * [[https://github.com/matrix-org/go-neb|go-neb]]: no package nor ITP yet
 * [[https://github.com/matrix-org/matrix-ircd|matrix-ircd]]: no package nor ITP yet
 * [[http://search.cpan.org/~pevans/App-MatrixTool/|matrixtool]]: (command-line tool) no package nor ITP yet

Matrix

This page lists Matrix-related software, and their status in Debian.

Packaging

Packaging team uses Alioth with a mailinglist.

Discussion about Matrix packaging takes place in #debian-matrix:matrix.org.

Clients

  • purple-matrix: in Debian sid

  • Riot: no package nor ITP yet (RFP)

    • depends on a lot of node packages that are not yet in Debian, including React

    • also depends on ?JavaScript version of olm, which is not buildable in Debian yet (see below)

    • build-depends on npm > 2, which is not in Debian

    • desktop version depends on Electron, which is not yet in Debian
  • quaternion: ITP/Git, currently in NEW

  • nheko: ITP/Git, currently in NEW

  • weechat plugin: no package nor ITP yet. Has known performance issues.

  • nachat: no package nor ITP yet -- seems to be abandoned upstream

Servers

Libraries/SDKs

  • olm: in Debian

    • ?JavaScript version cannot be built due to unusable emscripten

  • matrix-js-sdk: no package nor ITP yet

    • build-depends on Babel, which is in contrib

    • depends on another-json, which is not in Debian, but should be easy to package. But only needed by crypto code, so not needed until olm ?JavaScript is available

    • browser version depends on browser-request, which is not in Debian

    • new upstream version depends on bluebird, which is not yet in Debian (RFP)

  • matrix-python-sdk: no package nor ITP yet

  • gomatrix: no package nor ITP yet

  • matrix-appservice: no package nor ITP yet

    • depends on morgan, which is not in Debian yet

  • matrix-appservice-bridge: (?JavaScript) no package nor ITP yet

    • depends on jayschema and nedb, which are not in Debian yet

    • also depends on matrix-appservice, above
  • matrix-puppet-bridge: (?JavaScript) no package nor ITP yet

    • depends on several packages that are not yet in Debian

Bridges/Bots/etc