Enhancement

Security

Runtime issues

FTBFS submitted patches

QA work

In details:

tagsoup (1.2.1-1) unstable; urgency=low

  * QA upload
  * New upstream release
  * Switched to source format 3.0 (quilt)
  * Bump Standards-Version to 3.9.2
  * debian/control:
    - Build-depend removed cdbs
    - Build-depend add javahelper
    - Build-depend debhelper set version at >= 8~
    - libtagsoup-java-doc depens on default-jdk-doc instead of classpath-doc
    - Updated Vcs-* since tagsoup is now orphaned and has moved to old/
  * debian/rules refreshed, now uses javahelper
  * debian patch 0000-fix-tagsoup-version.patch to avoid FTBFS
 -- Leo Iannacone <l3on@ubuntu.com>   Thu, 15 Dec 2011 16:04:39 +0100

upse (1.0.0-1) unstable; urgency=low

  * QA upload
  * Imported Upstream version 1.0.0
  * Switch to dpkg-source 3.0 (quilt) format
  * debian/rules
    + Drop patch/unpatch
    + Added required build-arch build-indep
  * debian/control:
    + New maintainer Debian QA Group (Closes: #632262)
    + Build-depend on zlib1g-dev
    + Update short description for libupse-dev package
    + Update package name libupse1 to libupse2
    + Do not build upse-audacious plugin, avoid FTBFS
      with audacious 2.4 (Closes: #620915)
      - new patch 0000-drop-upse-audacious-to-build-in-Makefile.patch
      - Removed audacious-dev as Build-Depends
  * debian/rules swithed to use dh $@
  * Bump Standards-Version: 3.9.2
  * Drop obsolete dpatches
  * Refresh fix soname patch in 0001-fix-soname.patch
  * Update debian/copyright at new format
  * Add debian/compat at version 8
  * Add symbols for package libupse2
 -- Leo Iannacone <l3on@ubuntu.com>   Tue, 13 Dec 2011 23:29:27 +0100

RM

Other packages

node-commander (2.2.0-1) unstable; urgency=medium
 .
   [ Leo Iannacone ]
   * New upstream release.
   * Install package.json and index.js in nodejs/commander
     folder instead of commander.js
   * debian/control:
     + bump standards-version 3.9.5
     + set node-should as build-depends
     + do not depend on keypress, not required
     + added homogenius description for Node.js packages
     + added myself as Uploader
     + update Vcs-* fields, move project to pkg-javascript.
   * debian/rules:
     + enable tests
     + remove override_dh_auto_install, no longer needed
   * debian/patch/001_nodejs-shebangs.patch
     + test/run patch to use nodejs command instead of node
   * drop debian/lintian-overrides, not needed.
 -- Mike Gabriel <sunweaver@debian.org>  Fri, 09 May 2014 15:15:25 +0200

node-express (4.1.1~dfsg-1) unstable; urgency=medium
 .
   [ upstream ]
   * New release.
     Closes: bug#742178.
 .
   [ Jonas Smedegaard ]
   * Use github.org (not npmjs.org) as upstream source.
   * List URLs to source and preferred upstream contact in copyright
     file.
   * Update Homebase URL.
   * Use license shortname Expat (not MIT).
   * Wrap License paragraph at 72 chars.
   * Repackage using CDBS, Licensed GPL-3+.
   * Update package relations:
     + Build-depend on cdbs.
     + Depend on node-range-parser, node-cookie, node-buffer-crc32,
       node-fresh, node-methods, node-send, node-cookie-signature,
       node-debug.
     + Stop depending on node-mime.
     + Relax to build-depend unversioned on debhelper: Needed version
       satisfied in stable, and oldstable is no longer supported.
   * Update short and long description, based on Homepage.
   * Update Vcs-* fields: Use anonscm.debian.org URLs.
   * Add myself as uploader.
   * Add git-buildpackage config:
     + Enable pristine-tar and signed tags.
     + Suppress .gitignore when importing upstream tarballs.
   * Git-ignore quilt .pc dir.
   * Install examples.
   * Repackage upstream tarball to exclude test image: Embedded ICC
     profile has copyright but lacks DFSG-free licensing.
     Have watch file mangle debian version.
 .
   [ Leo Iannacone ]
   * Fix watch file to mangle filename.
   * Install package.json.
   * Stop install executable "express": Moved to separate project
     express-generator.
     Drop related patch 01.
   * Update package relations:
     + Depend on node-parseurl, node-type-is, node-accepts,
       node-escape-html, node-merge-descriptors, node-path-to-regexp,
       node-serve-static and node-utils-merge.
     + Stop depending on node-connect or node-mkdirp.
     + Relax to depend unversioned on nodejs: Only supported versions
       exists in any official Debian suite now.
     + Build-depend on nodejs: Needed only as hint to resolve distro-wide
       source<->binary relationships.
     + Suggest node-express-generator: Provides executable "express".
   * Bump standards-version to 3.9.5.
   * Remove David Paleino as uploader (acknowledged by him).
   * Add myself as uploader.
   * Update Vcs-* fields: Packaging git moved to project area at Alioth.
 -- Jonas Smedegaard <dr@jones.dk>  Wed, 30 Apr 2014 18:31:24 +0200

node-iscroll (5.1.1+dfsg1-2) unstable; urgency=low
 .
   [ Leo Iannacone ]
   * Fix finding iscroll module from nodejs.
     It can't be loaded to nodejs however, since iScroll needs to be run
     in a browser window. It can be used from Browserify. (Closes: #747654)
   * Stop node-iscroll uselessly recommending javascript-common
 .
   [ Balint Reczey ]
   * Fix FTBFS with Make 4
 -- Balint Reczey <balint@balintreczey.hu>  Fri, 11 Apr 2014 13:30:20 +0200