Possible liblapack transition

Version 3.2 of the lapack library has been released and is now in experimental (package version 3.2.0-1). As regards the version currently in Debian unstable (3.1.1), the API has changed in the following way:

According to one of the upstream authors we contacted, the *LASQ* routines were not intended for normal end-user programs. These are highly specialized routines for internal use by the Lapack library itself. On the other hand, ZCGESV is a "new" end-user routine, although it was introduced experimentally in 3.1.1. It is unlikely that programs linking against liblapack3gf in Debian are using ZCGESV.

The packages listed below build-depend on liblapack-dev. The columns in the table show whether the package builds correctly against liblapack-dev 3.2.0-1 (the version currently in experimental) and whether any of its files need one of the symbols cited above (this test was done by running nm on all files contained in the package).

RafaelLaboissiere and ?SylvestreLedru are coordinating this transition.

package

version

need symbol

build

comments

abinit

5.3.4.dfsg-3

(./)

arpack

2.1+parpack96.dfsg-1

(./)

arpack++

2.3-1

(./)

atlas

3.6.0-24

(./)

cernlib

2006.dfsg.2-13.2

(./)

clp

1.9.0-1

(./)

coinutils

2.4.0-1

(./)

cvxopt

1.1-1

(./)

dsdp

5.8-6

(./)

geant321

3.21.14.dfsg-8

(./)

ghemical

2.98-2

(./)

gimp-plugin-registry

1.0-1

(./)

gretl

1.8.0-2

(./)

harminv

1.3.1-2

(./)

hypre

2.4.0b-1

(./)

jags

1.0.3-1

(./)

libghemical

2.98-2

(./)

libitpp

4.0.6-2

(./)

linbox

1.1.6~rc0-3

(./)

mclibs

2006.dfsg.2-5

(./)

meep

0.20.3-1

(./)

mn-fit

5.13-6

FTBFS on my amd64 sid chroot -- RL

mpb

1.4.2-12

(./)

mpqc

2.3.1-5

(./)

necpp

1.3.0+cvs20090101-1

(./)

octave3.0

1:3.0.4~rc5-1

(./)

octave3.1

3.1.53-1

(./)

openmx

3.2.4.dfsg-3

(./)

openturns

0.12.2-2

(./)

paw

2.14.04.dfsg.2-6

(./)

petsc

2.3.3-15

(./)

psicode

3.3.0-4

(./)

pysparse

1.0.1-5

(./)

python-numarray

1.5.2-4

(./)

python-numeric

24.2-9

(./)

python-numpy

1.2.1-1

(./)

python-scipy

0.6.0-12

FTBFS on my amd64 sid chroot -- RL

r-base

2.8.1-2

(./)

r-base-core-ra

1.2.4-2

(./)

scalapack

1.8.0-3

(./)

shogun

0.6.7-1

(./)

suitesparse

3.2.0-4

(./)

symeig

1.5-1

(./)