Translation(s): English

This site contains important information about issues to be aware of for Wheezy LTS.

Timeframe

Wheezy Long Term Support starts on 26 April 2016 and will end on 31 May 2018, five years after Wheezy's release.

Supported architectures

i386, amd64, armel and armhf

Release Notes

Using Wheezy LTS updates

In contrast to Squeeze LTS, no additional repositories have to be added to /etc/apt/sources.list to download and install the LTS updates. More detailed instructions can be found at LTS/Using

Java: OpenJDK 7 will be the new default JRE / JDK

General information

Two months after the start of Wheezy-LTS on 26 June 2016, the default Java runtime environment will be switched to OpenJDK 7 via an update of java-common. Please ensure that your web and desktop applications are compatible with OpenJDK 7. For a list of possible compatibility issues, please read this official Oracle document. You are strongly encouraged to change the Java runtime environment to OpenJDK 7 with sudo update-alternatives --config java and to remove the unsupported OpenJDK 6 packages.

How to fix build failures with OpenJDK 7

Some Java packages will fail to build from source with OpenJDK 7. This list provides an overview of all affected packages. In most cases patches were attached to those bug reports and you could simply apply them.

The most common way to fix build failures with OpenJDK 7 is to switch the build dependency to default-jdk and to change paths in debian/rules to the default Java implementation.

For example: export JAVA_HOME=/usr/lib/jvm/default-java.

Please note that OpenJDK 6 is still available for building packages but it will not receive security updates after 26 June 2016 anymore.

Partially supported packages

Not supported packages

There are a set of packages not supported by Wheezy LTS. To check the support status for packages installed on the system, use the debian-security-support package, or check the list at security-support-ended.deb7.


CategoryLts | CategoryPermalink