Migration Notes

rollup.config.js using import (ES module syntax)

Example patch,

 --- a/rollup.config.js
 +++ b/rollup.config.js
 @@ -1,5 +1,5 @@
  import ascii from "rollup-plugin-ascii";
 -import node from "rollup-plugin-node-resolve";
 +import node from "@rollup/plugin-node-resolve";
  import {terser} from "rollup-plugin-terser";
  import * as meta from "./package.json";

Add to control, node-rollup-plugin-node-resolve (>= 9~)

rollup.config.js using require (Commonjs syntax)

You may need to convert require to import (see less.js as an example) or adjust the require statement to require('@rollup/plugin-node-resolve').nodeResolve.

--- a/debian/rollup.config.js
+++ b/debian/rollup.config.js
@@ -1,6 +1,6 @@
-var resolve = require('rollup-plugin-node-resolve');
+import node from "@rollup/plugin-node-resolve";
 var buble = require('rollup-plugin-buble');
-var cjs = require('rollup-plugin-commonjs');
+var cjs = require('@rollup/plugin-commonjs');

-const resolve = require('rollup-plugin-node-resolve')
-const common  = require('rollup-plugin-commonjs')
+const nodeResolve = require('@rollup/plugin-node-resolve').nodeResolve
+const common  = require('@rollup/plugin-commonjs')

Note: You may want to migrate node-resolve plugin and commonjs plugin together if both are used.

Remove deprecated customResolveOptions if minimum version of node-resolve-plugin is set to 11

-  resolve({
-    customResolveOptions: {
-      moduleDirectory: ['debian/node_modules', '/usr/share/nodejs']
-    }
+  nodeResolve({
+      moduleDirectories: ['debian/node_modules', '/usr/share/nodejs']

In Progress

Done in debian, patch forwarding pending

Done, using debian specific build configuration or patch forwarded