Packaging mapbox-studio-classic

Introduction

In this page will be tracked packaging information about mapbox-studio-classic nodejs module. Note that the original mapbox-studio module has been renamed mapbox-studio-classic. But when interacting with npm, it is still called mapbox-studio.

Please do not edit this page by hand. Use this script instead.

For more information about packaging a Node.js module, please take a look at this page.

Build dependencies

Name

npm

debian

task

tape

tape (4.2.1)

#798278

mapnik-test-data

mapnik-test-data (None)

Bundle

phantomjs

phantomjs (1.9.18)

phantomjs (1.9.0-1)

Dependencies

Name

npm

debian

task

mapbox-studio

mapbox-studio (0.1.5)

#761914

├── abaculus

abaculus (1.2.1)

License unclear github issue #22

│   ├── mapnik

mapnik (3.4.7)

node-mapnik (1.2.3-1build1)

abaculus req's mapnik ~3.4.1

│   ├── queue-async

queue-async (1.0.7)

queue-async (1.0.7-1)

│   └── sphericalmercator

sphericalmercator (1.0.4)

node-sphericalmercator (1.0.1-2)

├── carto

carto (0.15.2)

node-carto (0.9.5-2)

│   ├── mapnik-reference

mapnik-reference (8.4.0)

mapnik-reference (5.0.6-1)

│   ├── optimist

optimist (0.6.1)

node-optimist (0.3.5-1)

│   │   ├── minimist

minimist (1.2.0)

node-minimist (1.2.0-1)

mapbox-studio req's minimist 0.1.x - too new?

│   │   └── wordwrap

wordwrap (1.0.0)

node-wordwrap (0.0.2-2)

│   └── underscore

underscore (1.8.3)

underscore (1.7.0~dfsg-1ubuntu1)

├── cors

cors (2.7.1)

│   └── vary

vary (1.1.0)

node-vary (1.0.0-1)

node-vary update to 1.1.0?

├── dirty

dirty (0.9.9)

dirty.js (0.9.6-1)

dirty.js update to 0.9.9?

├── express

express (4.13.3)

node-express (4.1.1~dfsg-1)

│   ├── accepts

accepts (1.3.0)

node-accepts (1.1.1-1)

│   │   ├── mime-types

mime-types (2.1.7)

node-mime-types (2.0.2-1)

│   │   └── negotiator

negotiator (0.6.0)

node-negotiator (0.4.8-1)

│   ├── array-flatten

array-flatten (1.1.1)

│   ├── content-disposition

content-disposition (0.5.0)

node-content-disposition (0.5.0-1)

│   ├── content-type

content-type (1.0.1)

│   ├── cookie

cookie (0.2.2)

node-cookie (0.1.2-2)

│   ├── cookie-signature

cookie-signature (1.0.6)

node-cookie-signature (1.0.3-1)

│   ├── debug

debug (2.2.0)

node-debug (2.1.0+dfsg-1)

│   ├── depd

depd (1.1.0)

node-depd (1.0.0-1)

│   ├── escape-html

escape-html (1.0.3)

node-escape-html (1.0.1-1)

│   ├── etag

etag (1.7.0)

node-etag (1.4.0-1)

│   ├── finalhandler

finalhandler (0.4.0)

node-finalhandler (0.3.0-1)

│   │   ├── debug

debug (2.2.0)

node-debug (2.1.0+dfsg-1)

│   │   ├── escape-html

escape-html (1.0.3)

node-escape-html (1.0.1-1)

│   │   ├── on-finished

on-finished (2.3.0)

node-on-finished (2.1.0-2)

│   │   └── unpipe

unpipe (1.0.0)

│   ├── fresh

fresh (0.3.0)

node-fresh (0.2.0-1)

│   ├── merge-descriptors

merge-descriptors (1.0.0)

node-merge-descriptors (0.0.2-1)

│   ├── methods

methods (1.1.1)

node-methods (1.1.0-1)

│   ├── on-finished

on-finished (2.3.0)

node-on-finished (2.1.0-2)

│   │   └── ee-first

ee-first (1.1.1)

│   ├── parseurl

parseurl (1.3.0)

node-parseurl (1.3.0-1)

│   ├── path-to-regexp

path-to-regexp (1.2.1)

node-path-to-regexp (1.0.1-1)

│   │   └── isarray

isarray (0.0.1)

#780001

│   ├── proxy-addr

proxy-addr (1.0.8)

node-proxy-addr (1.0.3-1)

│   │   ├── forwarded

forwarded (0.1.0)

│   │   └── ipaddr.js

ipaddr.js (1.0.3)

node-ipaddr.js (0.1.3-1)

│   ├── qs

qs (5.2.0)

node-qs (2.2.4-1)

│   ├── range-parser

range-parser (1.0.2)

node-range-parser (0.0.4+git7d1cd72a-1)

│   ├── send

send (0.13.0)

node-send (0.9.4-1)

│   ├── serve-static

serve-static (1.10.0)

node-serve-static (1.6.4-2)

│   │   ├── escape-html

escape-html (1.0.3)

node-escape-html (1.0.1-1)

│   │   ├── parseurl

parseurl (1.3.0)

node-parseurl (1.3.0-1)

│   │   └── send

send (0.13.0)

node-send (0.9.4-1)

│   │   ├── debug

debug (2.2.0)

node-debug (2.1.0+dfsg-1)

│   │   ├── depd

depd (1.1.0)

node-depd (1.0.0-1)

│   │   ├── destroy

destroy (1.0.3)

│   │   ├── escape-html

escape-html (1.0.3)

node-escape-html (1.0.1-1)

│   │   ├── etag

etag (1.7.0)

node-etag (1.4.0-1)

│   │   ├── fresh

fresh (0.3.0)

node-fresh (0.2.0-1)

│   │   ├── http-errors

http-errors (1.3.1)

│   │   │   ├── inherits

inherits (2.0.1)

node-inherits (2.0.1-1)

│   │   │   └── statuses

statuses (1.2.1)

│   │   ├── mime

mime (1.3.4)

node-mime (1.2.11-1)

│   │   ├── ms

ms (0.7.1)

│   │   ├── on-finished

on-finished (2.3.0)

node-on-finished (2.1.0-2)

│   │   ├── range-parser

range-parser (1.0.2)

node-range-parser (0.0.4+git7d1cd72a-1)

│   │   └── statuses

statuses (1.2.1)

│   ├── type-is

type-is (1.6.9)

node-type-is (1.5.2-1)

│   │   ├── media-typer

media-typer (0.3.0)

node-media-typer (0.3.0-1)

│   │   └── mime-types

mime-types (2.1.7)

node-mime-types (2.0.2-1)

│   ├── utils-merge

utils-merge (1.0.0)

node-utils-merge (1.0.0-1)

│   └── vary

vary (1.1.0)

node-vary (1.0.0-1)

node-vary update to 1.1.0?

├── fstream

fstream (1.0.8)

node-fstream (0.1.24-1)

├── gazetteer

gazetteer (0.1.4)

├── getport

getport (0.1.0)

├── js-yaml

js-yaml (3.4.2)

│   ├── argparse

argparse (1.0.2)

#779680

│   │   ├── lodash

lodash (3.10.1)

node-lodash (2.4.1+dfsg-3)

argparse requires lodash >= 3.2.0?

│   │   └── sprintf-js

sprintf-js (1.0.3)

node-sprintf-js (1.0.3-1)

│   └── esprima

esprima (2.6.0)

#750223

├── log-rotate

log-rotate (0.2.7)

├── mapbox-studio-comic

mapbox-studio-comic (2.0.0)

Bundle

├── mapbox-studio-default-fonts

mapbox-studio-default-fonts (None)

Bundle

├── mapbox-studio-default-source

mapbox-studio-default-source (1.0.0)

Bundle

├── mapbox-studio-default-style

mapbox-studio-default-style (2.0.0)

Bundle

├── mapbox-studio-highcontrast

mapbox-studio-highcontrast (1.0.6)

Bundle

├── mapbox-studio-light

mapbox-studio-light (2.1.0)

Bundle

├── mapbox-studio-looseleaf

mapbox-studio-looseleaf (1.0.1)

Bundle

├── mapbox-studio-mapbox-outdoors

mapbox-studio-mapbox-outdoors (2.0.0)

Bundle

├── mapbox-studio-osm-bright

mapbox-studio-osm-bright (2.0.1)

Bundle

├── mapbox-studio-pencil

mapbox-studio-pencil (2.0.1)

Bundle

├── mapbox-studio-pirates

mapbox-studio-pirates (2.0.0)

Bundle

├── mapbox-studio-pro-fonts

mapbox-studio-pro-fonts (None)

Bundle

├── mapbox-studio-run-bike-and-hike

mapbox-studio-run-bike-and-hike (1.0.2)

Bundle

├── mapbox-studio-satellite-afternoon

mapbox-studio-satellite-afternoon (2.0.0)

Bundle

├── mapbox-studio-wheatpaste

mapbox-studio-wheatpaste (2.0.0)

Bundle

├── mapbox-upload

mapbox-upload (4.2.0)

│   ├── aws-sdk

aws-sdk (2.2.8)

│   │   ├── sax

sax (1.1.3)

sax.js (0.5.5-1)

│   │   ├── xml2js

xml2js (0.4.12)

node-xml2js (0.2.8-1)

│   │   │   ├── sax

sax (1.1.3)

sax.js (0.5.5-1)

│   │   │   └── xmlbuilder

xmlbuilder (3.1.0)

│   │   │   └── lodash

lodash (3.10.1)

node-lodash (2.4.1+dfsg-3)

argparse requires lodash >= 3.2.0?

│   │   └── xmlbuilder

xmlbuilder (3.1.0)

│   ├── minimist

minimist (1.2.0)

node-minimist (1.2.0-1)

mapbox-studio req's minimist 0.1.x - too new?

│   ├── progress-stream

progress-stream (1.1.1)

│   │   ├── single-line-log

single-line-log (1.0.0)

│   │   ├── speedometer

speedometer (0.1.4)

│   │   └── through2

through2 (2.0.0)

node-through2 (1.1.1-1)

progress-stream req's through2 ~0.2.3

│   │   ├── readable-stream

readable-stream (2.0.2)

#796355 needs upstream fix for node 4.x

│   │   └── xtend

xtend (4.0.0)

│   ├── request

request (2.64.0)

node-request (2.26.1-1)

mapbox-upload req's request ^2.55.0

│   └── s3-upload-stream

s3-upload-stream (1.0.7)

├── mapnik

mapnik (3.4.7)

node-mapnik (1.2.3-1build1)

abaculus req's mapnik ~3.4.1

├── mapnik-omnivore

mapnik-omnivore (6.3.1)

│   ├── gdal

gdal (0.7.1)

│   │   ├── nan

nan (2.0.9)

node-nan (1.3.0-1)

gdal req's nan > ^1.8.4

│   │   └── node-pre-gyp

node-pre-gyp (0.6.12)

│   ├── mapbox-file-sniff

mapbox-file-sniff (0.4.0)

│   │   ├── buffer

buffer (3.5.1)

│   │   │   ├── base64-js

base64-js (0.0.8)

│   │   │   ├── ieee754

ieee754 (1.1.6)

│   │   │   └── is-array

is-array (1.0.1)

│   │   └── detect-geocsv

detect-geocsv (0.0.1)

│   ├── mapnik

mapnik (3.4.7)

node-mapnik (1.2.3-1build1)

abaculus req's mapnik ~3.4.1

│   │   ├── mapnik-vector-tile

mapnik-vector-tile (0.11.0)

│   │   ├── nan

nan (2.0.9)

node-nan (1.3.0-1)

gdal req's nan > ^1.8.4

│   │   └── node-pre-gyp

node-pre-gyp (0.6.12)

│   ├── queue-async

queue-async (1.0.7)

queue-async (1.0.7-1)

│   ├── sphericalmercator

sphericalmercator (1.0.4)

node-sphericalmercator (1.0.1-2)

│   └── srs

srs (0.4.9)

node-srs (0.3.2+ds1-1build2)

mapnik-omnivore req's srs ~0.4.9

│   ├── nan

nan (2.0.9)

node-nan (1.3.0-1)

gdal req's nan > ^1.8.4

│   └── node-pre-gyp

node-pre-gyp (0.6.12)

├── mapnik-reference

mapnik-reference (8.4.0)

mapnik-reference (5.0.6-1)

├── mbtiles

mbtiles (0.8.0)

node-mbtiles (0.3.2-2)

mapbox-studio req's mbtiles >= 0.6.1

│   ├── sphericalmercator

sphericalmercator (1.0.4)

node-sphericalmercator (1.0.1-2)

│   ├── sqlite3

sqlite3 (3.1.0)

node-sqlite3 (2.2.0+ds1-1)

│   │   ├── nan

nan (2.0.9)

node-nan (1.3.0-1)

gdal req's nan > ^1.8.4

│   │   └── node-pre-gyp

node-pre-gyp (0.6.12)

│   │   ├── mkdirp

mkdirp (0.5.1)

node-mkdirp (0.5.0-1)

│   │   ├── nopt

nopt (3.0.4)

node-nopt (3.0.1-1)

│   │   │   └── abbrev

abbrev (1.0.7)

node-abbrev (1.0.5-2)

│   │   ├── npmlog

npmlog (1.2.1)

node-npmlog (0.0.4-1)

│   │   │   ├── ansi

ansi (0.3.0)

node-ansi (0.3.0-2)

│   │   │   ├── are-we-there-yet

are-we-there-yet (1.0.4)

│   │   │   │   ├── delegates

delegates (0.1.0)

│   │   │   │   └── readable-stream

readable-stream (2.0.2)

#796355 needs upstream fix for node 4.x

│   │   │   │   ├── core-util-is

core-util-is (1.0.1)

#780002

│   │   │   │   ├── inherits

inherits (2.0.1)

node-inherits (2.0.1-1)

│   │   │   │   ├── isarray

isarray (0.0.1)

#780001

│   │   │   │   ├── process-nextick-args

process-nextick-args (1.0.3)

│   │   │   │   ├── string_decoder

string_decoder (0.10.31)

│   │   │   │   └── util-deprecate

util-deprecate (1.0.2)

│   │   │   └── gauge

gauge (1.2.2)

│   │   │   ├── ansi

ansi (0.3.0)

node-ansi (0.3.0-2)

│   │   │   ├── has-unicode

has-unicode (1.0.0)

│   │   │   ├── lodash.pad

lodash.pad (3.1.1)

│   │   │   │   ├── lodash._basetostring

lodash._basetostring (3.0.1)

│   │   │   │   └── lodash._createpadding

lodash._createpadding (3.6.1)

│   │   │   ├── lodash.padleft

lodash.padleft (3.1.1)

│   │   │   │   ├── lodash._basetostring

lodash._basetostring (3.0.1)

│   │   │   │   └── lodash._createpadding

lodash._createpadding (3.6.1)

│   │   │   │   └── lodash.repeat

lodash.repeat (3.0.1)

│   │   │   │   └── lodash._basetostring

lodash._basetostring (3.0.1)

│   │   │   └── lodash.padright

lodash.padright (3.1.1)

│   │   │   ├── lodash._basetostring

lodash._basetostring (3.0.1)

│   │   │   └── lodash._createpadding

lodash._createpadding (3.6.1)

│   │   ├── rc

rc (1.1.2)

│   │   │   ├── deep-extend

deep-extend (0.4.0)

│   │   │   ├── ini

ini (1.3.4)

node-ini (1.1.0-1)

│   │   │   ├── minimist

minimist (1.2.0)

node-minimist (1.2.0-1)

mapbox-studio req's minimist 0.1.x - too new?

│   │   │   └── strip-json-comments

strip-json-comments (1.0.4)

│   │   ├── request

request (2.64.0)

node-request (2.26.1-1)

mapbox-upload req's request ^2.55.0

│   │   │   ├── aws-sign2

aws-sign2 (0.5.0)

│   │   │   ├── bl

bl (1.0.0)

node-bl (0.9.3-1)

│   │   │   │   └── readable-stream

readable-stream (2.0.2)

#796355 needs upstream fix for node 4.x

│   │   │   ├── caseless

caseless (0.11.0)

│   │   │   ├── combined-stream

combined-stream (1.0.5)

node-combined-stream (0.0.5-1)

│   │   │   ├── extend

extend (3.0.0)

node-extend (2.0.0-1)

│   │   │   ├── forever-agent

forever-agent (0.6.1)

node-forever-agent (0.5.1-1)

│   │   │   ├── form-data

form-data (1.0.0-rc3)

node-form-data (0.1.0-1)

│   │   │   │   ├── async

async (1.4.2)

node-async (0.8.0-1)

│   │   │   │   ├── combined-stream

combined-stream (1.0.5)

node-combined-stream (0.0.5-1)

│   │   │   │   │   └── delayed-stream

delayed-stream (1.0.0)

node-delayed-stream (0.0.5-1)

│   │   │   │   └── mime-types

mime-types (2.1.7)

node-mime-types (2.0.2-1)

│   │   │   │   └── mime-db

mime-db (1.19.0)

│   │   │   ├── har-validator

har-validator (2.0.2)

│   │   │   │   ├── chalk

chalk (1.1.1)

│   │   │   │   │   ├── ansi-styles

ansi-styles (2.1.0)

│   │   │   │   │   ├── escape-string-regexp

escape-string-regexp (1.0.3)

│   │   │   │   │   ├── has-ansi

has-ansi (2.0.0)

│   │   │   │   │   │   └── ansi-regex

ansi-regex (2.0.0)

│   │   │   │   │   ├── strip-ansi

strip-ansi (3.0.0)

│   │   │   │   │   │   └── ansi-regex

ansi-regex (2.0.0)

│   │   │   │   │   └── supports-color

supports-color (3.1.1)

│   │   │   │   │   └── has-flag

has-flag (1.0.0)

│   │   │   │   ├── commander

commander (2.8.1)

node-commander (2.4.0-1)

│   │   │   │   │   └── graceful-readlink

graceful-readlink (1.0.1)

│   │   │   │   ├── is-my-json-valid

is-my-json-valid (2.12.2)

│   │   │   │   │   ├── generate-function

generate-function (2.0.0)

│   │   │   │   │   ├── generate-object-property

generate-object-property (1.2.0)

│   │   │   │   │   │   └── is-property

is-property (1.0.2)

│   │   │   │   │   ├── jsonpointer

jsonpointer (3.0.0)

│   │   │   │   │   └── xtend

xtend (4.0.0)

│   │   │   │   └── pinkie-promise

pinkie-promise (1.0.0)

│   │   │   │   └── pinkie

pinkie (1.0.0)

│   │   │   ├── hawk

hawk (3.1.0)

│   │   │   │   ├── boom

boom (2.9.0)

│   │   │   │   │   └── hoek

hoek (2.16.3)

│   │   │   │   ├── cryptiles

cryptiles (2.0.5)

│   │   │   │   │   └── boom

boom (2.9.0)

│   │   │   │   ├── hoek

hoek (2.16.3)

│   │   │   │   └── sntp

sntp (1.0.9)

│   │   │   │   └── hoek

hoek (2.16.3)

│   │   │   ├── http-signature

http-signature (0.11.0)

│   │   │   │   ├── asn1

asn1 (0.2.3)

│   │   │   │   ├── assert-plus

assert-plus (0.1.5)

│   │   │   │   └── ctype

ctype (0.5.5)

│   │   │   ├── isstream

isstream (0.1.2)

│   │   │   ├── json-stringify-safe

json-stringify-safe (5.0.1)

node-json-stringify-safe (5.0.0-1)

│   │   │   ├── mime-types

mime-types (2.1.7)

node-mime-types (2.0.2-1)

│   │   │   ├── node-uuid

node-uuid (1.4.3)

node-uuid (1.4.0-1)

│   │   │   ├── oauth-sign

oauth-sign (0.8.0)

node-oauth-sign (0.3.1-1)

│   │   │   ├── qs

qs (5.2.0)

node-qs (2.2.4-1)

│   │   │   ├── stringstream

stringstream (0.0.4)

│   │   │   ├── tough-cookie

tough-cookie (2.2.0)

│   │   │   └── tunnel-agent

tunnel-agent (0.4.1)

node-tunnel-agent (0.3.1-1)

│   │   ├── rimraf

rimraf (2.4.3)

node-rimraf (2.2.8-1)

│   │   ├── semver

semver (5.0.3)

node-semver (2.1.0-2)

│   │   ├── tar

tar (2.2.1)

node-tar (0.1.18-1)

│   │   └── tar-pack

tar-pack (2.0.0)

│   │   ├── debug

debug (2.2.0)

node-debug (2.1.0+dfsg-1)

│   │   │   └── ms

ms (0.7.1)

│   │   ├── fstream

fstream (1.0.8)

node-fstream (0.1.24-1)

│   │   ├── fstream-ignore

fstream-ignore (1.0.2)

node-fstream-ignore (0.0.6-2)

│   │   │   ├── fstream

fstream (1.0.8)

node-fstream (0.1.24-1)

│   │   │   ├── inherits

inherits (2.0.1)

node-inherits (2.0.1-1)

│   │   │   └── minimatch

minimatch (3.0.0)

node-minimatch (1.0.0-1)

│   │   ├── graceful-fs

graceful-fs (4.1.2)

node-graceful-fs (3.0.2-1)

│   │   ├── once

once (1.3.2)

node-once (1.1.1-1)

│   │   ├── readable-stream

readable-stream (2.0.2)

#796355 needs upstream fix for node 4.x

│   │   ├── rimraf

rimraf (2.4.3)

node-rimraf (2.2.8-1)

│   │   ├── tar

tar (2.2.1)

node-tar (0.1.18-1)

│   │   └── uid-number

uid-number (0.0.6)

│   └── tiletype

tiletype (0.2.1)

├── minimist

minimist (1.2.0)

node-minimist (1.2.0-1)

mapbox-studio req's minimist 0.1.x - too new?

├── mkdirp

mkdirp (0.5.1)

node-mkdirp (0.5.0-1)

├── node-pre-gyp

node-pre-gyp (0.6.12)

├── passport

passport (0.3.0)

passportjs (0.1.17-1)

passport.js needs updating to 0.2.x

│   ├── passport-strategy

passport-strategy (1.0.0)

│   └── pause

pause (0.1.0)

├── passport-oauth

passport-oauth (1.0.0)

passportjs-oauth (0.1.7-1)

passport-oauth needs update to 1.0.x?

│   ├── passport-oauth1

passport-oauth1 (1.0.1)

│   │   ├── oauth

oauth (0.9.14)

node-oauth (0.9.11-1)

│   │   ├── passport-strategy

passport-strategy (1.0.0)

│   │   └── utils-merge

utils-merge (1.0.0)

node-utils-merge (1.0.0-1)

│   └── passport-oauth2

passport-oauth2 (1.1.2)

│   ├── oauth

oauth (0.9.14)

node-oauth (0.9.11-1)

│   ├── passport-strategy

passport-strategy (1.0.0)

│   └── uid2

uid2 (0.0.3)

├── progress-stream

progress-stream (1.1.1)

├── queue-async

queue-async (1.0.7)

queue-async (1.0.7-1)

├── request

request (2.64.0)

node-request (2.26.1-1)

mapbox-upload req's request ^2.55.0

├── rimraf

rimraf (2.4.3)

node-rimraf (2.2.8-1)

├── safer-stringify

safer-stringify (0.0.1)

├── speedometer

speedometer (0.1.4)

├── sphericalmercator

sphericalmercator (1.0.4)

node-sphericalmercator (1.0.1-2)

├── tar

tar (2.2.1)

node-tar (0.1.18-1)

│   ├── block-stream

block-stream (0.0.8)

node-block-stream (0.0.7-1)

│   │   └── inherits

inherits (2.0.1)

node-inherits (2.0.1-1)

│   ├── fstream

fstream (1.0.8)

node-fstream (0.1.24-1)

│   │   ├── graceful-fs

graceful-fs (4.1.2)

node-graceful-fs (3.0.2-1)

│   │   ├── inherits

inherits (2.0.1)

node-inherits (2.0.1-1)

│   │   ├── mkdirp

mkdirp (0.5.1)

node-mkdirp (0.5.0-1)

│   │   │   └── minimist

minimist (1.2.0)

node-minimist (1.2.0-1)

mapbox-studio req's minimist 0.1.x - too new?

│   │   └── rimraf

rimraf (2.4.3)

node-rimraf (2.2.8-1)

│   │   └── glob

glob (5.0.15)

node-glob (4.0.5-1)

│   │   ├── inflight

inflight (1.0.4)

│   │   │   ├── once

once (1.3.2)

node-once (1.1.1-1)

│   │   │   └── wrappy

wrappy (1.0.1)

│   │   ├── inherits

inherits (2.0.1)

node-inherits (2.0.1-1)

│   │   ├── minimatch

minimatch (3.0.0)

node-minimatch (1.0.0-1)

│   │   │   └── brace-expansion

brace-expansion (1.1.1)

│   │   │   ├── balanced-match

balanced-match (0.2.0)

│   │   │   └── concat-map

concat-map (0.0.1)

│   │   ├── once

once (1.3.2)

node-once (1.1.1-1)

│   │   │   └── wrappy

wrappy (1.0.1)

│   │   └── path-is-absolute

path-is-absolute (1.0.0)

│   └── inherits

inherits (2.0.1)

node-inherits (2.0.1-1)

├── through

through (2.3.8)

├── tilejson

tilejson (1.0.0)

node-tilejson (0.1.2-1)

│   ├── agentkeepalive

agentkeepalive (2.0.3)

│   ├── requestretry

requestretry (1.5.0)

│   │   ├── fg-lodash

fg-lodash (0.0.2)

│   │   │   ├── lodash

lodash (3.10.1)

node-lodash (2.4.1+dfsg-3)

argparse requires lodash >= 3.2.0?

│   │   │   └── underscore.string

underscore.string (3.2.2)

│   │   └── request

request (2.64.0)

node-request (2.26.1-1)

mapbox-upload req's request ^2.55.0

│   └── tiletype

tiletype (0.2.1)

├── tilelive

tilelive (5.9.0)

node-tilelive (4.5.0-1)

│   ├── minimist

minimist (1.2.0)

node-minimist (1.2.0-1)

mapbox-studio req's minimist 0.1.x - too new?

│   ├── progress-stream

progress-stream (1.1.1)

│   ├── queue-async

queue-async (1.0.7)

queue-async (1.0.7-1)

│   └── sphericalmercator

sphericalmercator (1.0.4)

node-sphericalmercator (1.0.1-2)

├── tilelive-bridge

tilelive-bridge (2.1.0)

node-tilelive-bridge (0.0.2-1)

│   ├── mapnik

mapnik (3.4.7)

node-mapnik (1.2.3-1build1)

abaculus req's mapnik ~3.4.1

│   ├── mapnik-pool

mapnik-pool (0.1.1)

│   │   ├── generic-pool

generic-pool (2.2.0)

node-generic-pool (2.0.3-1)

│   │   └── xtend

xtend (4.0.0)

│   └── sphericalmercator

sphericalmercator (1.0.4)

node-sphericalmercator (1.0.1-2)

├── tilelive-vector

tilelive-vector (3.5.0)

node-tilelive-vector (0.1.3-1)

│   ├── mapnik

mapnik (3.4.7)

node-mapnik (1.2.3-1build1)

abaculus req's mapnik ~3.4.1

│   ├── numeral

numeral (1.5.3)

│   ├── request

request (2.64.0)

node-request (2.26.1-1)

mapbox-upload req's request ^2.55.0

│   ├── spherical

spherical (0.1.0)

│   │   └── wgs84

wgs84 (0.0.0)

│   ├── sphericalmercator

sphericalmercator (1.0.4)

node-sphericalmercator (1.0.1-2)

│   ├── tar

tar (2.2.1)

node-tar (0.1.18-1)

│   ├── tilelive

tilelive (5.9.0)

node-tilelive (4.5.0-1)

│   └── underscore

underscore (1.8.3)

underscore (1.7.0~dfsg-1ubuntu1)

├── underscore

underscore (1.8.3)

underscore (1.7.0~dfsg-1ubuntu1)

└── vtfx

vtfx (None)

Legenda

not needed

in progress

done

warning

error

Package.json

The package.json for mapbox-studio can be seen by typing:

npm view mapbox-studio