Question

I want to install the java runtime 1.4.1 from Blackdown and do

 apt-get install j2re1.4 

it escapes with an error message :

 update-alternatives: unable to make /usr/lib/mozilla-cvs/plugins/javaplugin_oji.so.dpkg-tmp 
 a symlink to /etc/alternatives/javaplugin_oji-mozilla-cvs.so: No such file or directory

What is wrong?

Answer

Seems that this error message happen when the directory

 /usr/lib/mozilla-cvs/plugins

does not exist. According to debian-user maillist this has been reported as a bug, but a workaround exist

 mkdir -p /usr/lib/mozilla-cvs/plugins

will make the install procedure continue without problem.

See also: ?"JavaScript"