Differences between revisions 23 and 24
Revision 23 as of 2021-05-23 12:55:16
Size: 12329
Comment: fix package name spelling
Revision 24 as of 2021-05-23 13:09:53
Size: 12435
Comment: add info for jitsi-android-osgi
Deletions are marked like this. Additions are marked like this.
Line 71: Line 71:
|| {X} || jitsi-android-osgi || 1.0-SNAPSHOT || Jitsi library || || || || {X} || jitsi-android-osgi || 1.0-SNAPSHOT || Jitsi library || || API incompatible with libosgi-core-java. Try to patch or perhaps package a separate version of osgi-core. ||

Jitsi is a video conferencing solution that works using a web browser using WebRTC. Jitsi Videobridge is the backend server (known as Selective Forwarding Unit or SFU) that provides an API. It is written in Java and Kotlin. The API is used by a web application known as Jitsi Meet. Jitsi Videobridge is also used by the Jitsi Android application and Matrix for multi-user (not one-on-one) video calling.

This page tracks the progress of packaging Jitsi Videobridge into Debian as part of the Java packaging team. Jitsi Meet will be packaged and maintained as part of the Javascript team and tracked separately. This page does not track Jitsi Desktop application packaging.

Jars in Jitsi Videobridge

(./)

Jar

Version

Debian

Version

{i}

agafua-syslog

0.4

May not be needed. Not used with default configuration. Write to stdout (and journald) instead.

(./)

annotations

15.0

libjetbrains-annotations-java

20.1.0-1

(./)

aopalliance-repackaged

2.6.1

libaopalliance-java

20070526-6

(./)

bcpkix-jdk15on

1.65

libbcpkix-java

1.68-1

(./)

bcprov-jdk15on

1.65

libbcprov-java

1.68-1

(./)

bctls-jdk15on

1.65

source:bouncycastle?

988065 libbctls-java

{i}

callstats-java-sdk

5.2.0

To submit call statistics to online service. Disabled in default configuration. May still be needed. Uploaded. repo.

(./)

cglib-nodep

3.2.9

libcglib-java

3.2.12-1

(./)

checker-qual

2.10.0

libchecker-framework-java

3.0.1+ds2-3

(./)

commons-codec

1.9

libcommons-codec-java

1.11-1

(./)

commons-lang3

3.9

libcommons-lang3-java

3.11-1

(./)

config

1.4.1

libtypesafe-config-java

1.3.1-2.1

(./)

error_prone_annotations

2.3.4

liberror-prone-java

2.4.0-1

(./)

failureaccess

1.0.1

libguava-java

29.0-6

(./)

gson

2.3.1

libgoogle-gson-java

2.8.6-1

(./)

guava

28.2-jre

libguava-java

29.0-6

{X}

hk2-api

2.6.1

upstream repo

{X}

hk2-locator

2.6.1

upstream repo

{X}

hk2-utils

2.6.1

upstream repo

{X}

ice4j-3.0

22-g67ffceb

Depends on java-sdp-nist-bridge, jitsi-utils, jicoco-config, kotlin

{X}

j2objc-annotations

1.3

libguava-java?

(./)

jackson-annotations

2.10.1

libjackson2-annotations-java

2.12.1-1

(./)

jackson-core

2.10.0

libjackson2-core-java

2.12.1-1

(./)

jackson-databind

2.10.1

libjackson2-databind-java

2.12.1-1

(./)

jackson-module-jaxb-annotations

2.10.1

libjackson2-module-jaxb-annotations

2.8.10-4

{X}

jackson-module-kotlin

2.11.3

{X}

jain-sip-ri-ossonly

1.2.279-jitsi-oss1

libnist-sip-aosp-java?

9.0.0+r35-1.1

(./)

jakarta.activation-api

1.2.1

libjakarta-activation-java

2.0.0-1

(./)

jakarta.annotation-api

1.3.5

libjakarta-annotation-api-java

2.0.0-1

(./)

jakarta.inject

2.6.1

libatinject-jsr330-api-java?

1.0+ds1-5

(./)

jakarta.servlet-api

4.0.3

libjakarta-servlet-api-java

5.0.0-2

(./)

jakarta.validation-api

2.0.2

libjakarta-validation-api-java

3.0.0-1

(./)

jakarta.ws.rs-api

2.1.6

libjaxrs-api-java

2.1.2-2

(./)

jakarta.xml.bind-api

2.3.2

libjaxb-api-java

2.3.1-1

{X}

java-sdp-nist-bridge

1.2

Depends on jain-sip-ri-ossonly

(./)

javassist

3.22.0-CR2

libjavassist-java

1:3.27.0-1

(./)

javax.servlet-api

3.1.0

libservlet-ap-java

4.0.1-2

{X}

jcl-core

2.8

Depends on object-cloner

{X}

jersey-client

2.32

{X}

jersey-common

2.32

{X}

jersey-container-jetty-http

2.32

{X}

jersey-container-servlet

2.32

{X}

jersey-container-servlet-core

2.32

{X}

jersey-entity-filtering

2.32

{X}

jersey-hk2

2.32

{X}

jersey-media-jaxb

2.32

{X}

jersey-media-json-jackson

2.32

{X}

jersey-server

2.32

{X}

jersey-test-framework-core

2.32

(./)

jetty-client

9.4.35.v20201120

libjetty9-extra-java

9.4.36-1

(./)

jetty-continuation

9.4.35.v20201120

libjetty9-java

9.4.36-1

(./)

jetty-http

9.4.35.v20201120

libjetty9-java

9.4.36-1

(./)

jetty-io

9.4.35.v20201120

libjetty9-java

9.4.36-1

(./)

jetty-proxy

9.4.35.v20201120

libjetty9-extra-java

9.4.36-1

(./)

jetty-rewrite

9.4.35.v20201120

libjetty9-java

9.4.36-1

(./)

jetty-security

9.4.35.v20201120

libjetty9-java

9.4.36-1

(./)

jetty-server

9.4.35.v20201120

libjetty9-java

9.4.36-1

(./)

jetty-servlet

9.4.35.v20201120

libjetty9-java

9.4.36-1

(./)

jetty-servlets

9.4.35.v20201120

libjetty9-java

9.4.36-1

(./)

jetty-util

9.4.35.v20201120

libjetty9-java

9.4.36-1

(./)

jetty-util-ajax

9.4.35.v20201120

libjetty9-java

9.4.36-1

{X}

jicoco-1.1

77-g10b7019

Jitsi library

Depends on kotlin, jitsi-utils, jersey, smack, ...

{X}

jicoco-config-1.1

77-g10b7019

Jitsi library

Depends on kotlin, jitsi-utils, jersey, smack, ...

{X}

jitsi-android-osgi

1.0-SNAPSHOT

Jitsi library

API incompatible with libosgi-core-java. Try to patch or perhaps package a separate version of osgi-core.

{X}

jitsi-media-transform-1.0

214-gfc6cda2

Jitsi library

{X}

jitsi-metaconfig

315a3cec35

Jitsi library

Needs Kotlin.

{X}

jitsi-srtp-1.0

33-gfe519d1

Jitsi library

Needs Kotlin.

{X}

jitsi-stats-1.0

4-g6d906b2

Jitsi library

Needs Kotlin.

{i}

jitsi-utils-1.0

74-g0d09c0e

Jitsi library

Needs Kotlin. WIP repo.

{X}

jitsi-xmpp-extensions-1.0

15-g813e4c4

Jitsi library

Needs Kotlin.

(./)

jna

5.5.0

libjna-java

5.6.0-1

{X}

jnilib-1.0

4-g97f4e5e

Jitsi library

{X}

jniwrapper-java-1.0

4-g97f4e5e

Jitsi library

{X}

jniwrapper-native-1.0

4-g97f4e5e

Jitsi library

{i}

jose4j

0.5.1

Uploaded. repo.

(./)

json-simple

1.1.1

libjson-simple-java

2.3.0-1

(./)

jsr305

3.0.2

libjsr305-java

0.1svn49-11

{i}

jxmpp-core

0.6.2

Uploaded. repo.

{i}

jxmpp-jid

0.6.2

Uploaded. repo.

{i}

jxmpp-util-cache

0.6.2

Uploaded. repo.

{i}

kotlin-maven-plugin

1.3.72

Ready to upload. Part of kotlin package.

{i}

kotlin-osgi-bundle

1.3.72

Ready to upload. Part of kotlin package.

{i}

kotlin-reflect

1.3.72

Ready to upload. Part of kotlin package.

{i}

kotlin-stdlib

1.3.72

Ready to upload. Part of kotlin package.

{i}

kotlin-stdlib-common

1.3.71

Ready to upload. Part of kotlin package.

{i}

kotlin-stdlib-jdk7

1.3.72

Ready to upload. Part of kotlin package.

{i}

kotlin-stdlib-jdk8

1.3.72

Ready to upload. Part of kotlin package.

{X}

kotlin-unsigned

3.1.3

{X}

listenablefuture

9999.0

Seems to be internal dependency of guava.

(./)

log4j-api

2.3

liblog4j2-java

2.13.3-1

(./)

log4j-core

2.3

liblog4j2-java

2.13.3-1

{i}

minidns

1.0.0

Uploaded. repo.

{X}

object-cloner

0.1

(./)

objenesis

2.6

libobjenesis-java

3.1-1

(./)

okhttp

3.9.1

libokhttp-java

3.13.1-2

(./)

okio

1.13.0

libokio-java

1.16.0-2

(./)

org.osgi.core

4.3.1

libeclipse-osgi-java

3.16.100+eclipse4.18-1

{X}

osgi-resource-locator

1.0.3

{X}

pcap4j-core

1.8.2

{X}

pcap4j-packetfactory-static

1.8.2

(./)

reflections

0.9.11

libreflections-java

0.9.12

{X}

rtp-1.0

54-ge0d663c

Jitsi project

Needs Kotlin.

{X}

sctp-1.0

4-g97f4e5e

Jitsi project

(./)

sdp-api

1.0

libsdp-api-java

1.0-1.1

{i}

sentry

1.7.30

Not needed. For code quality checks.

(./)

slf4j-api

1.7.30

libslf4j-java

1.7.30-1

(./)

slf4j-simple

1.6.1

libslf4j-java

1.7.30-1

{i}

smack-core-4.2.4

47d17fc

WIP repo.

{i}

smack-extensions-4.2.4

47d17fc

WIP repo.

{i}

smack-im-4.2.4

47d17fc

WIP repo.

{i}

smack-java7-4.2.4

47d17fc

WIP repo.

{i}

smack-resolver-javax-4.2.4

47d17fc

WIP repo.

{i}

smack-sasl-javax-4.2.4

47d17fc

WIP repo.

{i}

smack-tcp-4.2.4

47d17fc

WIP repo.

{i}

spotbugs-annotations

4.1.4

Not needed. For code quality checks.

(./)

websocket-api

9.4.35.v20201120

libjetty9-extra-java

9.4.15-1

(./)

websocket-client

9.4.35.v20201120

libjetty9-extra-java

9.4.15-1

(./)

websocket-common

9.4.35.v20201120

libjetty9-extra-java

9.4.15-1

(./)

websocket-server

9.4.35.v20201120

libjetty9-extra-java

9.4.15-1

(./)

websocket-servlet

9.4.35.v20201120

libjetty9-extra-java

9.4.15-1

{X}

weupnp

0.1.4

libweupnp-java

0.1.4 (removed)

988092 Repo Uploaded.

(./)

xpp3

1.1.4c

libxpp3-java

1.14c-3

Notes

  • jitsi-meet will have stay in fasttrack for the foreseeable future.
  • Packaging the version used currently in Jitsi is somewhat questionable: the used version of Smack for example is a fork, upstream is at 4.4, but unfortunately, they don't follow SemVer and updating is a major pain. The same often goes with BouncyCastle.

  • The package jain-sip-ri-oss-only is just Jain SIP/jsip, but without the non open-source files (src/javax/*). The Maven packing is in the Jitsi fork at [2].
  • The removed files are in the Debian package libsdp-api-java and libsip-api-java (as a clean-room reimplementation).
  • java-sdp-nist-bridge is used to reconnect the deleted sources and libsdp-api-java.
  • Jain-sip, without the repackaging, was the original reason why Jitsi Desktop never made it into Debian (i.e. past the FTP masters) and subsequent efforts were then dropped.
  • Jitsi Desktop was earlier in Debian. So some extra steps may be needed when reintroducing it.


CategoryJava