Differences between revisions 30 and 32 (spanning 2 versions)
Revision 30 as of 2017-09-02 03:06:23
Size: 5538
Editor: ?dai
Comment: obsolete kde4/gnome applets
Revision 32 as of 2017-09-13 12:14:11
Size: 6189
Editor: ?dai
Comment: plasma-widget-uim, uim-applet-gnome and uim-toolbar-gtk{,3}-systray dropped
Deletions are marked like this. Additions are marked like this.
Line 9: Line 9:
== デフォルトインプットメソッドの変更 == == デフォルトインプットメソッドの変更 (future default IM) ==
Line 11: Line 11:
 * 現状の uim の懸念点
   * upstream の開発が停滞している。
   * Qt5 対応が開発途上でバグが多い。
 * 現状の uim の懸念点 (concerns @current)
   * upstream の開発が停滞している。(upstream development is stall)
   * Qt5 対応が開発途上でバグが多い。(coping with Qt5 is under development and buggy)
Line 16: Line 16:
      * plasma-widget-uim にバグがある?
      * 補足: Qt4 は次期 stable で削除予定。
      * --(plasma-widget-uim にバグがある?(looks like plasma-widget-uim has bug(s)))-- plasma-widget-uim dropped at 1:1.8.6+gh20161003.0.d63dadd-5~exp1
      * 補足: Qt4 は次期 stable で削除予定。(Qt4 will not be shipped in Debian 10)
Line 19: Line 19:
   * GNOME 3 対応にいくつか問題がある。
      * https://wiki.debian.org/ja/L10n/Japanese#line-30
   * GNOME 3 対応にいくつか問題がある。(coping with GNOME 3 has some issues)
      * --(https://wiki.debian.org/ja/L10n/Japanese#line-30 )-- uim-applet-gnome and uim-toolbar-gtk{,3}-systray dropped at 1:1.8.6+gh20161003.0.d63dadd-5~exp1
Line 23: Line 23:
   * uim-skk が UTF-8 に対応していない。
 * 変更先は ibus が有力。
   * uim-skk が UTF-8 に対応していない。(uim-skk does not handle UTF-8)
 * 変更先は ibus が有力。(ibus is reasonable alternative)
Line 27: Line 27:
   * 以前にも提起    * 以前にも提起 (this idea was raised in the past)
Line 30: Line 30:
 * 変更対象(tasksel)  * 変更対象(will be changed)(tasksel)
Line 73: Line 73:
   * アーキテクチャ非依存ファイルをuim-dataに移動 (move arch-independet files into uim-data)    * アーキテクチャ非依存ファイルをuim-dataに移動 (move arch-independent files into uim-data)
Line 78: Line 78:
   * uim: add uim-anthy, uim-skk to Breaks/Relapces.    * uim: add uim-anthy, uim-skk to Breaks/Replaces.
Line 117: Line 117:
 * --(uim 実パッケージに統合したインプットメソッドを debconf を使って選択できるようにする。)--
    * uim 実パッケージに統合したインプットメソッドは、すべて自動で登録する。
 * --(uim 実パッケージに統合したインプットメソッドを debconf を使って選択できるようにする。(make IMs integrated into real uim package be able to be selected from debconf))--
    * uim 実パッケージに統合したインプットメソッドは、すべて自動で登録する。(register IMs integrated into real uim package)

uim: Universal Input Method

パッケージ情報 (package information)

post stretchの作業指針 (guideline for post-stretch)

デフォルトインプットメソッドの変更 (future default IM)

UTF-8 がデフォルトとなった anthy 0.3 対応

パッケージの統廃合 (to be integrated/obsoleted packages)

実施作業 (work done)

  • debian-experimentalブランチ作成 (debian-experimental branch created) (from 8a8ca77e0754c3f2e1f3f0fc592378fa9c05fd77)
  • uimを実パッケージ化 (make uim real package)
    • uim-common, libuim-dataを内包 (contains uim-commonand libuim-data now)
    • uim-utilsを内包 (contains uim-utils)
      • Architecture: anyに変更 (change Architecture: any)
    • アーキテクチャ非依存ファイルをuim-dataに移動 (move arch-independent files into uim-data)
    • uim-ahtny, uim-skk, uim-tcode統合 (integrate uim-anthy, uim-skk, uim-tcode)
    • uim-m17nlib, uim-byeoru統合 (integrate uim-m17nlib, uim-byeoru)
    • uim-latin, uim-pinyin, uim-viqr, uim-ipa-x-sampa, uim-look integrated
    • uim-anthy, uim-skk, uim-tcode as meta packages.
    • uim: add uim-anthy, uim-skk to Breaks/Replaces.
  • uim を実パッケージに変更し、次のパッケージ内容をすべて統合 (make uim real package and contains these contents)

    • -uim-common-

    • -libuim-data-

    • -libuim-plugins-

    • -uim-utils-

    • uim-anthy
    • uim-skk
    • -uim-m17nlib-

    • -uim-byeoru-

    • -uim-latin-

    • -uim-pinyin-

    • uim-tcode
    • -uim-viqr-

    • -uim-ipa-x-sampa-

    • -uim-look-

  • uim-dataを追加、以下を移動 (add uim-data and integrate them)
    • -libuim-data-

    • -uim-plugins-

  • uim-anthy をメタパッケージ化 (make uim-anthy meta package)
    • Depends: anthy
  • uim-skk をメタパッケージ化 (make uim-skk meta package)
    • Depends: skkdic | skkdic-extra | skkserv | dbskkd-cdb
  • uim-tcode をメタパッケージ化 (make uim-tcode meta package)
    • Depends: uim-skk, t-code-common
  • 次のパッケージは廃止 (these packages will be obsoleted) (使用自体は可能: debian/NEWS 参照 (although still can be used: see debian/NEWS))
    • -uim-m17nlib-

    • -uim-byeoru-

    • -uim-latin-

    • -uim-pinyin-

    • -uim-viqr-

    • -uim-ipa-x-sampa-

    • -uim-look-

  • 次のパッケージも廃止する (let these packages to be obsoleted)
    • -uim-dict-gtk-

    • -uim-dict-gtk3-

    • -uim-applet-gnome-

    • -plasma-widget-uim-

  • uim 実パッケージに統合したインプットメソッドを debconf を使って選択できるようにする。(make IMs integrated into real uim package be able to be selected from debconf)

    • uim 実パッケージに統合したインプットメソッドは、すべて自動で登録する。(register IMs integrated into real uim package)

参考リンク (links)