Differences between revisions 1 and 2
Revision 1 as of 2015-02-17 21:58:06
Size: 4958
Editor: ?SarahFortune
Comment:
Revision 2 as of 2015-02-17 22:23:45
Size: 6317
Editor: ?SarahFortune
Comment:
Deletions are marked like this. Additions are marked like this.
Line 14: Line 14:
= Installing Debian Testing (Jessie) on MSI GS60 =
Line 23: Line 25:
 - Other options, like fingerprint reader, bluetooth... -~


- Other options, like fingerprint reader, bluetooth... -~
Line 32: Line 31:
||Boot Standard Kernel: || [{OK}] ||
|| LAN network card: || [{OK} in Jessie] ||
||Boot Standard Kernel: || {OK} ||
|| LAN network card: || {OK} in Jessie ||
Line 35: Line 34:
|| Detect hard drives: || [{i}] || || Detect hard drives: || {i} ||
Line 46: Line 45:
|| - Built-in (Trackpoint) || [?] || || - Built-in (Trackpoint) || [-] ||
Line 56: Line 55:
I used Debian netboot and PXE to run the installer as the laptop doesn't have a CD drive, and I don't have any external USB drives.

= Special instructions for PXE =
You have turn off secure boot in the BIOS. Otherwise the PXE loader will complain about that the boot image is not signed: "Invalid signature detected check secure boot policy in setup". The only keys it recognizes are from Microsoft.

Also, the default image for Debian netboot only works on older BIOSes and isn't right format for new UEFI systems. So, replace pxelinux.0 with the AMD 64 efi image: debian-installer/amd64/bootnetx64.efi

I used an Ubuntu system running tftpd-hpa to serve the boot image, and a router running DD-WRT to configure dhcp for PXE.

= SSD Setup =
The laptop has two SSDs and comes with RAID0 set up in the BIOS so they appear as one drive. However, grub doesn't support booting a RAID0 device, according to some posts I found. I was able to mount the disks and configure the partitions etc. from the installer, but grub would refuse to install with an error like, "disk mduuidxxxxxxxx not found". Eventually, I just gave up and deleted the RAID array in the BIOS.

= Ethernet =
The network card driver isn't included in the Debian stable installer, however the driver in testing works fine during install.

Translation(s): none

DebianOn is an effort to document how to install, configure and use Debian on some specific hardware. Therefore potential buyers would know if that hardware is supported and owners would know how get the best out of that hardware.

The purpose is not to duplicate the Debian Official Documentation, but to document how to install Debian on some specific hardware.

If you need help to get Debian running on your hardware, please have a look at our user support channels where you may find specific channels (mailing list, IRC channel) dedicated to certain types of hardware.

Installing Debian Testing (Jessie) on MSI GS60

Models covered
MSI GS60

Sub-model options : MSI GS60 Ghost Pro-066
- Intel Core i7 4710HQ (2.50GHz) - Video card: NVIDIA ?GeForce GTX 970M 6GB
- Screen size: 15.6" 1920x1080
- Wireless card: Killer N1525 Combo (2 x 2 ac)
- Disk and Ram size, optical device: 16GB Memory 1TB HDD 256 GB (128 GB M.2SATA x 2 RAID 0) SSD
- Other options, like fingerprint reader, bluetooth...

Overall Status

Core Components

[ATTACH]

Boot Standard Kernel:

{OK}

LAN network card:

{OK} in Jessie

Detect CD/DVD:

[-]

Detect hard drives:

{i}

Extra Features

CPU Frequency Scaling

[?]

Hibernation

[?]

Sleep / Suspend

[?]

Xorg

[?]

- OpenGL

[?]

- Resize-and-Rotate(randr)

[?]

Switch to External Screen

[?]

Mouse

- Built-in (Trackpoint)

[-]

- Built-in (Touchpad)

[?]

Modem

[-]

Wireless/Wifi

[?]

Keyboard's Hotkeys

[?]

Legend :
{OK} = OK ; {X} Unsupported(No Driver) ; /!\ = Error (Couldn't get it working); [?] Unknown, Not Test ; [-] Not-applicable
{i} = Configuration Required; X-( = Only works with a non-free driver and or firmware

Important Note

I used Debian netboot and PXE to run the installer as the laptop doesn't have a CD drive, and I don't have any external USB drives.

Special instructions for PXE

You have turn off secure boot in the BIOS. Otherwise the PXE loader will complain about that the boot image is not signed: "Invalid signature detected check secure boot policy in setup". The only keys it recognizes are from Microsoft.

Also, the default image for Debian netboot only works on older BIOSes and isn't right format for new UEFI systems. So, replace pxelinux.0 with the AMD 64 efi image: debian-installer/amd64/bootnetx64.efi

I used an Ubuntu system running tftpd-hpa to serve the boot image, and a router running DD-WRT to configure dhcp for PXE.

SSD Setup

The laptop has two SSDs and comes with RAID0 set up in the BIOS so they appear as one drive. However, grub doesn't support booting a RAID0 device, according to some posts I found. I was able to mount the disks and configure the partitions etc. from the installer, but grub would refuse to install with an error like, "disk mduuidxxxxxxxx not found". Eventually, I just gave up and deleted the RAID array in the BIOS.

Ethernet

The network card driver isn't included in the Debian stable installer, however the driver in testing works fine during install.

Configuration

Display

  • (not covered yet)

Audio

  • (not covered yet)

Mouse

  • (not covered yet)

Power Management

  • (not covered yet)

WiFi

  • (not covered yet)

Modem

  • (not covered yet)


System Summary

lspci

lsusb

lsusb -v | grep -E '\<(Bus|iProduct|bDeviceClass|bDeviceProtocol)' 2>/dev/null

USB Host controllers entries (without OHCI, UHCI, EHCI) are removed too.

Resources

Attachments

Some configuration files and sample outputs.

Credits