WiFi after wakeup

When you wake up after suspend to ram the WiFi will not work (on A150 model ZG5). You have to unload and the reload the module ath_pci: # modprobe -r ath_pci # modprobe ath_cpi

and then also: # sysctl -p

to make led pin works.

To do that in an automated way you have to add this line to etc/pm/config.d/modules: SUSPEND_MODULES="ath_pci"

Then create the file /etc/pm/sleep.d/00-sysctl.sh and add these lines in it: #!/bin/bash case $1 in resume) sysctl -p ;; esac

Save the file and then make it executable: # chmod +x /etc/pm/sleep.d/00-sysctl.sh

Reboot the system.

Touchpad settings on startup

You have to run "gsynaptics-init" every time you log-on the DE.

Setup (of wireless) sections

These sections are confusing, because it's not clear which parts always apply, and which parts are alternatives. I think the following is what is intended. If so, I'll re-format it to make it clear. There are two main alternatives: 1. kernel.org / mac80211 ... or 2. ?MadWifi If I choose ?MadWifi, then I can do it in any of three different ways: 2a. non-free driver 2b. via module assistant 2c. from source Having chosen and performed either 1 or 2 (and the relevant 2a/b/c) then I should go on and do: 3 WiFi LED

Linux Image Version

Hi, I wonder if someone could put info about using linux-image 486 or 686 for this laptop.


Some info on how to update the BIOS from Debian could be helpful.


Is there a mailing list or forum for Debian Users of this netbook?

Net Install

I actually had a problem trying to install from a USB drive. The installer would not recognize the HDD with the USB Drive package loaded. The kernel messages reported it and I could mount it from a console, but for some reason the installer just didn't want to use it as the target. I followed the instructions from the install manual on booting from the network and the install went beautifully! The system does PXE Booting, so follow the instructions for that.

Suspend to Ram

To fix an issue with resuming from ram requiring You to press a key once to resume,then again(when using the suggested lid.sh command),I added a line to lid.sh to detect the lid state,and exit if it is open.This problem I believe is caused by the lid button reporting two events,one for close, another for open(may be a better way around this,but it works for me). the following is the contents of my lid.sh:


grep -q open /proc/acpi/button/lid/LID0/state && exit 0


edit:went ahead and added to InstallingDebianOn/Acer/AspireOne wiki,along with adobe flash acceleration tweak


I use sidux (distro based on Sid, see http://sidux.com) on my Acer Aspire One 150BGb. There is no 'bug' that the tapping does not work. With the new X.org, tapping is turned off by default, while it was on by default in older X.org. It can easy be enabled using hal, check out my entry in the sidux wiki (http://sidux.com/index.php?module=pnWikka&tag=AcerAspireOne150Bg). I have used a lot of info from this article, thanks a lot!


The instructions moved my glxgears to 1300 fps on 2.6.30 (400 fps on a fresh Mepis install, 700 fps after kernel update).


Using Debian lenny and an Aspire One purchased in early 2009. I've added "options snd-hda-intel model=acer-aspire position_fix=1" to my /etc/modprobe.d/alsa-base. When I tried recording I was getting massive noise and no signal on one input source and silence on the other, whether I had an external microphone plugged in or not. I ran "alsamixer -V capture" and changed "Input Source" to "Front Mic". Now I get silence on that input source with no external mic, but it works with the external mic. It's good enough for me, and may help others, but I would be interested to hear if anyone has got internal mic working and auto-switching when you plug in / unplug an external mic. -- pjt33, 15th August 2009.