Translation(s): 简体中文 日本語


Fcitx5

Fcitx 5 is a generic input method framework.

Package status

All packages: Fcitx5 package family

It only has been packaged on bullseye and later. For buster and before, please use fcitx, aka fcitx4.

Install Fcitx5 on bullseye

For Simplified Chinese users

Install fcitx5 and fcitx5-chinese-addons. Then logout and login again in your desktop environment. The input methods are not added to fcitx immediately. You need to configure it manually. You can run fcitx5-configtool from terminal or system tray.

apt install --install-recommends fcitx5 fcitx5-chinese-addons

Be sure to install recommended packages, it works for most people. But if you want a minimal set of packages to install, try (for KDE user):

apt install --no-install-recommends fcitx5 fcitx5-chinese-addons fcitx5-frontend-gtk3 fcitx5-frontend-qt5 fcitx5-module-xorg kde-config-fcitx5 im-config

im-config is used to automatically configure the required environment for input methods.

For Traditional Chinese users

You can install fcitx5-chinese-addons too, it provides table method. But you can also install fcitx5-chewing for zhuyin.

For Japanese users

Install fcitx5 and fcitx5-mozc/fcitx5-skk, and remove uim and uim-mozc.

apt install --install-recommends fcitx5 fcitx5-mozc
apt remove uim uim-mozc

or

apt install --install-recommends fcitx5 fcitx5-skk
apt remove uim uim-mozc

For Korean users

Install fcitx5 and fcitx5-hangul.

apt install --install-recommends fcitx5 fcitx5-hangul

Other languages

Package

Language

fcitx5-rime

Chinese

fcitx5-libthai

Thai

GNOME

Gnome users should install gnome-shell-extension-kimpanel.

Fcitx5 works on Wayland, so you don't need to switch to Xorg.

Please notice that GNOME will install iBus regardless, you can switch the input method with im-config.

KDE

KDE users must also install kde-config-fcitx5. And see also known issue.

Theme

Except the builtin theme, currently there's extra one available. fcitx5-material-color. See the screenshots at upstream.

You can configure theme through "Fcitx 5 Configuration" -> "Configure addons" -> "Classic User Interface" -> "Theme".

Migrate from fcitx4

Install fcitx5-config-qt, then open "Fcitx 5 Migration Wizard" from desktop menu. If you want to migrate pinyin and table data from fcitx4, libime-bin is also needed.

Known Issues

  1. The fcitx icons in KDE Breeze, Papirus are not applied. 976603

  2. Can't input in some proprietary Qt software.
    Because these software don't include fcitx5 modules in their embedded Qt library. Usually they only include fcitx4 modules.
    Fcitx5 supports the old fcitx4 modules as well. But to use it successfully on these proprietary Qt software, the QT_IM_MODULE should be set to fcitx. However im-config set it to fcitx5. 977203
    The solution is to modify the environment before running these software, for example run export QT_IM_MODULE=fcitx first.

See also


CategoryKeyboard CategoryLocalization CategorySoftware