Differences between revisions 86 and 87
Revision 86 as of 2008-12-02 00:33:22
Size: 18650
Editor: ?sampablokuper
Comment: Moved ML150 down
Revision 87 as of 2008-12-02 00:48:58
Size: 18740
Editor: ?sampablokuper
Comment: Added my ML110 G3 bug
Deletions are marked like this. Additions are marked like this.
Line 29: Line 29:
|| ML110 G3 || SATA || [http://cdimage.debian.org/cdimage/etch_di_rc1/i386/iso-cd/debian-testing-i386-netinst.iso etch rc1/i386] || || Used software RAID, default intallation worked just fine. However, "vga=791" must be appended to kernel line, otherwise no consoles will be spawn. ||
|| ML110 G3 || Network || [http://cdimage.debian.org/debian-cd/4.0_r0/i386/iso-cd/debian-40r0-i386-netinst.iso Debian Etch 4.0] || Failed || Broadcom network card no longer supported by new 'free' Tigon3 drivers. ||
||<style="text-align: center;" |3> ML110 G3 || SATA || [http://cdimage.debian.org/cdimage/etch_di_rc1/i386/iso-cd/debian-testing-i386-netinst.iso etch rc1/i386] || || Used software RAID, default intallation worked just fine. However, "vga=791" must be appended to kernel line, otherwise no consoles will be spawn. ||
|| Network || [http://cdimage.debian.org/debian-cd/4.0_r0/i386/iso-cd/debian-40r0-i386-netinst.iso Debian Etch 4.0] || Failed || Broadcom network card no longer supported by new 'free' Tigon3 drivers. ||
|| Network || Lenny || [http://bugs.debian.org/507502 #507502] || ||

Installer Compatibility Table

This table is a community maintained matrix of DebianInstaller builds and their compatibility with various HP ?ProLiant systems. This page does not infer official support from HP. Information on official HP support offerings for Debian can be found on [http://hp.com/go/debian http://hp.com/go/proliantdebian]. Additional list of links and information at [http://h71028.www7.hp.com/enterprise/downloads/Debian-Proliant-Howto-etch-final-070907.pdf Debian Proliant how to Etch 070907 (PDF) ]

System

Config

Installer

?InstallationReport

Summary

Etch

BL20p G3

[http://cdimage.debian.org/cdimage/etch_di_rc1/i386/iso-cd/debian-testing-i386-netinst.iso RC1 netboot/i386]

Worked

BL25p G1

BL35p G1

BL40p G1

BL45p G1

BL460c G1

[http://cdimage.debian.org/cdimage/etch_di_rc1/amd64/iso-cd/debian-testing-amd64-netinst.iso RC1 netboot/amd64]

[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=398981 #398981]

Worked

BL465c G1

BL480c G1

BL485c G1

DL140 G3

SATA Hot Plug

2.6.18-based daily

Works 99% perfectly with 2007.01.16 - PS2 is not detected but everything else works (including USB) so this isn't a big issue. Test machine has ?SmartArray E200 RAID controller

DL140 G3

SAS Hot Plug

2.6.18-based daily

PS2 is not detected but everything else works (including USB) so this isn't a big issue (but cannot use KVM). Test machine has LSI SAS RAID controller.

DL145 G1

IDE

[http://ftp.nl.debian.org/debian/dists/testing/main/installer-amd64/beta3/images/netboot/netboot.tar.gz Etch Beta 3 netboot/amd64]

[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=384238 #384238]

DL145 G3

SATA

4.0r0 netinst CD

[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=421646 #421646]

DL320 G4

SATA

[http://cdimage.debian.org/cdimage/daily-builds/daily/arch-latest/amd64/iso-cd/debian-testing-amd64-netinst.iso 20070208 daily build]

[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=410336 #410336]

Worked

DL360 G5

[http://cdimage.debian.org/cdimage/etch_di_beta3/amd64/iso-cd/debian-testing-amd64-netinst.iso Etch Beta 3 netinst/amd64]

[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=384202 #384202]

[#daily Etch Beta 3 issues fixed in daily builds]

DL360 G5

SAS

4.0r0 netinst CD

DL365 G1

Network

debootstrap

Installed from an Ubuntu CD. Had to manually install the HP Array Configuration Utility CLI for Linux from HP's website, and its needed librairy, to configure the disk arrays, which were perfectly detected, but was unable to install Grub, had to go for lilo.

DL380 G1

SCSI

[http://cdimage.debian.org/cdimage/etch_di_beta3/i386/iso-cd/debian-testing-i386-netinst.iso Etch Beta 3 netinst/i386]

Unable to get access Integrated Smart Array RAID volume. Probably the same problem seen [http://www.thestevensons.org/node/view/649 here for fedora] and in debian in bug [http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=380272 #380272]. Works fine with Sarge netinst.

DL380 G4

SCSI

[http://cdimage.debian.org/cdimage/etch_di_beta3/i386/iso-cd/debian-testing-i386-netinst.iso Etch Beta 3 netinst/i386]

[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=383544 #383544]

DL380 G5

SAS

[http://cdimage.debian.org/debian-cd/4.0_r0/i386/iso-cd/debian-40r0-i386-netinst.iso etch4.0/i386]

Worked. It's possible to install HP official software hpacucli, hpadu, hpasm, cmanic and cpqacuxe officialy supported only for 3.1 Sarge. Don't work for me hprsm, hpsmh. Also possible to install the opensource array monitoring tool cpqarrayd and array-info.

DL385 G2

amd64 daily (2006.11.30)

[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=401150 #401150]

Worked

DL580 G4

SAS

DL585 G1

SCSI

DL585 G2

[http://cdimage.debian.org/cdimage/etch_di_rc1/amd64/iso-cd/debian-testing-amd64-netinst.iso RC1 netboot/amd64]

[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=398992 #398992]

Worked

ML110 G3

SATA

[http://cdimage.debian.org/cdimage/etch_di_rc1/i386/iso-cd/debian-testing-i386-netinst.iso etch rc1/i386]

Used software RAID, default intallation worked just fine. However, "vga=791" must be appended to kernel line, otherwise no consoles will be spawn.

Network

[http://cdimage.debian.org/debian-cd/4.0_r0/i386/iso-cd/debian-40r0-i386-netinst.iso Debian Etch 4.0]

Failed

Broadcom network card no longer supported by new 'free' Tigon3 drivers.

Network

Lenny

[http://bugs.debian.org/507502 #507502]

ML110 G4

SATA

20061121/i386

Didn't work with lvm root and LILO, using cciss driver with hardware RAID1

20070127/i386

worked fine.

20070217/amd64

[http://bugs.debian.org/411621 #411621]

No key input is avaiable after showing 1st dialog on VGA console. However install with serial (console=ttyS0 option) was success. It also works with an USB keyboard.

[http://cdimage.debian.org/debian-cd/4.0_r0/i386/iso-cd/debian-40r0-i386-netinst.iso Debian Etch 4.0]

Worked. Kernel 2.6.18-4-686. Sotware RAID during install on /, /home and swap. Network card supported natively. VESA driver only for xorg.

ML150 G3

SATA

amd64 (2007.09.14)

Worked with hardware RAID1.

ML310 G2

SATA

[http://cdimage.debian.org/debian-cd/4.0_r0/i386/iso-cd/debian-40r0-i386-netinst.iso Debian Etch 4.0]

worked

ML310 G3

+smartarray 641

[http://cdimage.debian.org/cdimage/etch_di_rc1/i386/iso-cd/debian-testing-i386-netinst.iso etch rc1/i386]

worked

Onboard SATA

[http://cdimage.debian.org/cdimage/etch_di_rc1/i386/iso-cd/debian-testing-i386-netinst.iso 20070208 daily]

worked

ML310 G5

SATA

[http://cdimage.debian.org/debian-cd/4.0_r0/i386/iso-cd/debian-40r0-i386-netinst.iso Debian Etch 4.0]

worked. Integrated RAID Controler is ?SataRaid and at this time HP does not provide software RAID drivers. You must use ["SoftwareRAID"].

ML320 G4

ML330 G3

SCSI/SmartArray 641

[http://cdimage.debian.org/debian-cd/4.0_r0/i386/iso-cd/debian-40r0-i386-netinst.iso etch4.0/i386]

default installation worked just fine (used GRUB and cciss for hardware RAID-1)

ML350 G5

SAS/HP Smart array E200i

[http://cdimage.debian.org/debian-cd/4.0_r1/amd64/iso-dvd/debian-40r1-amd64-DVD-1.iso etch4.0/amd64]

worked

ML370 G1

SCSI/SmartArray

Worked, use Alien to install HPASM

ML370 G3

SCSI/SmartArray

[http://cdimage.debian.org/cdimage/etch_di_rc2/i386/iso-cd/ netinst RC2 20070317]

[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=415963 #415963]

Worked, besides some general D-I issues that have nothing to do with the hardware

ML370 G5

ML570 G4

ML110 G5

[http://cdimage.debian.org/debian-cd/4.0_r3/amd64/iso-cd/debian-40r3-amd64-netinst.iso etch40r3/amd64 (netinst)]

Worked except network card. You can find working compiled tg3 kernel module and source code [http://demir.web.tr/tg3.tar.gz here].

Sarge

BL20pG3

SCSI

[http://cdimage.debian.org/debian-cd/3.1_r0a/i386/iso-cd/debian-31r0a-i386-netinst.iso 31r0a/i386]

GRUB fails under linux26, use LILO

[http://cdimage.debian.org/cdimage/unofficial/amd64-3.1_r0/iso-cd/debian-31r0a-amd64-netinst.iso 31r0a/amd64]

GRUB and LILO fail

[#hpde HPDE] 20060905/i386

(./)

[#hpde HPDE] 20060815/amd64

(./)

BL25pG1

SCSI

[http://cdimage.debian.org/debian-cd/3.1_r0a/i386/iso-cd/debian-31r0a-i386-netinst.iso 31r0a/i386]

GRUB fails under linux26, use LILO

[http://cdimage.debian.org/cdimage/unofficial/amd64-3.1_r0/iso-cd/debian-31r0a-amd64-netinst.iso 31r0a/amd64]

GRUB and LILO fail

[#hpde HPDE] 20060905/i386

(./)

[#hpde HPDE] 20060815/amd64

(./)

BL460c

SCSI

[http://cdimage.debian.org/debian-cd/3.1_r0a/i386/iso-cd/debian-31r0a-i386-netinst.iso 31r0a/i386]

Missing storage/network drivers

[http://cdimage.debian.org/cdimage/unofficial/amd64-3.1_r0/iso-cd/debian-31r0a-amd64-netinst.iso 31r0a/amd64]

Missing storage/network drivers

[#hpde HPDE] 20061023/i386

(./)

[#hpde HPDE] 20061023/amd64

(./)

DL320G4

SATA

[http://cdimage.debian.org/debian-cd/3.1_r0a/i386/iso-cd/debian-31r0a-i386-netinst.iso 31r0a/i386]

Missing SATA driver (ahci) - NIC driver too old (tg3)

[http://cdimage.debian.org/cdimage/unofficial/amd64-3.1_r0/iso-cd/debian-31r0a-amd64-netinst.iso 31r0a/amd64]

[#hpde HPDE] 20060905/i386

[#hpde HPDE] 20060815/amd64

DL360G4

SCSI

[http://cdimage.debian.org/debian-cd/3.1_r0a/i386/iso-cd/debian-31r0a-i386-netinst.iso 31r0a/i386]

GRUB fails under linux26, use LILO

[http://cdimage.debian.org/cdimage/unofficial/amd64-3.1_r0/iso-cd/debian-31r0a-amd64-netinst.iso 31r0a/amd64]

GRUB and LILO fail

[#hpde HPDE] 20060905/i386

(./)

[#hpde HPDE] 20060815/amd64

(./)

DL380G1

SCSI

[http://cdimage.debian.org/debian-cd/3.1_r0a/i386/iso-cd/debian-31r0a-i386-netinst.iso 31r0a/i386]

(./)

DL380 G2

SCSI

[http://cdimage.debian.org/debian-cd/3.1_r4/i386/iso-cd/debian-31r4-i386-netinst.iso 31r4/i386]

(./) Initially GRUB seems to fail but can work. See notes below.

DL380G4

SCSI

[http://cdimage.debian.org/debian-cd/3.1_r0a/i386/iso-cd/debian-31r0a-i386-netinst.iso 31r0a/i386]

GRUB fails under linux26, use LILO

[http://cdimage.debian.org/cdimage/unofficial/amd64-3.1_r0/iso-cd/debian-31r0a-amd64-netinst.iso 31r0a/amd64]

GRUB and LILO fail

[#hpde HPDE] 20061106/i386

(./)

[#hpde HPDE] 20061106/amd64

(./)

DL380G5

SAS

[http://cdimage.debian.org/debian-cd/3.1_r0a/i386/iso-cd/debian-31r0a-i386-netinst.iso 31r0a/i386]

cciss driver too old, missing bnx2 driver for onboard nic

[http://cdimage.debian.org/cdimage/unofficial/amd64-3.1_r0/iso-cd/debian-31r0a-amd64-netinst.iso 31r0a/amd64]

[#hpde HPDE] 20061106/i386

(./)

[#hpde HPDE] 20061106/amd64

(./)

DL580G4

SCSI

[http://cdimage.debian.org/debian-cd/3.1_r0a/i386/iso-cd/debian-31r0a-i386-netinst.iso 31r0a/i386]

cciss driver too old, missing bnx2 driver for onboard nic

[http://cdimage.debian.org/cdimage/unofficial/amd64-3.1_r0/iso-cd/debian-31r0a-amd64-netinst.iso 31r0a/amd64]

[#hpde HPDE] 20061027/i386

(./)

[#hpde HPDE] 20061023/amd64

need to drop to shell to load cciss driver

ML110 G4

SATA

[http://amd64.debian.net/debian/dists/sarge/main/installer-amd64/current/images/ 3.1r4/amd64]

kernel panic while initial boot (...seems normal to me, all ML110 G4 are intel based)

ML310 G3

SCSI

[http://cdimage.debian.org/debian-cd/3.1_r0a/i386/iso-cd/debian-31r0a-i386-netinst.iso 31r0a/i386]

[http://cdimage.debian.org/cdimage/unofficial/amd64-3.1_r0/iso-cd/debian-31r0a-amd64-netinst.iso 31r0a/amd64]

[#hpde HPDE] 20070111/i386

(./)

[#hpde HPDE] 20061130/amd64

SATA

[http://cdimage.debian.org/debian-cd/3.1_r0a/i386/iso-cd/debian-31r0a-i386-netinst.iso 31r0a/i386]

Needs newer ata_piix driver

[http://cdimage.debian.org/cdimage/unofficial/amd64-3.1_r0/iso-cd/debian-31r0a-amd64-netinst.iso 31r0a/amd64]

[#hpde HPDE] 20070111/i386

[#hpde HPDE] 20061130/amd64

ML115 G5

SATA2

[http://cdimage.debian.org/cdimage/archive/4.0_r4/amd64/jigdo-cd/debian-40r4-amd64-CD-1.jigdo CD1 4.0_r4 Built with jigdo ]

(./)

?Anchor(hpde)

HPDE Builds

Contact DannFrazier to obtain an HPDE installer build

?Anchor(daily)

Daily Builds

Daily builds are available from the [http://www.us.debian.org/devel/debian-installer/ d-i devel page]

Known Issues

Virtual Media Disconnect crashes kernel

Kernel crashes have been observed when ejecting Virtual CD-ROM media is ejected, even when the media is umounted. The suggested workaround is to shutdown the OS before ejecting the Virtual CD-ROM. Observed on an iLO 2 system running kernel-image-2.6.8-12-amd64-generic (2.6.8-16sarge5hpde1).

Remote Serial Console hangs

The boot sequence has been observed to hang when Linux is configured to use the Remote Serial Console. Sending data to the serial console (e.g., pressing enter) will allow the console output to proceed. Observed on an iLO 2 system running kernel-image-2.6.8-12-amd64-generic (2.6.8-16sarge5hpde1).

Panic loading cciss driver

The em64t-p4 flavor kernel has been observed to panic when attempting to load the cciss driver:

 SCSI subsystem initialized
 HP CISS Driver (v 2.6.10)
 cciss: using DAC cycles
 ACPI: PCI interrupt 0000:06:00.0[A] -> GSI 16 (level, low) -> IRQ 16
 cciss cciss0: SendCmd Invalid command list address returned! (2)
 ciss cciss0: SendCmd Timeout out, No command list address returned!
 cciss: unable to determine firmware version of controller
 cciss cciss0: SendCmd Invalid command list address returned! (2)
 cciss cciss0: SendCmd Timeout out, No command list address returned!
 cciss: report logical volume command failed
 Using anticipatory io scheduler
 pivot_root: No such file or direKernel panic: Attempted to kill init!
 ctory

If you experience this problem, it is recommended to use the amd64-generic kernel instead.

Grub fails to install

Two different issues have been observed to cause this problem:

  • The Debian 2.6.8 kernel has a [http://dannf.org/bloggf/tech/cciss-grub-real-fix.html bug] in the block layer that causes certain ioctls to fail. The HPDE installer includes the fix for this bug. Debian 2.4 kernels do not seem to be affected.

  • Grub may also fail if the partition that holds /boot extends past the first 512MB. You can identify this situatin by choosing "Execute a Shell" in the main menu and running 'cat /target/tmp/grub*'. If you see the message Error 18: Selected cylinder exceeds maximum supported by BIOS, try creating a separate /boot partition that resides within the first 512MB of your disk. This has only been observed with the i386 installer.

  • Debian-installer gets an error during GRUB install. Using grub manually yields:

grub> root (hd0,0)
 Filesystem type is ext2fs, partition type 0x83
grub> setup (hd0)
 Checking if "/boot/grub/stage1" exists... no
 Checking if "/grub/stage1" exists... no
Error 15: File not found
  • Mounting this partition showed that the grub files had been copied to the appropriate places (/boot/grub/stage1, etc.). I tried using the 'install' command directly and used tab completion to find the stage1 image by starting out with '(hd0,0)/' and hitting tab. Doing so only displayed '(hd0,0)/lost+found/'. It seems that there was caching going on somewhere such that the RAID controller drivers were reading the files (so Linux could see them) but grub couldn't see them yet. I rebooted and started the setup over again making sure to leave the /boot filesystem intact and the partitioning intact. Having done so, the GRUB Install portion of setup was successful.

debootstrap fails

There has been a report of a "debootstrap error" message while installing a ?ProLiant with a burned netinst ISO. This is believed to be caused by an issue with reading the burned media. Installing using iLO virtual media, or by [http://www.debian.org/releases/stable/i386/ch04s06.html.en netbooting the installer].

AMD system doesn't detect NIC/Smart Array controller or panics with "PCI-DMA: high address but no IOMMU"

Try passing pci=nommconf as described [http://h18004.www1.hp.com/products/servers/linux/k8-notes.html here].

Automatic partitioning detects disk, but fails to partition

The guided partitioning option "use entire disk" in the sarge installer may fail on very large logical disks (>1 TB). It is still possible to use the entire disk, but you will have to partition the disk manually instead of using the guided option. See [http://bugs.debian.org/412624 #412624] for details.

Incorrect cache size in /proc/cpuinfo

In sarge, /proc/cpuinfo is known to incorrectly display 0KB cachesize for with certain systems using Xeon CPUs. The output is correct in etch.

Debian 4.0 ('etch') installs 486 kernel on AMD system, only sees 1 CPU

If you install etch for i386 using the CD 1 of the full CD set, it will be unable to find the AMD-optimized kernel and will fallback to installing the 486 kernel. This is because CD 1 does not include the k7 kernel, which is optimized for AMD systems and the 486 kernel does not provide SMP support. This is Debian Bug [http://bugs.debian.org/417051 417051].

For new installs, you can get around this by either installing with the netinst ISO (requires install-time access to a Debian mirror) or by using DVD 1, which contains the k7 kernel.

If you've already installed, you can install the k7 kernel simply by running:

  • aptitude install linux-image-2.6-k7

You will need to reboot to begin running this kernel.

Debian 4.0 ('etch') does not support more than 16 LUNs on a Smart Array Controller

If you configure more than 16 logical drives on a Smart Array controller, it will only see the first 16. This is due to a hardcoded limit in the cciss driver.