GNOME transitions

GNOME 3.6

dconf

libdconf0 -> libdconf1

cheese

libcheese3 -> libcheese7, libcheese-gtk21 -> libcheese-gtk23.

evolution-data-server

(lots)

gnome-desktop3

libgnome-desktop-3-2 -> libgnome-desktop-3-4.

Can be co-installed without problems, by relaxing the gnome-desktop3-data dependency.

gdm3 + gnome-shell

Not a library, but gdm3 and gnome-shell need to be upgraded to 3.6 together.

Transitions that must happen first include gnome-bluetooth, gnome-desktop3, evolution-data-server.

gnome-bluetooth

libgnome-bluetooth10 -> libgnome-bluetooth11

cogl

libcogl9 -> libcogl11

Seems to be largely orthogonal to any other transitions? Most things linking cogl do so indirectly.

GNOME 3.8

stricter rules for GInterfaces

GLib >= 2.35.2 will break pygobject < 3.7.2. http://blogs.gnome.org/desrt/2012/11/05/a-warning-about-glib/