Differences between revisions 6 and 9 (spanning 3 versions)
Revision 6 as of 2015-11-27 18:51:46
Size: 2898
Editor: MichaelPaoli
Comment: English/typo correction
Revision 9 as of 2019-07-05 21:25:35
Size: 2831
Editor: ?Yvan Masson
Comment: remove useless colon
Deletions are marked like this. Additions are marked like this.
Line 6: Line 6:
Freshplayerplugin allow [[Iceweasel]] to use the [[Chromium]] flash plug-in: [[PepperFlashPlayer|pepperflashplugin-nonfree]]. Freshplayerplugin allows [[Firefox]] to use the [[Chromium]] flash plug-in: [[PepperFlashPlayer|pepperflashplugin-nonfree]].
Line 10: Line 10:
You can know more about your flash version used by Iceweasel on this page: http://www.adobe.com/software/flash/about/ You can know more about your flash version used by Firefox on this page: http://www.adobe.com/software/flash/about/
Line 12: Line 12:
= Deploy Freshplayerplugin = = Installing Freshplayerplugin =
Line 14: Line 14:
Freshplayerplugin is now in the jessie-backports repositories and those who are more recent. You just need to install the package {{{browser-plugin-freshplayer-pepperflash}}} to enjoy it. Freshplayerplugin is in the jessie-backports repository and newers. You just need to install the package {{{browser-plugin-freshplayer-pepperflash}}} to enjoy it.
Line 21: Line 21:
<!> Some libraries needed are missing in Wheezy, this method will work only work for Jessie. <!> <!> Some libraries needed are missing in Wheezy, this method will only work for Jessie. <!>
Line 24: Line 24:
First, remove all the other flash plug-in to avoid conflict, then install the flash plug-in for Chromium : [[PepperFlashPlayer/Installing|here]]. First, remove all the other flash plug-in to avoid conflict, then install the flash plug-in for Chromium: [[PepperFlashPlayer/Installing|here]].
Line 32: Line 32:
Install the required dependences for the compilation: Install the required dependencies for the compilation:
Line 38: Line 38:
As the project is still under development, this list can change. That can evolve with the needs.  As the project is still under development, this list can evolve.
Line 60: Line 60:
Restart Iceweasel for taking the change into account, and check that is working with the test here : http://www.adobe.com/software/flash/about/ Restart Firefox for taking the change into account, and check that is working with the test here : http://www.adobe.com/software/flash/about/
Line 63: Line 63:
In our case, the library {{{libfreshwrapper-pepperflash.so}}} make a link with the plug-in{{{pepperflashplugin-nonfree}}}. You just need to update the Chromium plug-in to enjoy the latest version of flash from Iceweasel: see [[PepperFlashPlayer/Installing|here]]. In our case, the library {{{libfreshwrapper-pepperflash.so}}} makes a link with the plug-in {{{pepperflashplugin-nonfree}}}. You just need to update the Chromium plug-in to enjoy the latest version of flash from Firefox: see [[PepperFlashPlayer/Installing|here]].
Line 68: Line 68:
= See Also : = = See Also =

Translation(s): English - Français


Freshplayerplugin allows Firefox to use the Chromium flash plug-in: pepperflashplugin-nonfree.

You can know more about your flash version used by Firefox on this page: http://www.adobe.com/software/flash/about/

Installing Freshplayerplugin

Freshplayerplugin is in the jessie-backports repository and newers. You just need to install the package browser-plugin-freshplayer-pepperflash to enjoy it.

apt install browser-plugin-freshplayer-pepperflash

Compiling Freshplayerplugin

<!> Some libraries needed are missing in Wheezy, this method will only work for Jessie. <!>

Requirement :

First, remove all the other flash plug-in to avoid conflict, then install the flash plug-in for Chromium: here.

Compiling Freshplayerplugin for Jessie

Dependences

Make sure that you have access to the sources repository in order to start the compilation : see here

Install the required dependencies for the compilation:

apt-get install cmake gcc g++ git pkg-config ragel libasound2-dev libssl-dev libglib2.0-dev libconfig-dev libpango1.0-dev libgl1-mesa-dev libevent-dev libgtk2.0-dev libxrandr-dev libxrender-dev libxcursor-dev libv4l-dev libgles2-mesa-dev libavcodec-dev libva-dev libvdpau-dev libdrm-dev libpulse-dev

As the project is still under development, this list can evolve.

Compilation

Download and compile the source code in order to obtain the file: libfreshwrapper-pepperflash.so.

cd
git clone https://github.com/i-rinat/freshplayerplugin.git
cd freshplayerplugin
mkdir build
cd build
cmake ..
make

Deploy the library

cp libfreshwrapper-pepperflash.so /usr/lib/mozilla/plugins/

Restart Firefox for taking the change into account, and check that is working with the test here : http://www.adobe.com/software/flash/about/

Update the flash plugin

In our case, the library libfreshwrapper-pepperflash.so makes a link with the plug-in pepperflashplugin-nonfree. You just need to update the Chromium plug-in to enjoy the latest version of flash from Firefox: see here.

Depending on the development of the project Freshplayerplugin you can, optionally, update libfreshwrapper-pepperflash.so by restarting the compilation above.

See Also