Differences between revisions 79 and 80
Revision 79 as of 2006-08-01 19:36:01
Size: 8755
Comment: More cleanup of the list; many packages were fixed by their maintainers
Revision 80 as of 2006-08-01 19:47:24
Size: 8373
Comment:
Deletions are marked like this. Additions are marked like this.
Line 291: Line 291:
 * mldonkey-gui
Line 293: Line 292:
 * mlterm
Line 297: Line 295:
 * mozilla-thunderbird
Line 302: Line 299:
 * notify-daemon
Line 305: Line 301:
 * nzb
Line 309: Line 304:
 * okle - QA
Line 311: Line 305:
 * openbox
Line 313: Line 306:
 * packagesearch
Line 316: Line 308:
 * pia
Line 324: Line 315:
 * python2.1-gdchart2
 * python2.2-gdchart2
 * python2.3-gdchart2
 * python2.3-gnome2-extras
 * python2.4-gdchart2
 * python2.4-gnome2-extras
 * python-gnome2-extras
Line 339: Line 325:
 * rosegarden4
Line 342: Line 327:
 * rxvt-unicode-lite
 * rxvt-unicode-ml
 * sawfish
Line 350: Line 332:
 * sim
 * siptoolbox
Line 363: Line 343:
 * totem-gstreamer
 * totem-xine

This page coordinates the efforts to transition to the new freetype ABI and API introduced in 2.1.10-1.

The following is a list of packages which depend on libfreetype6, but do not build-depend on it. This should be avoided, see ?SteveLangasek's [http://lists.debian.org/debian-devel-announce/2005/11/msg00016.html email] on the matter for more background, and information on how to help fix the issues. (The same issues arise with dependencies on other libraries, such as libaudio2; please try to remove as many bogus library dependencies as you can at once.)

If you are working on a package, please claim it adding your name at the end of the line, in parenthesis. When a fix is ACCEPTed in the archive, please mark it with [DONE]. (Update 2006-08-01: to make this more readable, just remove it from the list!)

If you can help analyse what needs to be done for each package, please add a note next to the package name with indications so others know what to do more easily.

Bugs filed for this transition should be [http://lists.debian.org/debian-devel-announce/2005/09/msg00002.html usertagged]. Tag: extradeps-libfreetype6, user: debian-release@lists.debian.org. The list of such bugs can be accessed via http://people.debian.org/~adeodato/release-usertag/extradeps-libfreetype6.

Useful things

  • [http://people.debian.org/~keybuk/libtool-updating.html libtool updating HOWTO]

    • find neccessary versions in one command:
      • find . -name ltmain.sh -print0 | xargs -0 grep -H ^VERSION= && head -1 Makefile.in && grep Generated configure | head -1

    • Update libtoolage with one command:
      • libtoolize --copy --force && aclocal-VERSION && autoconf

    • find mentions of libtool in the source
      • rgrep -il libtool .
  • There are cases when relibtoolizing will not help, e.g. if a package uses libtool convenience libraries (non-empty noinst_LTLIBRARIES in some Makefile.am), since libtool is not able to prune unneeded libraries for them. ?KurtRoeckx is working on a patch to address this.

  • All the packages maintained by the Debian Qt/KDE Maintainers are already relibtoolized, and those that appear in the list below (marked "KDE") do suffer the above mentioned bug about convenience libs. The maintainers are aware of this, and are waiting on Kurt's patch.

Package List

  • abiword - false positive (missing build-dep) - reported, no bug number yet
  • abiword-gnome - false positive (missing build-dep)
  • abiword-plugins - affected, but built from a source package that needs rebuilt anyway
  • abiword-plugins-gnome - affected, but built from a source package that needs rebuilt anyway
  • advi - false positive, ocaml only supports static libs
  • amaya - false positive (missing build-dep)
  • apollon - reported, no bug number yet
  • ark - KDE
  • arson
  • asc blocked by [http://bugs.debian.org/344989 #344989]

  • avifile-utils [http://bugs.debian.org/349463 #349463]

  • bbpager
  • beep-media-player
  • bibletime - insane KDE/libtools interaction; package uses .a convenience libs, which triggers libtool recursion, changing it to .la's gives undefined references instead :(

  • conglomerate
  • conky
  • creox
  • cronosii
  • csound
  • dbus-1-utils - reported, no bug number yet
  • digikam - KDE
  • digikamimageplugins - KDE
  • dillo
  • dopewars
  • drip
  • drivel
  • droidbattles
  • dvdauthor
  • dx
  • easytag
  • eiciel
  • eterm -- uses automake1.7; trivial re-libtoolization repaired the dependencies -- fix not yet in archive
  • ettercap-gtk
  • evince
  • evolution-exchange
  • exult-studio
  • facturalux
  • fbdesk
  • fcitx
  • fluxbox
  • freetype2-demos - false positive, libfreetype source package (hah)
  • gcc-snapshot
  • gcolor2
  • gcompris
  • gfax
  • gkrellm-hdplop
  • glade-gnome
  • gnome-control-center
  • gnome-keyring
  • gnome-media
  • gnome-netstatus-applet
  • gnome-pilot
  • gnomesword
  • gnucash
  • gnuplot-nox
  • gpdf
  • gphotocoll
  • gpredict
  • gpsd-clients
  • granule
  • grig
  • grip -- bug filed, number not yet known
  • gtk2.0-examples - false positive (missing build-dep)
  • gtkhtml
  • gtklookat
  • guarddog
  • guidedog
  • guikachu
  • guikachu2rcp
  • gwaterfall
  • hotswap-gui
  • hsetroot
  • icewm
  • icewm-gnome-support
  • idesk
  • inkscape
  • k3b
  • kaddressbook - KDE
  • kaffeine
  • kaffeine-gstreamer
  • kaffeine-xine
  • kalarm - KDE
  • kalgebra
  • kaptain
  • kaquarium
  • karamba
  • karbon - KDE
  • karm
  • kate - KDE
  • kazehakase
  • kbabel - KDE
  • kbarcode
  • kbattleship - KDE
  • kbiff
  • kcheckgmail
  • kchmviewer
  • kcontrol - KDE
  • kcpuload
  • kdebase-bin - KDE
  • kdebluetooth
  • kdebluetooth-irmcsync
  • kdegraphics-kfile-plugins - KDE
  • kdelibs-bin - KDE
  • kdelirc - KDE
  • kdepim-kio-plugins - KDE
  • kdepim-kresources - KDE
  • kdesktop - KDE
  • kdevelop3
  • kdevelop3-plugins
  • kdiff3
  • kdirstat
  • kdvi
  • keduca - KDE
  • kexi
  • kexi-mysql-driver
  • kexi-postgresql-driver
  • kfish
  • kflog
  • kfocus
  • kfouleggs - KDE
  • kghostview - KDE
  • kguitar
  • kicker - KDE
  • kig - KDE
  • kile
  • kimdaba
  • kino
  • kiosktool
  • kipi-plugins
  • kismet
  • kitty
  • kkbswitch
  • klibido
  • klinkstatus
  • klipper - KDE
  • klog
  • klogic
  • kmail - KDE
  • kmatplot
  • kmenuedit - KDE
  • kmess
  • kmldonkey
  • kmobiletools
  • kmrml - KDE
  • kmyfirewall
  • kmymoney2
  • knapster2
  • knetdockapp
  • knetfilter
  • knetload
  • knewsticker - KDE
  • knights
  • knoda
  • knutclient
  • koffice-libs - KDE
  • komba2
  • kommander
  • kommando
  • kompare - KDE
  • kompose
  • konqueror - KDE
  • konserve
  • konversation
  • kopete - KDE
  • korganizer - KDE
  • kover
  • kpdf - KDE
  • kpovmodeler - KDE
  • kpowersave
  • kprof
  • kpsk
  • krdc - KDE
  • krec - KDE
  • krename - Isaac Clerencia
  • krfb - KDE
  • krita - KDE
  • krusader
  • kshutdown
  • ksirtet - KDE
  • ksmserver - KDE
  • ksociograma
  • ksocrat - QA
  • ksplash - KDE
  • ksudoku
  • ksvg - KDE
  • ksysguard - KDE
  • ktechlab
  • ktimetrace
  • ktrack
  • kuake
  • kvdr
  • kvirc
  • kwavecontrol
  • kwin - KDE
  • kwin-baghira
  • kwin-style-powder
  • kwin-style-suse2
  • kwirelessmonitor
  • kword - KDE
  • kxdocker
  • kxstitch
  • labplot
  • libaqbanking-ofx0
  • libaqdtaus2
  • libaqgeldkarte0
  • libaqhbci8
  • libavahi-qt3-1
  • libavifile-0.7c2 [http://bugs.debian.org/349463 #349463]

  • libcairo-ocaml
  • libdx4
  • libfox1.2c2
  • libfox1.4
  • libfreetype6-dev - false positive, freetype source package (hah)
  • libgal23
  • libgdchart-gd1-noxpm
  • libgdchart-gd1-xpm
  • libgdchart-gd2-noxpm
  • libgdchart-gd2-noxpm-dev
  • libgdchart-gd2-xpm
  • libgdchart-gd2-xpm-dev
  • libgnomeprint2.2-0
  • libgnome-print-perl
  • libgtk2.0-bin - false positive (missing build-dep)
  • libgtk+2.0-directfb0
  • libgtkhtml1.1-3
  • libhk-kdeclasses7
  • libimage-imlib2-perl
  • libimlib2-ruby
  • libjmagick6-jni
  • libk3b2
  • libkcal2b - KDE
  • libkdepim1a
  • libkjsembed1 - KDE
  • libkpimidentities1 - KDE
  • libksieve0 - KDE
  • libmatchbox1
  • libopenscenegraph1c2
  • libpcmanx-core0
  • libplplot9
  • libplplot-dev
  • libpoppler0c2
  • libpoppler0c2-glib
  • libpoppler0c2-qt
  • libqt0-ruby1.8 - KDE
  • libqt-perl
  • librmagick-ruby1.8
  • librsvg2-2
  • libsilgraphite-2.0
  • libxsharp0
  • lilo-config - KDE
  • lyx-qt
  • mail-notification
  • mergeant
  • mgp
  • mldonkey-server
  • mlterm-tools
  • motv
  • mozilla-plugin-pcmanx
  • muse
  • mysql-navigator - QA
  • networkstatus - KDE
  • neverball
  • ntop
  • nut-cgi
  • obconf
  • octave-plplot
  • octplot
  • oooqs-kde
  • orage
  • pcmanx-gtk2
  • php4-imagick
  • picwiz
  • plplot9-driver-gd
  • plplot9-driver-xwin
  • plplot-tcl
  • potracegui
  • prestimel
  • pypanel
  • python-gnome2-extras
  • python-libavg
  • qalculate-gtk
  • qalculate-kde
  • qgo
  • qlo10k1
  • qsstv
  • quanta - KDE
  • rekall
  • rhythmbox
  • rss-glx
  • rxvt-unicode
  • scim
  • score-reading-trainer
  • scribus
  • scrot
  • showimg
  • skippy
  • smb4k
  • swscanner
  • sylpheed-claws-gtk2-trayicon
  • synce-kde
  • taskjuggler
  • tclmagick
  • telak
  • terraform
  • tetex-bin
  • thunar
  • verbiste-gnome
  • wmhdplop
  • wv
  • xastir
  • xfce4-mixer
  • xfmedia
  • xfwm4
  • xsidplay
  • yacas-proteus
  • yank