[:DebianLenny:Debian Lenny] > Etch to Lenny Upgrade


Upgrading Debian GNU/Linux from Etch (4.0) to Lenny (5.0)

Release Notes

First you should read the Lenny release notes (this link is for i386): [http://www.debian.org/releases/stable/i386/release-notes/] - this has exhaustive and official documentation on how to upgrade and the change log. For most users, this quick guide will suffice. If you are on a production system, you should probably read the official documentation instead of this.

Sources

You should edit your {{{/etc/apt/sources.list }}} and replace any instance of etch with lenny. Here's an example sources.list:

#Main
deb http://ftp.us.debian.org/debian/ lenny main contrib non-free
deb-src http://ftp.us.debian.org/debian/ lenny main contrib non-free

#Updates
deb http://security.debian.org/ lenny/updates main contrib non-free
deb-src http://security.debian.org/ lenny/updates main contrib non-free

testing

Note that some of you may have been on testing which would have been lenny while it was in development. If you have such a system and you upgraded, you are now on testing for squeeze, or lenny +1.

stable

If in your sources.list you had stable then when you upgrade you will move to the stable distribution, or lenny. Here is the sources.list that is distributed with Lenny (for i386), in case you need a reference:

Upgrading

Run:

apt-get update
apt-get dist-upgrade

Once that process is finished, you will be running Lenny.

Notes on Backports

[:Backports:Backports.org] is a semi-official repository provided by Debian Developers, which provides newer packages for the stable release, based on a rebuild of the package from the "testing" archive.

The backports.org repository contains packages from testing, but with reduced version numbers, therefore the upgrade path from etch-backports to lenny is saved. However, there are a few backports only which are made from unstable (security updates and the following exceptions: firefox, kernel, openoffice.org, xorg).

If you do not use one of these exceptions, you can safely upgrade to lenny. If you use one of these exceptions, set the pin-priority (see man apt_preferences) temporarily to 1001 for all packages from etch, and you should be able to do a safe dist-upgrade too.

For example, the trac package in backports.org has version

0.11.1-2~bpo40+1

and in lenny

0.11.1-2.1

As 0.11.1-2~bpo40+1 < 0.11.1-2.1 (apt considers ~ lower), the backports package will be replaced by the lenny package when you upgrate to lenny.

If you use backports, but does not upgrade to Lenny immediately after Lenny is released, you should disable backports.org entries in your sources.list, if you don't want to get packages from Squeeze. This can happen because backports are built based on testing, and testing will change from lenny to squeeze as soon as Lenny is released. This issue is discussed in [http://lists.debian.org/debian-isp/2008/09/msg00046.html this thread] on the debian-isp mailing list. TBD: confirm or infirm this from backports.org

This behaviour has been confirmed by the backports team in this[http://lists.backports.org/lurker-bpo/message/20080930.090902.0f29d785.en.html mail].

License


CategoryPermalink