Frequently Asked Questions

Embedded Debian

Where do I download the Emdebian distribution?

There are two distributions, Emdebian Grip which is standard Debian binaries/packages merely repackaged with some bloat removed. Available for all debian architectures. Emdebian Crush is a much smaller busybox-based distribution for arm only. At this stage it is fairly experimental, but it does work.

Both Grip and Crush can be further optimised for static configurations by using Baked.


There are two mirrors currently, carrying the Emdebian Grip, Emdebian Crush and toolchain repositories.

deb wheezy-grip main

deb wheezy-grip main

deb sid-grip main

deb sid-grip main

Using Emdebian Grip

Emdebian Grip 2.0 (based on Debian GNU/Linux 6.0 "Squeeze") uses components but this caused problems and has been dropped for subsequent versions.

Emdebian Grip is also due to be integrated into Debian and the codenames and suites have been renamed to distinguish the Emdebian Grip ones from the existing Debian equivalents.

Suite names in Emdebian Grip

Debian suite

Emdebian Grip suite







Codenames in Emdebian Grip

Debian codename

Emdebian Grip codename







Guide to using Emdebian Grip

What do I need to build a uclibc toolchain in debian?

Slind includes uclibc support, but is largely woody-vintage.

New uclibc packages are being prepared for Debian and new -uclibc architectures are supported by dpkg. (455501)

No Essential in Emdebian

None. This is a common misconception about how Debian classifies packages as Essential. Essential exists solely to shorten the dependency lists of other packages, it does not indicate which packages are essential to the operation of a Debian or Emdebian system. In Debian, packages which are required for all basic Debian tasks are classified as Priority: requried, those which are not required but generally important are Priority: important etc. Essential only means that packages which depend on an Essential package do not (indeed should not) specify a dependency on those packages unless the package needs a specific version of that package which is higher than the version in oldstable.

In Emdebian, there is no common package set and users are free to ignore all Priority settings. Multistrap has a configuration setting to omit all Priority: required packages for this reason. Essential packages receive special handling by dpkg and apt which complicates the freedom to use only the specific packages that an Emdebian system might need, therefore Emdebian drops the Essential flag completely.

An Emdebian system can be simply a kernel and a shell or it can be a full system which has nearly all the packages commonly found on a Debian desktop. Importantly, Emdebian can offer any combination of packages within that spectrum whereas the minimal set in Debian is still a few hundred packages.

What changes do I have to do to the linux-libc-dev source package so I can build them for a uclibc-* architecture?

Sorry, all this doesn't work,yet. all of it should work with the next version of lkh, though. When bootstrapping in the phase where you have no target compiler you have to disable the tests: setting DEB_BUILD_OPTIONS=nocheck will do that. uClibc support should be in it very soon now.

Should I build my own cross toolchain - or use a prebuilt one?

That depends on what you want to do. If you want to build for a existing set of applications and libraries it is a good idea to use the toolchain they used. If you are starting from scratch you can build your own. It's not that hard, the toolchain howto on the emdebian site helps, also have a look at the README.cross in binutils and gcc-X.Y debian directory.

I was just wondering what the policy in on keeping the sid/etch packages install-able?

The idea has been (for a while) to have the common toolchains available and up to date for stable, testing and unstable, but this has proved difficult to actually do, and whilst most of the infrastructure is now there, there is still some work needed to make the system build new compilers each time debian uploads a new one, and to fix the patches when they get stale.

Are there currently any plans for cross tools in debian proper?

We have got preliminary agreement for Debian main to provide a set of cross-compilers as part of the normal packages which will cover most needs. Doing this will mean that we don't need to maintain our own parallel set.

At Debconf9 a scheme was agreed to solve the problem that autobuilders can not work with cross-dependencies. Hopefully there will be at least -arm-gnueabi cross-tools in squeeze.

Would help working on these be useful, or should I just be more patient ?

Help would be very useful. Developer time is the only thing stopping things progress faster.

Help with cross-compiling.

Some packages include documentation on cross-compiling. An important piece of information is the list of cache variables available to ./configure --cache-file. These allow you to look up each point at which ./configure fails in the buildd log at Debian for your target architecture and identify the value detected during a native build. You can then set this value in an $arch.cache file in the top level source and pass that cache file to ./configure. (It may be useful to set this file chmod 444 to prevent ./configure from altering it).

Cross-installing Debian using debootstrap

multistrap is preferred to debootstrap.


When using debootstrap for Squeeze, you will need to create some directories for dash installation:

mkdir -p /usr/share/man/man1

(This is fixed in wheezy-grip and later via grip-config.)

Example for sid-grip:

sudo apt-get install emdebian-archive-keyring
sudo debootstrap --keyring /usr/share/keyrings/emdebian-archive-keyring.gpg  sid-grip sid-grip-chroot /usr/share/debootstrap/scripts/sid

(After the EmdebianIntegration, the mirror location will change and the keyring dance will become unnecessary.)

Example for wheezy-grip:

sudo apt-get install emdebian-archive-keyring
sudo debootstrap --keyring /usr/share/keyrings/emdebian-archive-keyring.gpg  wheezy-grip wheezy-grip-chroot /usr/share/debootstrap/scripts/wheezy

There may also issues with the root password when installing a foreign architecture, before you leave the second-stage chroot, run


and set a known password for root.

How could I preconfigure debconf questions when configuring my root filesystem?

You need to feed debconf answers before installing the packages. An example using debconf-set-selections can help:

echo "packagename  name/question  type value" | debconf-set-selections
LANG=C DEBCONF_NONINTERACTIVE_SEEN=true DEBIAN_FRONTEND=noninteractive apt-get install package

Multi-Arch in Emdebian Grip

Whilst the packages converted for use in Emdebian Grip retain any Multi-Arch paths set by the same package in Debian, the emgrip processing did not preserve the Multi-Arch field in DEBIAN/control before the wheezy-grip release. This means that a system running Emdebian Grip cannot make use of Multi-Arch itself - dpkg and apt will accept the additional architecture but the packages cannot be installed. It is not expected that many devices running Emdebian Grip would need to use Multi-Arch but it can be fixed for future releases.

This behaviour was fixed after the wheezy-grip release. As packages in sid-grip receive updates from Debian, those packages will have the Multi-Arch field restored but support will be incomplete until more packages are updated.

With the rebuild of the Emdebian packages for integration into Debian, this field will be preserved, such that once jessie-grip starts to become available via Debian mirrors (rather than solely via Emdebian ones), full Multi-Arch support will be restored.

CategoryPermalink CategoryEmdebian