Differences between revisions 1 and 632 (spanning 631 versions)
Revision 1 as of 2007-10-07 12:26:06
Size: 1583
Comment:
Revision 632 as of 2020-01-16 01:29:20
Size: 6736
Comment: Qt packages built with OpenGL ES support are now available
Deletions are marked like this. Additions are marked like this.
Line 1: Line 1:
#language en
## TRANSLATORS: please note that it isn't very useful to translate the news items on this page.
## Instead, please subscribe to d-d-a and send translations to the developer mailing list for your language.
~-[[DebianWiki/EditorGuide#translation|Translation(s)]] : English - [[es/DeveloperNews|español]] - [[fr/DeveloperNews|Français]] - [[ja/DeveloperNews|日本語]]-~

<<TableOfContents()>>
Line 3: Line 10:
This wiki page collects small news that all developers should know but that are not worth a dedicated mail to debian-devel-announce. Then when we have collected 5 items, we'll send the content of this wiki page to debian-devel-announce. This wiki page collects small news that all developers should know but that are not worth a dedicated mail to debian-devel-announce. Follow the template "Example of news" and add your news below it. If there are some other items already, please sort your item in descending order of importance to the Debian development community. See [[/Help]] for more information on how to write entries. If you have any questions, please ask the [[Teams/Publicity|publicity team]] or the [[https://lists.debian.org/debian-l10n-english/|the Debian English localisation mailing-list]].
Line 5: Line 12:
=== Homepage field in debian/control === If you are able to post to debian-devel-announce (all Debian members can) and there are 5 or more items below, you might want to send out the news. To send out a new issue, you can use this [[https://salsa.debian.org/publicity-team/devnews/raw/master/generate-email|helper script]] to generate the email version of this page. After generating the mail, proof-read it, correct any spelling, formatting or grammatical errors and send out the mail. Once the mail is sent and archived, please delete the items that were sent, add a link to the archived mail in the [[#issues|Previous news]] section and mention the mail in ProjectNews.
Line 7: Line 14:
For quite some time, we used to put the URL of the upstream project in the description itself. The recommended way is now to put it in the new "Homepage" field in the source stanza of the control file. The field will be propagated in the source package and in the binary packages (and thus will end up in Sources.gz and Packages.gz). It's possible to override the Homepage field for each a specific binary package by putting a second Homepage field in the corresponding binary stanza in the control file. === Example of news ===
Line 9: Line 16:
This was implemented in dpkg 1.14.6. This is a sample news. Copy it and edit the title, content and signature... You can use [[https://www.debian.org|links]] like this. Put real news below this sample.
Line 11: Line 18:
=== Vcs-* fields in debian/control === -- Your Name
Line 13: Line 20:
If your package is managed in a VCS, you should indicate where the repository is located in the {{{Vcs-<Kind>}}} field. If the content of the repository can be browsed on the web, you should indicate the URL in the {{{Vcs-Browser}}} field. === Qt packages built with OpenGL ES support are now available ===
Line 15: Line 22:
The fields officially supported by dpkg are:
 * Vcs-Arch (arch and baz)
 * Vcs-Bzr (bazaar)
 * Vcs-Cvs
 * Vcs-Darcs
 * Vcs-Git
 * Vcs-Hg (Mercurial)
 * Vcs-Mtn (Monotone)
 * Vcs-Svn (Subversion)
Thanks to Dmitry Shachnev's work Qt packages now offer two OpenGL flavours, Desktop and ES [1].
This changes are provided by Qt GUI and Qt Quick libraries. With the help of the Release Team
the necessary packages in the archive have been rebuilt in order to pick up the changes. Desktop
and ES packages are not co-installable as they provide the same set of shared libraries. So most
packages now have an alternative dependency like
Line 25: Line 28:
Here are some examples:
{{{
Vcs-Browser: http://ikiwiki.info/cgi-bin/viewvc.cgi/trunk/?root=ikiwiki
Vcs-Svn: svn://svn.kitenet.net/ikiwiki/trunk
}}}
  libqt5gui5 (>= 5.x) | libqt5gui5-gles (>= 5.x).
Line 31: Line 30:
This was implemented in dpkg 1.14.6. Packages get such a dependency automatically if they are using ${shlibs:Depends}. More details
are available in Dmitry's blog post [1].
Line 33: Line 33:
=== Add your news here === [1] https://mitya57.me/weblog/2020/01/qt-opengl-es-packages-available.html

-- Lisandro Damián Nicanor Pérez Meyer


== Previous news ==

<<Anchor(issues)>>
[[https://lists.debian.org/debian-devel-announce/2020/01/msg00001.html|50]]
<<BR>>
[[https://lists.debian.org/debian-devel-announce/2019/08/msg00003.html|49]]
[[https://lists.debian.org/debian-devel-announce/2019/05/msg00002.html|48]]
[[https://lists.debian.org/debian-devel-announce/2019/02/msg00001.html|47]]
[[https://lists.debian.org/debian-devel-announce/2018/10/msg00002.html|46]]
[[https://lists.debian.org/debian-devel-announce/2018/02/msg00005.html|45]]
[[https://lists.debian.org/debian-devel-announce/2017/08/msg00002.html|44]]
[[https://lists.debian.org/debian-devel-announce/2016/11/msg00008.html|43]]
[[https://lists.debian.org/debian-devel-announce/2016/10/msg00004.html|42]]
[[https://lists.debian.org/debian-devel-announce/2016/06/msg00002.html|41]]
[[https://lists.debian.org/debian-devel-announce/2016/01/msg00000.html|40]]
<<BR>>
[[https://lists.debian.org/debian-devel-announce/2015/06/msg00002.html|39]]
[[https://lists.debian.org/debian-devel-announce/2015/03/msg00004.html|38]]
[[https://lists.debian.org/debian-devel-announce/2014/11/msg00015.html|37]]
[[https://lists.debian.org/debian-devel-announce/2014/07/msg00007.html|36]]
[[https://lists.debian.org/debian-devel-announce/2014/05/msg00007.html|35]]
[[https://lists.debian.org/debian-devel-announce/2014/01/msg00007.html|34]]
[[https://lists.debian.org/debian-devel-announce/2013/07/msg00001.html|33]]
[[https://lists.debian.org/debian-devel-announce/2013/04/msg00007.html|32]]
[[https://lists.debian.org/debian-devel-announce/2012/12/msg00002.html|31]]
[[https://lists.debian.org/debian-devel-announce/2012/08/msg00003.html|30]]
<<BR>>
[[https://lists.debian.org/debian-devel-announce/2012/03/msg00000.html|29]]
[[https://lists.debian.org/debian-devel-announce/2012/01/msg00005.html|28]]
[[https://lists.debian.org/debian-devel-announce/2011/12/msg00001.html|27]]
[[https://lists.debian.org/debian-devel-announce/2011/03/msg00006.html|26]]
[[https://lists.debian.org/debian-devel-announce/2011/02/msg00000.html|25]]
[[https://lists.debian.org/debian-devel-announce/2010/11/msg00002.html|24]]
[[https://lists.debian.org/debian-devel-announce/2010/08/msg00001.html|23]]
[[https://lists.debian.org/debian-devel-announce/2010/05/msg00006.html|22]]
[[https://lists.debian.org/debian-devel-announce/2010/02/msg00010.html|21]]
[[https://lists.debian.org/debian-devel-announce/2010/01/msg00005.html|20]]
<<BR>>
[[https://lists.debian.org/debian-devel-announce/2010/01/msg00001.html|19]]
[[https://lists.debian.org/debian-devel-announce/2009/10/msg00001.html|18]]
[[https://lists.debian.org/debian-devel-announce/2009/08/msg00002.html|17]]
[[https://lists.debian.org/debian-devel-announce/2009/05/msg00011.html|16]]
[[https://lists.debian.org/debian-devel-announce/2009/04/msg00012.html|15]]
[[https://lists.debian.org/debian-devel-announce/2009/03/msg00000.html|14]]
[[https://lists.debian.org/debian-devel-announce/2009/01/msg00007.html|13]]
[[https://lists.debian.org/debian-devel-announce/2008/12/msg00009.html|12]]
[[https://lists.debian.org/debian-devel-announce/2008/12/msg00001.html|11]]
[[https://lists.debian.org/debian-devel-announce/2008/09/msg00003.html|10]]
<<BR>>
[[https://lists.debian.org/debian-devel-announce/2008/07/msg00000.html|9]]
[[https://lists.debian.org/debian-devel-announce/2008/05/msg00013.html|8]]
[[https://lists.debian.org/debian-devel-announce/2008/04/msg00013.html|7]]
[[https://lists.debian.org/debian-devel-announce/2008/04/msg00006.html|6]]
[[https://lists.debian.org/debian-devel-announce/2008/03/msg00009.html|5]]
[[https://lists.debian.org/debian-devel-announce/2008/02/msg00000.html|4]]
[[https://lists.debian.org/debian-devel-announce/2007/12/msg00011.html|3]]
[[https://lists.debian.org/debian-devel-announce/2007/12/msg00007.html|2]]
[[https://lists.debian.org/debian-devel-announce/2007/11/msg00006.html|1]]

----
## This page is referenced repeatedly in debian-devel-announce emails (listed above).
CategoryPermalink

Translation(s) : English - español - Français - 日本語

News for Debian developers

This wiki page collects small news that all developers should know but that are not worth a dedicated mail to debian-devel-announce. Follow the template "Example of news" and add your news below it. If there are some other items already, please sort your item in descending order of importance to the Debian development community. See /Help for more information on how to write entries. If you have any questions, please ask the publicity team or the the Debian English localisation mailing-list.

If you are able to post to debian-devel-announce (all Debian members can) and there are 5 or more items below, you might want to send out the news. To send out a new issue, you can use this helper script to generate the email version of this page. After generating the mail, proof-read it, correct any spelling, formatting or grammatical errors and send out the mail. Once the mail is sent and archived, please delete the items that were sent, add a link to the archived mail in the Previous news section and mention the mail in ProjectNews.

Example of news

This is a sample news. Copy it and edit the title, content and signature... You can use links like this. Put real news below this sample.

-- Your Name

Qt packages built with OpenGL ES support are now available

Thanks to Dmitry Shachnev's work Qt packages now offer two OpenGL flavours, Desktop and ES [1]. This changes are provided by Qt GUI and Qt Quick libraries. With the help of the Release Team the necessary packages in the archive have been rebuilt in order to pick up the changes. Desktop and ES packages are not co-installable as they provide the same set of shared libraries. So most packages now have an alternative dependency like

  • libqt5gui5 (>= 5.x) | libqt5gui5-gles (>= 5.x).

Packages get such a dependency automatically if they are using ${shlibs:Depends}. More details are available in Dmitry's blog post [1].

[1] https://mitya57.me/weblog/2020/01/qt-opengl-es-packages-available.html

-- Lisandro Damián Nicanor Pérez Meyer

Previous news

50
49 48 47 46 45 44 43 42 41 40
39 38 37 36 35 34 33 32 31 30
29 28 27 26 25 24 23 22 21 20
19 18 17 16 15 14 13 12 11 10
9 8 7 6 5 4 3 2 1


CategoryPermalink